Advertisement:

Author Topic: TO CONNECT TO DATABASE  (Read 2690 times)

Offline babson

  • Newbie
  • *
  • Posts: 3
TO CONNECT TO DATABASE
« on: July 18, 2007, 06:58:41 AM »
I TRY TO VISIT MY WEBSITE YESTERDAY, THIS IS THE ERROR I GET,

$db_user = '*****'; $db_passwd = '******'; $db_prefix = 'nairocom_'; $db_persist = 0; $db_error_send = 1; ########## Directories/Files ########## # Note: These directories do not have to be changed unless you move things.�$boarddir = '/home/nairocom/public_html'; # The absolute path to the forum's folder. (not just '.'!) $sourcedir = '/home/nairocom/public_html/Sources'; # Path to the Sources directory. ########## Error-Catching ########## # Note: You shouldn't touch these settings. $db_last_error = 1184697937; # Make sure the paths are correct... at least try to fix them.�if (!file_exists($boarddir) && file_exists(dirname(__FILE__) . '/agreement.txt')) $boarddir = dirname(__FILE__); if (!file_exists($sourcedir) && file_exists($boarddir . '/Sources')) $sourcedir = $boarddir . '/Sources'; ?>
Warning: Cannot modify header information - headers already sent by (output started at /home/nairocom/public_html/Settings.php:49) in /home/nairocom/public_html/Sources/Subs-Auth.php on line 211

Warning: Cannot modify header information - headers already sent by (output started at /home/nairocom/public_html/Settings.php:49) in /home/nairocom/public_html/Sources/Subs-Auth.php on line 212

Warning: Cannot modify header information - headers already sent by (output started at /home/nairocom/public_html/Settings.php:49) in /home/nairocom/public_html/Sources/Subs-Auth.php on line 213
Connection Problems
Sorry, SMF was unable to connect to the database.

AND DONT KNOW WHAT TO DO AGAIN, PLS CAN SOMEONE THERE TELL ME WHAT TO DO TO HAVE ACCESS TO MY WEBSITE AGAIN? THE SITE IS hxxp:www.nairakobo.com [nonactive]. U CAN VISIT THE SITE AND SEE THE ERROR AGAIN.

THX.
« Last Edit: July 18, 2007, 07:03:29 AM by Harro »

Offline Harro

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,122
  • Gender: Male
  • I'm watching you
Re: TO CONNECT TO DATABASE
« Reply #1 on: July 18, 2007, 07:04:13 AM »
Edit that because you had your database username and password there for the whole world to see. And beleive me, you don't want that ;)

Anyway, open your settings.php file and see if there is any text before <?php or after ?>

Offline shadow82x

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,279
  • Gender: Male
    • cmblaber on LinkedIn
Re: TO CONNECT TO DATABASE
« Reply #2 on: July 19, 2007, 11:36:25 AM »
I would assume this is coming from a mod.
Colin B
Former Spammer, Customize, & Support Team Member

Offline metallica48423

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,842
  • Gender: Male
  • Professional Multislacker!
    • Zentendo
Re: TO CONNECT TO DATABASE
« Reply #3 on: July 20, 2007, 03:25:42 AM »
Shadow, sorry, but, you are wrong.  It is their Settings.php.

Babson, as harro suggested, make sure everything is between <?php and ?>.  If it is, then something may be wrong with php on your host, you will need to contact your host and ask.
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

Quote
Microsoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"

Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

Offline shadow82x

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,279
  • Gender: Male
    • cmblaber on LinkedIn
Re: TO CONNECT TO DATABASE
« Reply #4 on: July 20, 2007, 10:34:27 AM »
Shadow, sorry, but, you are wrong.  It is their Settings.php.

Babson, as harro suggested, make sure everything is between <?php and ?>.  If it is, then something may be wrong with php on your host, you will need to contact your host and ask.
The same exact thing happened to me before after I installed a mod though and the "<?php and ?>" got all messed up. I had to manually fix it. Maybe I am wrong but just saying.
« Last Edit: July 20, 2007, 10:36:27 AM by shadow82x »
Colin B
Former Spammer, Customize, & Support Team Member

Offline Harro

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,122
  • Gender: Male
  • I'm watching you
Re: TO CONNECT TO DATABASE
« Reply #5 on: July 20, 2007, 12:00:54 PM »
Mods shouldn't affect settings.php though

babjusi

  • Guest
Re: TO CONNECT TO DATABASE
« Reply #6 on: July 20, 2007, 02:18:36 PM »
Shadow, sorry, but, you are wrong.  It is their Settings.php.

Babson, as harro suggested, make sure everything is between <?php and ?>.  If it is, then something may be wrong with php on your host, you will need to contact your host and ask.
The same exact thing happened to me before after I installed a mod though and the "<?php and ?>" got all messed up. I had to manually fix it. Maybe I am wrong but just saying.

Which mod was that, shadow?

Offline shadow82x

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,279
  • Gender: Male
    • cmblaber on LinkedIn
Re: TO CONNECT TO DATABASE
« Reply #7 on: July 20, 2007, 02:29:42 PM »
It was a while ago I forgot. Now that I look at it. Its not a mod unless if it effects settings.php
Colin B
Former Spammer, Customize, & Support Team Member