• Welcome to Simple Machines Community Forum. Please login or sign up.

Redirection Boards

Started by Oldiesmann, October 18, 2004, 07:01:58 AM

Previous topic - Next topic

ekfaysal



This is happening to me when i m trying to upload in my forum
Please help
im using smf 1.1.3 with Default theme color variation

HEB XI 1

I also got the error:

6.    Execute Modification    ./Sources/Subs-Boards.php    Test failed

Installed Mods:
     Tiny Portal
     Gallery 2 Integration
     Custom Board Sort
     Repeating Calendar Events

http://baker.hebxi1.com


After going thru most of the pages on this thread, I decided to use a simple href tag in the board title, as suggested back on page 2 or so.

My situation is probably unique in that I actually USE the board I would like to redirect ... I have posts in there that another site pulls from to act as a type of blog.  So while I will need to be able to access them, I don't want the general public to do so - I want them directed to the other site.

Don't know if that is an option using the mod?  Currently I just have to remember the board ID and enter it into the address manually to access the board and posts.

feelingshehides

October 04, 2007, 12:23:56 AM #322 Last Edit: October 04, 2007, 03:25:42 AM by feelingshehides
Is there a new update to this for 1.14 ? can't seem to install the mod :( same error as above post..

Can this also work with Valid Dilber MC Theme ? it errors also.. i first tried the default theme.

BigMike

Quote from: feelingshehides on October 04, 2007, 12:23:56 AM
Is there a new update to this for 1.14 ? can't seem to install the mod

feelingshehides, I assume you are talking about version 1.1.4.

I installed this Redirection Board mod on my forum when it was version 1.1.2.

I then updated my forum to 1.1.3 and the mod still worked.

And now I just updated my forum to 1.1.4 and the mod still works.

So the mod will RUN on SMF 1.1.4, but as for the installation, I do not know about this.


Also, the reason why I came back here is because I wish to address an issue I have in my error log.

I remember a while ago I found the solution on SMF for this, but I've searched, searched, and then when I was tired of searching, I searched more and could not find exactly what I am looking for.

Oldiesmann: I am getting a Undefined index: current_board error, about 5,000 something times per day. I usually just empty out my error log once it gets to page 2,000 or so, but I order to track other errors, I really should take care of this problem.

I remember the fix was just something simple. I think SMF just needs to know that the variable "current_board" is a proper variable that is used by the system.

My searches returned a lot of threads (containing the search term "Undefined index") but they were either not answered or contained answers not pertaining to this situation.

Thanks a bunch
BigMike

Neorics

October 14, 2007, 08:54:41 AM #324 Last Edit: October 14, 2007, 11:16:46 AM by Neorics
when i was installing the redirection mod on my custom theme i dont know where to put this one cause the search is very vague.. btw i'm following the modification_1-0.xml is that the correct file?


<operation>
         <search position="after"><![CDATA[
            echo '
      </td>
   </tr>';
]]></search>
         <add><![CDATA[
            elseif ($board['is_redirect'])
            {
               if($board['redirect_count_clicks'])
               {
                  // How many redirected clicks? We have to be grammatically correct, you know ;)
                  echo ($board['redirect_clicks'] == 1 ? $txt['redirected_click'] : '<b>'. $board['redirect_clicks'] .'</b> '. $txt['redirected_clicks']);
               }
               else
               {
                  // For now, just show this filler text. I'll probably do more with this in the next version...
                  echo 'N/A';
               }
            }
]]></add>
      </operation>


i have a lot of this

echo '
      </td>
   </tr>';
[For Hire] I can help you with anything regarding Simple Machines Forum and TinyPortal  ~ My Portfolio

Johno69

I had the same problem while installing on versatility 2 theme.

I thought I had it right but kept getting template error, so gave up.

softtouch

I did not read all replies here, but are there anywhere some permissions settings related to membergroups?
What I would like to do is to redirect member without enter board permission to an url of my choice, but once they are added to a specific membergroup, they should be able to enter that board without getting redirected.
This way, I could show a message with some info about the board and why they can not enter the board etc.

Johno69

When you create a board you have the option to make it available to only certain groups.

Make a redirect board available to one group and a real board available to another group. When you change the user to the group then then see the real board and not the redirect.

NiteCloak

I'm running SMF 1.1.4 (Theme = 'Black Rain' by Crip) and thankfully I rarely get test failures when looking to install new mods.  Sadly I am getting three such errors with this mod which is a shame because I could really use it.

The results of a test install on the package file are as follows:

1.     Execute Code     RedirectPdb.php     
2.    Execute Modification    ./Sources/BoardIndex.php       Test successful
3.    Execute Modification    ./Sources/Load.php                    Test successful
4.    Execute Modification    ./Sources/ManageBoards.php    Test successful
5.    Execute Modification    ./Sources/MessageIndex.php     Test successful
6.    Execute Modification    ./Sources/Subs-Boards.php      Test failed
7.    Execute Modification    ./Themes/default/BoardIndex.template.php    Test failed
8.    Execute Modification    ./Themes/default/ManageBoards.template.php    Test successful
9.    Execute Modification    ./Themes/default/MessageIndex.template.php    Test failed
10.    Execute Modification    ./Themes/babylon/BoardIndex.template.php    Test successful
11.    Execute Modification    ./Themes/babylon/MessageIndex.template.php    Test successful
12.    Execute Modification    ./Themes/classic/BoardIndex.template.php    Test successful
13.    Execute Modification    ./Themes/classic/MessageIndex.template.php    Test successful
14.    Execute Modification    ./Themes/default/languages/Help.english.php    Test successful
15.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test successful



The mods I have installed (and there are many) are as follows:

   Mod Name     Version     
1.    SMF 1.1.2 Update Package    1.1.2
2.    PaypalDonations    1.7    [ Failed | Not Applied ]
3.    Color Bar    2.0
4.    Award Mod    1.11
5.    Integrated Chat    2.7
6.    SSI Membergroup    1.0
7.    Enhanced Calendar    1.1
8.    Custom Profile Field Mod    3.16
9.    Who Voted What?    1.1.2    
10.    Add PM Info To header (v1.1)    1.1
11.    RSS Feed Icon    1.1    
12.    Users Online Today Mod    1.4.0    
13.    Topic Ratings    1.03    
14.    Reg Bar    1.0    
15.    SMF Shoutbox    1.16
16.    mp3 Flash Player BBC Tag (XHTML Compliant)    1.0
17.    SMF 1.0.11 / 1.1.3 Update    1.1    
18.    Order News    1.0.1    
19.    Stars to Profile    1.0.1
20.    YouTube BBCode    1.3    
21.    SMF 1.0.12 / 1.1.4 / 2.0 b1.1 Update    1.0    
22.    XFire Field    1.4    
23.    Welcome Topic Mod    1.0    
24.    Advanced Visual Verification    1.2
25.    Redirection Boards    2.01    [ Failed | Not Applied ]


Any ideas?


~ ~ ~
Avatar Packs by NiteCloak:
Super Heroes : Status : Download
Sci-Fi & Fantasy Fiction : Status : Download
Military Assault Weapons : Status : Download
Ancient Symbolism : Status : Download
~~~
One good turn gets all the sheets

TrueSatan

The more mods you add the more fails you will get...

Your error is a variant on the most common error of all those reported on these pages...it tells you that another mod you have installed has already edited the file(s) in question and that you thus need to do a manual installation of this mod. Please read:

http://docs.simplemachines.org/index.php?topic=402.msg531#msg531

http://www.simplemachines.org/community/index.php?topic=34526.0

The following may also prove helpful:

http://modparser.dev.dansoftaustralia.net/

Mirror of the last link:

http://www.smfhacks.com/smf-package-parser.html

NiteCloak

That last link is bogus.  I uploaded the Board Redirect package tar by Oldiesmann and it tells me its:

Readme:
Ad Management Mod
Written by: jerm (electrohome88)
Email: electrohome88@hotmail.com
Support site: www.smfads.com

----------
This mod will display ads on various parts of your forum on the default theme in SMF Version 1.1
---------
Version 2.3 Jan 11, 2007
- New setting: Disable ads for admins
- New setting: Disable reports(one less query)
- New setting: Disable all ads
- New setting: Ability to make post ads not look like posts.
- Added the ability to display ads between categories
- Added the ability to display ads after the last post
- Added the ability to display ads under child boards
- Fixed issues about not finding functions(caused forums to crash)


So I tried a couple of other mods and it came up with the same BS.    Clearly this is some kind of scam to get SMF people with half a brain to insert ad code in to their forums.
~ ~ ~
Avatar Packs by NiteCloak:
Super Heroes : Status : Download
Sci-Fi & Fantasy Fiction : Status : Download
Military Assault Weapons : Status : Download
Ancient Symbolism : Status : Download
~~~
One good turn gets all the sheets

TrueSatan

The information I provided was not bogus!

The package parsers sometimes suffer from cache issues and so the previous...and entirely legitimate...mod sent to them can be shown instead of the one you uploaded. The ad management mod, had you bothered to check you would have found this out, is an approved SMF mod package not some ad scam:

http://custom.simplemachines.org/mods/index.php?mod=255

Please do not post in the insulting manner you have just used!

NiteCloak

Apologies if the post seemed offensive that was not my intent.  The statement of "bogus" was not implying that your post was, and by association "you", just that link! However, as far as I am concerned that link is useless.  I went back again this morning and tried again and I am getting yet another mod that I didn't input. Clearly they need to figure out a way to flush the cache serverside after each session otherwise it fails as a service unless by some miracle the mod last entered also happens to be the one you want as well.

The link above that dansofasutralia.net one just errors out each time telling me that the package-info.xml file is invalid!

Sadly because of the nature of my work, I simply don't have the time available to do the reading research and data assimilation required by the first links you provided although I strongly suspect that is where I will really find the answer I need to fix my problem.


~ ~ ~
Avatar Packs by NiteCloak:
Super Heroes : Status : Download
Sci-Fi & Fantasy Fiction : Status : Download
Military Assault Weapons : Status : Download
Ancient Symbolism : Status : Download
~~~
One good turn gets all the sheets

TrueSatan

Unfortunately server issues do happen and when the system is one that the site admin may not, personally, use on a regular basis they may not be aware of the problem. A few installations of the Package Parser have been updated recently is reponce to discussions had on the bugs forum here between Sarge and myself, one such is that on SMF Helper...that installation works properly with this mod.

http://www.smfhelper.info/forum/package.php5

Should you have a problem with that installation of the Package Parser please contact any of the admins on SMF Helper (I'm an admin there) and we will remedy any problems as quickly as possible...that said it is not a requirement for all mods to work with the Package Parser and some simply don't do so.

NiteCloak

Well thanks that one worked and parsed very nicely (based upon 1.1.4)

I decided to read through the whole thing before attempting any changes but I stopped when I got to this:


In file $sourcedir/ManageBoards.php

Find:

'permission_mode' => 'normal',





Do something with this: (position not specified)

'is_redirect' => 0,
'count_clicks' => 0,
'target' => '',
'url' => '',




I'm no code guru so what are the possibilities that someone knows "what" to do with that?
~ ~ ~
Avatar Packs by NiteCloak:
Super Heroes : Status : Download
Sci-Fi & Fantasy Fiction : Status : Download
Military Assault Weapons : Status : Download
Ancient Symbolism : Status : Download
~~~
One good turn gets all the sheets

TrueSatan

It should have, at the problem point, stated "Add after"....I'll have to look at the mod some time to try to see what made that glitch occur...haven't seen it happen previously.

SgtMic

Since the great hardware crash of 2008, can someone send me this mod? The mod so far is not able to be downloadable yet. fightinirishman2 at hotmail dot com

Thanks.
There is nothing more deadly than a US Marine and his rifle.
A close second is a US Marine and his K-BAR.
2/5 Fox Co.  (BlackHearts)
FAST Co. 5th Plt. (FIDO)


SgtMic

There is nothing more deadly than a US Marine and his rifle.
A close second is a US Marine and his K-BAR.
2/5 Fox Co.  (BlackHearts)
FAST Co. 5th Plt. (FIDO)

Pond_Hockey

Is there anyway that you can change this mod so that it redirects topics instead of the boards?

Advertisement: