• Welcome to Simple Machines Community Forum. Please login or sign up.
November 28, 2021, 06:09:21 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Redirection Boards

Started by Oldiesmann, October 18, 2004, 07:01:58 AM

Previous topic - Next topic

perplexed

Quote from: Pond_Hockey on February 09, 2008, 10:39:55 PM
Is there anyway that you can change this mod so that it redirects topics instead of the boards?

If you move topics, you can leave a redirection move notice in its place, that would achieve the same thing, I think :)

Pond_Hockey

February 10, 2008, 08:51:08 PM #341 Last Edit: February 10, 2008, 11:54:39 PM by Pond_Hockey
That didn't work. What I want is so that when you click the topic title to enter the topic it takes you to another site. Is that possible?

Pяηѕѕ LF

Bonjour,

I Have a problem with this mod in boardindex.template.php

Find This :

<td class="windowbg2">
<b><a href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b><br />


Change With This:

<td class="windowbg2"', $board['is_redirect'] && $modSettings['redirect_hide_columns'] ? ' colspan="2"' : '' , '>
<b><a href="', $board['href'], '" name="b', $board['id'], '"', ($board['is_redirect'] && $board['redirect_target'] != '') ? ' target="' . $board['redirect_target'] . '"' : '' , '>', $board['name'], '</a></b><br />



But me i have this code:

<td class="windowbg2">
',$board['viewer_text'],'<b><a href="', $board['href'], '" name="b', $board['id'], '">', $board['name'], '</a></b><br />


how i can change it ??

thanks for your help.


1.1.21 Default

denzil69

version 2.0.1
default theme

error in theme.template

ive deleted

ranKoto

hi all

i just install version 2.0.1

but i got this little 'inconvinience"..
after installing this mod, the list of my child board that usually appear in a bold text which is indicate that there is a new post in there turn into normal text ( just like it was visited )

is there anyway how to fix this ?
thanks before

EagleTrades

March 09, 2008, 01:29:38 PM #345 Last Edit: March 09, 2008, 01:32:54 PM by EagleTrades
Oldiesman,

Installed this mod.  We are using dilbermc.  The mod is working correctly except for one thing.  When you select the redirect option, then _blank to create a new window upon opening, the link works but does not open a new window.  I uninstalled, reinstalled, followed steps in the above thread and still can't get any of the redirects to open in new window.

Is there a hack that can be used to force open all in new window?  I don't want people to navigate away from the forum to another page, then have to navigate back to the forum.

Thanks in advance.  Excellent mod though.  I have been looking for this capability for a while.
Regards,

Admin
Eagle Trades Ltd.
Website: www.eagletrades.net
Email: admin@eagletrades.net

Darknico

March 12, 2008, 11:42:06 AM #346 Last Edit: March 12, 2008, 01:43:03 PM by Darknico
Quote from: NiteCloak on January 11, 2008, 10:30:06 AM
I'm no code guru so what are the possibilities that someone knows "what" to do with that?

a error in a mod package:

modification_1-1_part1

Search:
<operation>
<search postion="before"><![CDATA[
'permission_mode' => 'normal',
]]></search>
<add><![CDATA[
'is_redirect' => 0,
'count_clicks' => 0,
'target' => '',
'url' => '',
]]></add>
</operation>


Replace:
<operation>
<search position="before"><![CDATA[
'permission_mode' => 'normal',
]]></search>
<add><![CDATA[
'is_redirect' => 0,
'count_clicks' => 0,
'target' => '',
'url' => '',
]]></add>
</operation>


error:

postion --> position
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


EagleTrades

Hello,

Thank you for the reply.  Can you tell me where I need to place the hack you included in your reply?

Sorry, still new to PHP.  The good thing is that the more I hang around this forum, the better I get at it.
Regards,

Admin
Eagle Trades Ltd.
Website: www.eagletrades.net
Email: admin@eagletrades.net

Darknico

This problem

Quote from: NiteCloak on January 11, 2008, 10:30:06 AM
Well thanks that one worked and parsed very nicely (based upon 1.1.4)

I decided to read through the whole thing before attempting any changes but I stopped when I got to this:


In file $sourcedir/ManageBoards.php

Find:

'permission_mode' => 'normal',





Do something with this: (position not specified)

'is_redirect' => 0,
'count_clicks' => 0,
'target' => '',
'url' => '',




I'm no code guru so what are the possibilities that someone knows "what" to do with that?
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


EagleTrades

I aam not sure either.  But in looking at the code, I would say the following:

Code:
'target' => '',


Replace:
'target' => '_blank',


Wouldn't this force a new window on click?  I think it would.  However, I do not know much about SMF hacks either. So, maybe someone else has some input here.  Again, thank you for you help so far.
Regards,

Admin
Eagle Trades Ltd.
Website: www.eagletrades.net
Email: admin@eagletrades.net

No.Body

I get an error :(


1.  Execute Code  RedirectPdb.php 
2. Execute Modification ./Sources/BoardIndex.php Test successful
3. Execute Modification ./Sources/Load.php Test successful
4. Execute Modification ./Sources/ManageBoards.php Test successful
5. Execute Modification ./Sources/MessageIndex.php Test successful
6. Execute Modification ./Sources/Subs-Boards.php Test failed
7. Execute Modification ./Themes/default/BoardIndex.template.php Test failed
8. Execute Modification ./Themes/default/ManageBoards.template.php Test successful
9. Execute Modification ./Themes/default/MessageIndex.template.php Test failed
10. Execute Modification ./Themes/babylon/BoardIndex.template.php Skipping file
11. Execute Modification ./Themes/babylon/MessageIndex.template.php Skipping file
12. Execute Modification ./Themes/classic/BoardIndex.template.php Skipping file
13. Execute Modification ./Themes/classic/MessageIndex.template.php Skipping file
14. Execute Modification ./Themes/default/languages/Help.english.php Test successful
15. Execute Modification ./Themes/default/languages/Modifications.english.php Test successful

perplexed

use the package parser in my signature and either install the mod manually or use it to edit those files that failed :)

No.Body

Quote from: perplexed on March 13, 2008, 12:42:50 PM
use the package parser in my signature and either install the mod manually or use it to edit those files that failed :)

I got this after using the parser...


Quote
ERROR: The package-info.xml file is invalid!

Debugging Information
Error message: String could not be parsed as XML
Source: /home/sleepy1/public_html/PackageParser/index.php:155
Errors encountered while parsing XML file:

Stack Trace:
#0 /home/sleepy1/public_html/PackageParser/index.php(155): SimpleXMLElement->__construct('')
#1 /home/sleepy1/public_html/PackageParser/index.php(96): parsePackageInfoXML('/home/sleepy1/b...', 'install', 'theme')
#2 /home/sleepy1/public_html/PackageParser/index.php(782): parseArchive('/tmp/phph1K2JI', 'install', 'theme')
#3 {main}

XML File:

EagleTrades

Quote from: perplexed on March 13, 2008, 12:42:50 PM
use the package parser in my signature and either install the mod manually or use it to edit those files that failed

Thank you.  I keep forgetting to use the package parser.  It is really a an awesome tool.  I finally bookmarked it so it would be handy when needed.

Thanks again.
Regards,

Admin
Eagle Trades Ltd.
Website: www.eagletrades.net
Email: admin@eagletrades.net


Ncen

QuoteERROR: The package-info.xml file is invalid!


Debugging Information
Error message: String could not be parsed as XML
Source: /home/sleepy1/public_html/PackageParser/index.php:155
Errors encountered while parsing XML file:
Stack Trace:
#0 /home/sleepy1/public_html/PackageParser/index.php(155): SimpleXMLElement->__construct('')
#1 /home/sleepy1/public_html/PackageParser/index.php(96): parsePackageInfoXML('/home/sleepy1/b...', 'install', 'all')
#2 /home/sleepy1/public_html/PackageParser/index.php(782): parseArchive('/tmp/phppPBGwi', 'install', 'all')
#3 {main}

XML File:

That's the error i get trying to use the parser. :/

EagleTrades

March 13, 2008, 03:40:13 PM #356 Last Edit: March 13, 2008, 03:41:50 PM by EagleTrades
Hello,

I ran the package parser and got the following errors.

QuoteERROR: The package-info.xml file is invalid!

Debugging Information
Error message: String could not be parsed as XML
Source: /home/sleepy1/public_html/PackageParser/index.php:155
Errors encountered while parsing XML file:
Stack Trace:
#0 /home/sleepy1/public_html/PackageParser/index.php(155): SimpleXMLElement->__construct('')
#1 /home/sleepy1/public_html/PackageParser/index.php(96): parsePackageInfoXML('/home/sleepy1/b...', 'install', 'theme')
#2 /home/sleepy1/public_html/PackageParser/index.php(782): parseArchive('/tmp/php6j5I3B', 'install', 'theme')
#3 {main}

However, I have installed this mod regardless and the redirects are working as they should.  The only exception is that when you tell the redirect to open the link in a new window, using "target=_blank", it does not open in a new window. This is the only complaint that I really have at this point. I am not so sure that I want users navigating away from the forum without an easy way to get back to that particular topic.

Based on the above, I suspect that the problem is the paths stated in the XML file. Of course, I would like to see a correction for this as it is just one more of those things that ticks at me.  But, I guess if the redirects are working, that is what I was after anyway.
Regards,

Admin
Eagle Trades Ltd.
Website: www.eagletrades.net
Email: admin@eagletrades.net

JoshieDaMan

Quote1.     Execute Code     RedirectPdb.php     
2.    Execute Modification    ./Sources/BoardIndex.php    Test successful
3.    Execute Modification    ./Sources/Load.php    Test failed
4.    Execute Modification    ./Sources/ManageBoards.php    Test successful
5.    Execute Modification    ./Sources/MessageIndex.php    Test successful
6.    Execute Modification    ./Sources/Subs-Boards.php    Test successful
7.    Execute Modification    ./Themes/default/BoardIndex.template.php    Test failed
8.    Execute Modification    ./Themes/default/ManageBoards.template.php    Test successful
9.    Execute Modification    ./Themes/default/MessageIndex.template.php    Test successful
10.    Execute Modification    ./Themes/babylon/BoardIndex.template.php    Test successful
11.    Execute Modification    ./Themes/babylon/MessageIndex.template.php    Test successful
12.    Execute Modification    ./Themes/classic/BoardIndex.template.php    Test successful
13.    Execute Modification    ./Themes/classic/MessageIndex.template.php    Test successful
14.    Execute Modification    ./Themes/default/languages/Help.english.php    Test successful
15.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test successful


Solution?

perplexed

Quote from: JoshieDaMan on April 04, 2008, 06:07:38 PM
Quote1.     Execute Code     RedirectPdb.php     
2.    Execute Modification    ./Sources/BoardIndex.php    Test successful
3.    Execute Modification    ./Sources/Load.php    Test failed
4.    Execute Modification    ./Sources/ManageBoards.php    Test successful
5.    Execute Modification    ./Sources/MessageIndex.php    Test successful
6.    Execute Modification    ./Sources/Subs-Boards.php    Test successful
7.    Execute Modification    ./Themes/default/BoardIndex.template.php    Test failed
8.    Execute Modification    ./Themes/default/ManageBoards.template.php    Test successful
9.    Execute Modification    ./Themes/default/MessageIndex.template.php    Test successful
10.    Execute Modification    ./Themes/babylon/BoardIndex.template.php    Test successful
11.    Execute Modification    ./Themes/babylon/MessageIndex.template.php    Test successful
12.    Execute Modification    ./Themes/classic/BoardIndex.template.php    Test successful
13.    Execute Modification    ./Themes/classic/MessageIndex.template.php    Test successful
14.    Execute Modification    ./Themes/default/languages/Help.english.php    Test successful
15.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test successful


Solution?

use the package parser to edit the failed files manually :)

soyabiatch

I have the same as pp and get this on the parser

ERROR: The package-info.xml file is invalid!

Debugging Information
Error message: String could not be parsed as XML
Source: /home/sleepy1/public_html/PackageParser/index.php:155
Errors encountered while parsing XML file:

Stack Trace:
#0 /home/sleepy1/public_html/PackageParser/index.php(155): SimpleXMLElement->__construct('')
#1 /home/sleepy1/public_html/PackageParser/index.php(96): parsePackageInfoXML('/home/sleepy1/b...', 'install', 'all')
#2 /home/sleepy1/public_html/PackageParser/index.php(784): parseArchive('/tmp/phpc2GxVy', 'install', 'all')
#3 {main}

XML File:

Advertisement: