• Welcome to Simple Machines Community Forum. Please login or sign up.
November 28, 2021, 07:12:40 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


Redirection Boards

Started by Oldiesmann, October 18, 2004, 07:01:58 AM

Previous topic - Next topic

Rosenstein

I think you shouldn't replace in  "./Sources/ManageBoards.php"
Quote
	
	
	
'permission_mode' => 'normal',
with
Quote
	
	
	
'is_redirect' => 0,
	
	
	
'count_clicks' => 0,
	
	
	
'target' => '',
	
	
	
'url' => '
But, instead add after
Quote
	
	
	
'permission_mode' => 'normal',
Because, when you replace it it gives "8: Undefined index: permission_mode" error.

bran8464

I would love to have a function like this but when I attempt to install on my 1.1.5, default, I get this:

Installations actions for "Redirection Boards":
Installing this package will perform the following actions:  Type Action Description
1. Execute Code RedirectPdb.php 
2. Execute Modification ./Sources/BoardIndex.php Test successful
3. Execute Modification ./Sources/Load.php Test failed
4. Execute Modification ./Sources/ManageBoards.php Test successful
5. Execute Modification ./Sources/MessageIndex.php Test failed
6. Execute Modification ./Sources/Subs-Boards.php Test successful
7. Execute Modification ./Themes/default/BoardIndex.template.php Test failed
8. Execute Modification ./Themes/default/ManageBoards.template.php Test successful
9. Execute Modification ./Themes/default/MessageIndex.template.php Test failed
10. Execute Modification ./Themes/babylon/BoardIndex.template.php Test failed
11. Execute Modification ./Themes/babylon/MessageIndex.template.php Test failed
12. Execute Modification ./Themes/classic/BoardIndex.template.php Test failed
13. Execute Modification ./Themes/classic/MessageIndex.template.php Test failed
14. Execute Modification ./Themes/default/languages/Help.english.php Test successful
15. Execute Modification ./Themes/default/languages/Modifications.english.php Test successful

Any answers?

bran8464

July 29, 2008, 05:15:01 AM #382 Last Edit: July 29, 2008, 05:25:41 AM by bran8464
On the other hand I also installed it on a clean test site and it installed and it works fine.
This is a great mod and I want it!

My main concern is that I would like to get it into the main site and working

eculewatt

it installed successfully the thing is it shows no words where it is. i can see that it's under "Override Member's Theme" because theres a question mark and to the right is a check spot and when i click the check spot 2 text boxes appear. but i don;t know what to type in them because there is no words
help please, thanks
SMF version 1.1.6
smf forum: http://www.pspgrounds.com/forum

bran8464

The bottom box is where you put in something like this: _blank (to open in a new page) and the box above it is where you put the url to redirect to.

peony

Hello Everybody,

I'm new to administrating forums and don't know much about programming.
I installed the Redirect mod without any error messages. 

However, when I go to "Modify Boards",  I can't see the text associated with the new extra options. I can only see the 2 help question marks, 3 new check boxes, and 2 text boxes. I checked off all the boxes and put the redirect link the first box and my board now redirects. However, while I can see that it keeps track of the number of redirects, the text "redirected clicks" does not show, like on the board at http://smf.oldiesmann.us/ [nofollow].

Is there anything I can do about this?

Also, I can't access the forum homepage under the Babylon theme after installing the mod. (I can still access the admin part though.)
I get the following message:

Template Parse Error!
There was a problem loading the /Themes/babylon/BoardIndex.template.php template or language file. Please check the syntax and try again - remember, single quotes (') often have to be escaped with a slash (\). To see more specific error information from PHP, try accessing the file directly.

You may want to try to refresh this page or use the default theme.

Parse error: syntax error, unexpected '/' in .../Themes/babylon/BoardIndex.template.php on line 131
122:                echo '<img src="', $settings['images_url'], '/on.gif" alt="', $txt[333], '" title="', $txt[333], '" border="0" />';
123:             // This board doesn't have new posts, but its children do.
124:             elseif ($board['children_new'])
125:                echo '<img src="', $settings['images_url'], '/on2.gif" alt="', $txt[333], '" title="', $txt[333], '" border="0" />';
126:             // No new posts at all!  The agony!!
127:             else
128:                echo '<img src="', $settings['images_url'], '/off.gif" alt="', $txt[334], '" title="', $txt[334], '" border="0" />';
129:
130:             echo '</a></td>
131:             echo '</a></td>
132:       <td', $board['is_redirect'] && $modSettings['redirect_hide_columns'] ? ' colspan="2"' : '', '>
133:          <b><a href="', $board['href'], '" name="b', $board['id'], '"', ($board['is_redirect'] && $board['redirect_target'] != '') ? ' target="' . $board['redirect_target'] . '"' : '', '>', $board['name'], '</a></b><br />
134:          ', $board['description'];


How can I get the redirect mod to work with the Babylon theme?

peony

RE: getting the Babylon theme to work
I really had no idea what I was doing, but I opened up the ".../Themes/babylon/BoardIndex.template.php" file in FrontPage and deleted line 131. After reuploading it, I can now see the Home page, but when I click on the board, I get another message:

Template Parse Error!
There was a problem loading the /Themes/babylon/MessageIndex.template.php template or language file. Please check the syntax and try again - remember, single quotes (') often have to be escaped with a slash (\). To see more specific error information from PHP, try accessing the file directly.

You may want to try to refresh this page or use the default theme.

Parse error: syntax error, unexpected ')', expecting ',' or ';' in .../Themes/babylon/MessageIndex.template.php on line 111
102:             echo '
103:                ', $txt[22], ' ', $txt[30], ' ', $board['last_post']['time'], '<br />
104:                ', $txt['smf88'], ' ', $board['last_post']['link'], ' ', $txt[525], ' ', $board['last_post']['member']['link'];
105:
106:          elseif ($board['is_redirect'])
107:          {
108:             if($board['redirect_count_clicks'])
109:             {
110:                // How many redirected clicks? We have to be grammatically correct, you know ;)
111:                echo ($board['redirect_clicks'] == 1) ? $txt['redirected_click'] : '<b>' . $board['redirect_clicks'] . '</b> ' . $txt['redirected_clicks']);
112:             }
113:             else
114:             {
115:                // For now, just show this filler text. I'll probably do more with this in the next version...


This time I don't know how to even try to fix it... Can anyone help me?

peony

I decided to stick with the default theme, so that I can avoid a lot of future difficulties when using other mods.

Does anyone know why I can't see the redirect text on the forums page, though? I attached a picture of what appears.

Thanks!

Johno69

looks like it didn't update your language file, check that manualy.

peony

Hi Johno69,

Thanks for your reply! The language file did look like it was missing some information. I followed the manual install instructions and updated the file.

However, I still can't see any text for the redirected boards.... just numbers.

peony

Hello,

I think I found a clue as to what could be causing the problem. When I look at the information on the visitors of the board, I see that the following error message is reported:

8: Undefined index: redirected_clicks
File: /home/forum/Themes/default/BoardIndex.template.php (main sub template - eval?)
Line: 186


Below is an excerpt of the code from the file involved. Line 186 is the one in red.

         <tr>
            <td colspan="3" class="windowbg', !empty($settings['seperate_sticky_lock']) ? '3' : '', '">
               <span class="smalltext"><b>', $txt['parent_boards'], '</b>: ', implode(', ', $children), '</span>
            </td>
         </tr>';
            }
         }
         echo '
      </table>';
      }
      echo '
   </div>';
   }


Does anyone know what the problem might be?

Thank you in advance!

Adish - (F.L.A.M.E.R)

I had some problems and then i uninstalled this mod.. But now in the board.. the tick box for the redirection still remains.. i tried alot to remove the box from the files as such but didnt get the solution. This is causing me 29 error pages at a time as i go to the create new board... so please help me fast...

Adish - (F.L.A.M.E.R)

Phew.... I atlast got it removed.. anyways thanks to the one who was trying to answer my question.

cheshirex

I'm wondering if I could use this application paired with a blog mod.  What I'd like to be able to do is create a "Random Blog" link that would take you to any of (let's say for the time being) 10 blogs listed.

So - anyone know if there's any way to set it up to allow more than one link per redirect board AND choose a link at random? 

*wishful thinking*  Thanks in advance for any answers I get.

WiredStorm

very nice thanks - you should try make an image so it doesnt show newposts/no new posts icon and an re-directing icon

istup

August 28, 2008, 02:16:49 AM #395 Last Edit: August 29, 2008, 01:19:44 AM by istup
Quote from: Oldiesmann on October 18, 2004, 07:01:58 AM
Link to Mod

This provides the functionality for redirecting users when they enter certain boards. Several new options will appear in the "Modify Boards" section of the admin center.

NEW! Version 2.01 released (September 30th, 2006)!

New features:
No new features in this version. Just bugfixes and compatibility with 1.0.8 and 1.1 RC3

Note: Due to the number of bugs in 2.0, you can't upgrade from it. You will need to uninstall it first and re-install this version instead.

Let me know if you have any problems or questions.

Update (9/30/06): Fixed some more bugs and updated the mod to work with 1.0.8 and 1.1 RC3...

Screenshots attached...
First screenshot shows default "Modify Board" screen.
Second screenshot shows several additional redirection boards settings that show up after you check the "Make this a redirection board" box (ah the fun of Javascript).
The third screenshot shows a default redirection board. The "--" column can be hidden by checking the box next to Hide "topics and posts" for redirection boards in the "Edit Features and Options" section (1.0.x) or "Manage Boards -> General Settings" section (1.1). If you aren't counting clicks, "N/A" is displayed instead of the number of clicks.

Test: http://smf.oldiesmann.us/index.php / http://smf.oldiesmann.us/index.php?board=93

I tried to install this mod but i got error...

1.     Execute Code     RedirectPdb.php     
2.    Execute Modification    ./Sources/BoardIndex.php    Test successful
3.    Execute Modification    ./Sources/Load.php    Test successful
4.    Execute Modification    ./Sources/ManageBoards.php    Test successful
5.    Execute Modification    ./Sources/MessageIndex.php    Test successful
6.    Execute Modification    ./Sources/Subs-Boards.php    Test failed
7.    Execute Modification    ./Themes/default/BoardIndex.template.php    Test successful
8.    Execute Modification    ./Themes/default/ManageBoards.template.php    Test successful
9.    Execute Modification    ./Themes/default/MessageIndex.template.php    Test successful
10.    Execute Modification    ./Themes/babylon/BoardIndex.template.php    Test successful
11.    Execute Modification    ./Themes/babylon/MessageIndex.template.php    Test successful
12.    Execute Modification    ./Themes/classic/BoardIndex.template.php    Test successful
13.    Execute Modification    ./Themes/classic/MessageIndex.template.php    Test successful
14.    Execute Modification    ./Themes/default/languages/Help.english.php    Test successful
15.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test successful

Can you pls help to solve this issue


Adish - (F.L.A.M.E.R)

I am getting errors in the error log when i go to create a redirection board.

Here are the errors..

8: Undefined index: permission_mode
File: /home/goldysun/public_html/Themes/default/ManageBoards.template.php (modify_board sub template - eval?)
Line: 409

And same on Lines 410,411 and 412

This is the Url it shows me that it has came from:- http://goldysun.com/index.php?action=manageboards;sa=newboard;cat=1

Please let me know whats the solution, thank you.

Hoochie Coochie Man

Quote from: Rosenstein on July 05, 2008, 08:43:38 PM
I think you shouldn't replace in  "./Sources/ManageBoards.php"
Quote
	
	
	
'permission_mode' => 'normal',
with
Quote
	
	
	
'is_redirect' => 0,
	
	
	
'count_clicks' => 0,
	
	
	
'target' => '',
	
	
	
'url' => '
But, instead add after
Quote
	
	
	
'permission_mode' => 'normal',
Because, when you replace it it gives "8: Undefined index: permission_mode" error.

Thanks for this tip.

and thanks for the mod, I think this tip should added to packege, because if it's not, we are getting "Undefined index: permission_mode" error"

and here is Turkish Language:

Help.turkish.php
$helptxt['redirect_target'] = 'Hedef URLnin açılacağı pencere. Yönlendirilmiş bölümü aynı pencerede açmak istemiyorsanız bu ayara ihtiyaç duyarsınız.
Hedef bir pencerenin ismi veya takip eden isimlerden biri olabilir:<br />
_blank - Yeni bir pencerede aç<br />
_parent - üst framesette aç<br />
_self - Aynı framede aç<br />
_top - Aynı pencerede aç, frame dışında';
$helptxt['enable_redirect'] = 'Bağlı olmaksızın ya da bunu bir yönlendirme bölümü yapmamak. Yönlendirme bölümü, üyeyi tıkladığında başka bir linke yönlenmesini sağlayan bölümdür.
<b>Not:</b> Bu bölümü yönlendirilmiş bölüm yapmadan önce
lütfen bölümün boş ya da herhangi bir alt bölümü olmadığından emin olun.
Ayrıca şunuda bilin ki, o bölümü görüntülemeye izni olmayanlar bile direk
url ile yönelndirilmiş bölüme giriş yapabilirler...';
$helptxt['redirect_hide_columns'] = 'Eğer seçilense, bu yönlendirilmiş bölümün mesaj ve konu sayılarını saklayacaktır.
Default temada, "X mesaj Y konu" sütunu saklanır. Babylon temada, "X mesaj in Y konu" sütunu saklanır, ve Classic temada, "mesaj" and "konu" sütunu saklanır. Eğer bu seçilmemişse "--" onun yerine gösterilir.';


Modifications.turkish.php
$txt['redirected_click'] = '<b>1</b> yönlendirilmiş tıklama';
$txt['redirected_clicks'] = ' yönlendirilmiş tıklamalar';
$txt['redirect_count_clicks'] = 'Tüm tıklamaları say?';
$txt['redirect_count_clicks_desc'] = 'Bu, kaç kere üyelerin yönlendirildiğini sayacak.';
$txt['redirect_enable'] = 'Bu bölümü yönlendir.';
$txt['redirect_enable_desc'] = 'Bu, bölüme giriş yapan üyeleri, sizin seçtiğiniz bir linke yönlendirecek.';
$txt['redirect_location'] = 'Üyenin yönlendirileceği URL ';
$txt['redirect_hide_columns'] = 'Yönlendirilmiş bölümler için "mesaj" ve "konu" ları gizle.';
$txt['redirect_no_child'] = 'Yönlendirilmiş bölümler alt bölümlere sahip olamaz!';
$txt['redirect_no_url'] = 'Yönlendirilmiş bölümler bir URLye sahip olmalıdır!';
$txt['redirect_reset_clicks'] = 'Tıklama sayacını sıfırla';
$txt['redirect_reset_clicks_desc'] = 'Tıklama sayacını sıfıra(0) sıfırlayacak.';
$txt['redirect_target'] = 'URL için hedef';
$txt['redirect_target_desc'] = 'Yeni linke yönlendirmek için hedef (_blank)';
İnadına SMF 1.1.X

fyndler

Hi i use the Dark Fantasy theme and i have read the manuall file but i dont get what he really means :/

Could someone make a easyer explination for me ? :)

Thanks

Goodman854

3.     Execute Modification     ./Sources/Load.php     Test failed
4.    Execute Modification    ./Sources/ManageBoards.php    Test successful
5.    Execute Modification    ./Sources/MessageIndex.php    Test successful
6.    Execute Modification    ./Sources/Subs-Boards.php    Test successful
7.    Execute Modification    ./Themes/default/BoardIndex.template.php    Test failed

Advertisement: