Advertisement:

Author Topic: Sorted Package Manager Listing  (Read 41435 times)

Offline rexdelsar

  • Newbie
  • *
  • Posts: 2
Re: Sorted Package Manager Listing
« Reply #40 on: January 22, 2009, 02:00:31 AM »
Are you using [THIS] version?
Nope.. I think I'm using the version prior to that.

Anyway, I solved the problem by doing a manual uninstall of the package, afterwhich I can reinstall this updated version. Thanks!

Offline Tinny

  • Semi-Newbie
  • *
  • Posts: 11
  • Gender: Male
    • Unholy Shunters
Re: Sorted Package Manager Listing
« Reply #41 on: March 27, 2009, 08:47:12 AM »
I was having problems trying to install this on smf 1.1.8

Fixed it :D

If anyone needs it, the attached file works on smf 1.1.8

Offline Ashdaw

  • Jr. Member
  • **
  • Posts: 183
  • Gender: Male
    • GreycastleOZ
Re: Sorted Package Manager Listing
« Reply #42 on: June 17, 2009, 08:34:53 AM »
I had the added this mod to a friends site 2 years ago and lately I had been having trouble adding other mods and I finally found that this mod had the change added to the packages.template.php in the wrong spot, as soon as I manually removed it, no more trouble.

I will download the File you have added here Tinny and see if will be ok. :)
You are more than welcome to visit my site.
Greycastle

Offline timned88

  • Jr. Member
  • **
  • Posts: 360
    • The Magic in Pixels
Re: Sorted Package Manager Listing
« Reply #43 on: July 17, 2009, 06:23:40 AM »
can this be made for 2.0 rc1.2?  I miss having this mod on-board!

Offline timned88

  • Jr. Member
  • **
  • Posts: 360
    • The Magic in Pixels
Re: Sorted Package Manager Listing
« Reply #44 on: August 07, 2009, 07:43:40 AM »
can this be made for 2.0 rc 1.2?  i really miss this mod...

Offline Naveeddil

  • Semi-Newbie
  • *
  • Posts: 72
  • Gender: Male
Re: Sorted Package Manager Listing
« Reply #45 on: August 22, 2009, 12:27:24 PM »
Hello Dear!
it is working fine after installing this Mod Manually (Manual Installation due to conflict with other Mods)
but i'm getting an error as highlited in Attached file
while i'm also sowing the code for the package.template.php (i think it is the place from where this problem arissed)

I'm new to PHP so please Help that what should i do to remove the error
I edited the code and added
Code: [Select]
$context['session_id'], ' because on the page it were giving session error and Expiration
.
.
.
Code from template file (where i think i missed something)
Code: [Select]
<a href="', $scripturl, '?action=packages;sa=uninstall;package=', $package['filename'], ';sesc=', $context['session_id'], '">[ ', $txt['smf198b'], ' ]</a>';
elseif ($package['can_upgrade'])
echo '
<a href="', $scripturl, '?action=packages;sa=install;package=', $package['filename'], '">[ ', $txt['package_upgrade'], ';sesc=', $context['session_id'], '"]</a>';
elseif ($package['can_install'])
echo '
<a href="', $scripturl, '?action=packages;sa=install;package=', $package['filename'], '">[ ', $txt['package11'], ';sesc=', $context['session_id'], '"]</a>';

echo '
<a href="', $scripturl, '?action=packages;sa=list;package=', $package['filename'], '">[ ', $txt['package14'], ' ]</a>
<a href="', $scripturl, '?action=packages;sa=remove;package=', $package['filename'], ';sesc=', $context['session_id'], '"', $package['is_installed'] && $package['is_current'] ? ' onclick="return confirm(\'' . $txt['package_delete_bad'] . '\');"' : '', '>[ ', $txt['package52'], ' ]</a>

PLEASE HELP

Offline postfix

  • Newbie
  • *
  • Posts: 2
Re: Sorted Package Manager Listing
« Reply #46 on: November 07, 2009, 01:34:33 PM »
It didn't work with SMF-1.1.10   :'(

Offline Cal O'Shaw

  • Full Member
  • ***
  • Posts: 444
  • SMF 1.1.14 & 2.0 Sites
Re: Sorted Package Manager Listing
« Reply #47 on: February 20, 2010, 11:49:07 PM »
Hello,

What was the change made to this package today?  Ownership change?  I have a version that is working under 1.1.11 and am wondering if I should replace with this one (seems unlikely, but wanted to ask)?

If you are open to suggestions, could you make some indication (lines or alternating shades) to make it easier to hit the correct button when choosing to take an action?  There's that wide unmarked space between the left-justified Package names and the right-justified action buttons, and it's easy, when one has, say, 33 packages, for the mouse to drift up or down when trying to click the proper button.

Grazie,

Cal

Offline live627

  • On Hiatus
  • SMF Hero
  • *
  • Posts: 5,620
  • Gender: Male
    • live627 on Facebook
    • live627 on GitHub
    • live627 on LinkedIn
    • @live627 on Twitter
    • livemods
Re: Sorted Package Manager Listing
« Reply #48 on: February 22, 2010, 10:47:38 PM »
Only ownership change
Try not to become a man of success, but rather try to become a man of value.
- Albert Einstein

Offline Robin1989

  • Jr. Member
  • **
  • Posts: 165
  • Gender: Male
  • lovin smf
    • Acidmods
Re: Sorted Package Manager Listing
« Reply #49 on: February 23, 2010, 09:35:13 AM »
will it be updated to work with 2.0 with the new owner

Offline live627

  • On Hiatus
  • SMF Hero
  • *
  • Posts: 5,620
  • Gender: Male
    • live627 on Facebook
    • live627 on GitHub
    • live627 on LinkedIn
    • @live627 on Twitter
    • livemods
Re: Sorted Package Manager Listing
« Reply #50 on: February 23, 2010, 11:21:04 PM »
Tomorrow I will update it
Try not to become a man of success, but rather try to become a man of value.
- Albert Einstein

Offline timned88

  • Jr. Member
  • **
  • Posts: 360
    • The Magic in Pixels
Re: Sorted Package Manager Listing
« Reply #51 on: February 24, 2010, 02:37:23 PM »
looking forward to it.

Offline live627

  • On Hiatus
  • SMF Hero
  • *
  • Posts: 5,620
  • Gender: Male
    • live627 on Facebook
    • live627 on GitHub
    • live627 on LinkedIn
    • @live627 on Twitter
    • livemods
Re: Sorted Package Manager Listing
« Reply #52 on: February 24, 2010, 10:44:38 PM »
Update 1.0:

Adds striping to the packages list in SMF 1.1.x
Compatible with SMF 2.0 RC2

@timned88: Try the version emulator. I have not tested this mod with SMF 2.0 RC1.2
Try not to become a man of success, but rather try to become a man of value.
- Albert Einstein

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,531
  • Gender: Male
    • dragomano on GitHub
    • @dragomano on Twitter
    • Russian translations for SMF mods
Re: Sorted Package Manager Listing
« Reply #53 on: February 25, 2010, 12:01:04 PM »
Russian translation:
Code: [Select]
<file name="$languagedir/Modifications.russian-utf8.php" error="skip">
<operation>
<search position="end" />
<add><![CDATA[
// --- Sorted Package Manager Listing ---
$txt['pkgstate_cannot_install'] = 'Неудачная установка';
$txt['pkgstate_cannot_uninstall'] = 'Установленные - Неудаляемые (нет секции удаления для этой версии SMF)';
$txt['pkgstate_cannot_uninstall_2'] = 'Установленные - Неудаляемые';
$txt['pkgstate_cannot_upgrade'] = 'Необновляемые';
$txt['pkgstate_install'] = 'Неустановленные';
$txt['pkgstate_uninstall'] = 'Установленные';
$txt['pkgstate_upgrade'] = 'Обновляемые';
$txt['pkgstatehelp_cannot_install'] = 'Эти моды не могут быть установлены на текущую версию SMF. Вы можете попробовать связаться с автором каждого мода и попросить его обновить свой продукт для поддержки последней версии SMF.';
$txt['pkgstatehelp_cannot_uninstall_2'] = 'Эти моды установлены, но авторы были настолько ленивы, что даже не сделали их удаляемыми. Вам придётся удалять эти моды вручную.';
$txt['pkgstatehelp_cannot_upgrade'] = 'Эти моды установлены и для них доступны обновления. Однако что-то мешает им обновиться.';
$txt['pkgstatehelp_install'] = 'Эти моды не установлены. Возможно, некоторые из них не совместимы с Вашей версией SMF.';
$txt['pkgstatehelp_uninstall'] = 'Эти моды уже установлены и могут быть удалены.';
$txt['pkgstatehelp_upgrade'] = 'Установлены предыдущие версии этих модов. Установка новой версии мода обновит текущую.';
]]></add>
</operation>
</file>

Offline live627

  • On Hiatus
  • SMF Hero
  • *
  • Posts: 5,620
  • Gender: Male
    • live627 on Facebook
    • live627 on GitHub
    • live627 on LinkedIn
    • @live627 on Twitter
    • livemods
Re: Sorted Package Manager Listing
« Reply #54 on: February 25, 2010, 05:24:29 PM »
Thank you. Is that utf-8 or both?
Try not to become a man of success, but rather try to become a man of value.
- Albert Einstein

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,531
  • Gender: Male
    • dragomano on GitHub
    • @dragomano on Twitter
    • Russian translations for SMF mods
Re: Sorted Package Manager Listing
« Reply #55 on: February 25, 2010, 07:56:00 PM »
Thank you. Is that utf-8 or both?
It's possible (both), but in different files - encoded with ANSI and UTF8 encoded separately. Example:

file russian-utf8.xml (encoded to UTF8 without BOM):
Code: [Select]
<file name="$languagedir/Modifications.russian-utf8.php" error="skip">
<operation>
<search position="end" />
<add><![CDATA[
// --- Sorted Package Manager Listing ---
$txt['pkgstate_cannot_install'] = 'Неудачная установка';
$txt['pkgstate_cannot_uninstall'] = 'Установленные - Неудаляемые (нет секции удаления для этой версии SMF)';
$txt['pkgstate_cannot_uninstall_2'] = 'Установленные - Неудаляемые';
$txt['pkgstate_cannot_upgrade'] = 'Необновляемые';
$txt['pkgstate_install'] = 'Неустановленные';
$txt['pkgstate_uninstall'] = 'Установленные';
$txt['pkgstate_upgrade'] = 'Обновляемые';
$txt['pkgstatehelp_cannot_install'] = 'Эти моды не могут быть установлены на текущую версию SMF. Вы можете попробовать связаться с автором каждого мода и попросить его обновить свой продукт для поддержки последней версии SMF.';
$txt['pkgstatehelp_cannot_uninstall_2'] = 'Эти моды установлены, но авторы были настолько ленивы, что даже не сделали их удаляемыми. Вам придётся удалять эти моды вручную.';
$txt['pkgstatehelp_cannot_upgrade'] = 'Эти моды установлены и для них доступны обновления. Однако что-то мешает им обновиться.';
$txt['pkgstatehelp_install'] = 'Эти моды не установлены. Возможно, некоторые из них не совместимы с Вашей версией SMF.';
$txt['pkgstatehelp_uninstall'] = 'Эти моды уже установлены и могут быть удалены.';
$txt['pkgstatehelp_upgrade'] = 'Установлены предыдущие версии этих модов. Установка новой версии мода обновит текущую.';
]]></add>
</operation>
</file>

and file russian.xml (encoded in ANSI):
Code: [Select]
<file name="$languagedir/Modifications.russian.php" error="skip">
<operation>
<search position="end" />
<add><![CDATA[
// --- Sorted Package Manager Listing ---
$txt['pkgstate_cannot_install'] = 'Неудачная установка';
$txt['pkgstate_cannot_uninstall'] = 'Установленные - Неудаляемые (нет секции удаления для этой версии SMF)';
$txt['pkgstate_cannot_uninstall_2'] = 'Установленные - Неудаляемые';
$txt['pkgstate_cannot_upgrade'] = 'Необновляемые';
$txt['pkgstate_install'] = 'Неустановленные';
$txt['pkgstate_uninstall'] = 'Установленные';
$txt['pkgstate_upgrade'] = 'Обновляемые';
$txt['pkgstatehelp_cannot_install'] = 'Эти моды не могут быть установлены на текущую версию SMF. Вы можете попробовать связаться с автором каждого мода и попросить его обновить свой продукт для поддержки последней версии SMF.';
$txt['pkgstatehelp_cannot_uninstall_2'] = 'Эти моды установлены, но авторы были настолько ленивы, что даже не сделали их удаляемыми. Вам придётся удалять эти моды вручную.';
$txt['pkgstatehelp_cannot_upgrade'] = 'Эти моды установлены и для них доступны обновления. Однако что-то мешает им обновиться.';
$txt['pkgstatehelp_install'] = 'Эти моды не установлены. Возможно, некоторые из них не совместимы с Вашей версией SMF.';
$txt['pkgstatehelp_uninstall'] = 'Эти моды уже установлены и могут быть удалены.';
$txt['pkgstatehelp_upgrade'] = 'Установлены предыдущие версии этих модов. Установка новой версии мода обновит текущую.';
]]></add>
</operation>
</file>

Offline Membre

  • Semi-Newbie
  • *
  • Posts: 32
Re: Sorted Package Manager Listing
« Reply #56 on: February 26, 2010, 09:25:13 AM »
Spanish_es / Spanish_latin / Spanish ( add utf8 also please :) )

         <add><![CDATA[
// --- Sorted Package Manager Listing ---
$txt['pkgstate_cannot_install'] = No se puede instalar';
$txt['pkgstate_cannot_uninstall'] = 'Instalado - No Desinstalable (no hay seccion de desinstalacion para esta version de SMF)';
$txt['pkgstate_cannot_uninstall_2'] = 'Instalado - No Desinstalable';
$txt['pkgstate_cannot_upgrade'] = 'No se puede Actualizar';
//$txt['pkgstate_install'] = 'Instalable';
$txt['pkgstate_install'] = 'No Instalado';
//$txt['pkgstate_uninstall'] = 'Instalado - No Desinstalable';
$txt['pkgstate_uninstall'] = 'Instalado';
$txt['pkgstate_upgrade'] = 'Actualizable';

$txt['pkgstatehelp_cannot_install'] = 'Este mod no puede ser instalado en tu version actual de SMF. Tu podrias contactar el autor del mod y pedir si puede actualizarlo para que soporte la ultima version del SMF.';
$txt['pkgstatehelp_cannot_uninstall_2'] = 'Estos mods estan instalados, pero los autores fueron vagos y no le hicieron un desinstalador. Tendras que desinstalarlos manualmente.';
$txt['pkgstatehelp_cannot_upgrade'] = 'Estos mods estan instalados y una actualizacion esta disponible. Sin embargo, algo esta deteniendo el correcto funcionamiento de la actualizacion.';
$txt['pkgstatehelp_install'] = 'Estos mods no estan instalados. Los mods son compatibles con tu version de SMF.';
$txt['pkgstatehelp_uninstall'] = 'Estos mods estan instalados y pueden ser desinstalados.';
$txt['pkgstatehelp_upgrade'] = 'Una version previa de estos mods esta instalada. Instalando la nueva version actualizara tu instalacion actual.';
]]></add>

Offline live627

  • On Hiatus
  • SMF Hero
  • *
  • Posts: 5,620
  • Gender: Male
    • live627 on Facebook
    • live627 on GitHub
    • live627 on LinkedIn
    • @live627 on Twitter
    • livemods
Re: Sorted Package Manager Listing
« Reply #57 on: February 26, 2010, 05:52:06 PM »
Thanks guys
Try not to become a man of success, but rather try to become a man of value.
- Albert Einstein

Offline Am'

  • Full Member
  • ***
  • Posts: 484
  • Gender: Male
  • En Quête De Sagesse
Re: Sorted Package Manager Listing
« Reply #58 on: March 11, 2010, 03:51:44 AM »
not compatible with rc3
اذا أحس أحد انه لم يخطأ ابدا في حياته, فهذا يعني أنه لم يجرب أي جديد في حياته
My Mods For SMF 2 RC3 : XQuote XCode - Vbulletin Style New Meta Tags

Offline [unplugged]

  • Sophist Member
  • *****
  • Posts: 1,312
  • Gender: Male
  • I know just enough to get me in trouble...
    • Empire of the Sun
Re: Sorted Package Manager Listing
« Reply #59 on: March 11, 2010, 04:23:45 AM »
RC3 has only been out for a couple of days. I'm sure the update is on it's way. The only reason it failed at all is because RC3 wrapped the <h3> tag in <div>'s to help with styling Curve better.

It didn't take much to get this installed on my RC3. If you absolutely have to have it right away:

1) Make backups (this should always be step 1).
2) Upload the mod package.
3) Go to package manager and down at the very bottom right corner, select Advanced.
4) Change where is says SMF 2.0 RC2 to SMF 2.0 RC3.
5) Install the mod. (You will get two fails for the Packages.template.php. Ignore these and install anyway.)
6) Upload the attached Packages.template.php (which I have already manually edited) to your Themes/default/ folder.
7) Enjoy the mod.
« Next Edit: Tomorrow at 08:34:45 PM by SunKing »   <---- « someone stole my sig... :o »