News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Visual Warning Mod

Started by Eleglin, July 31, 2007, 08:53:40 AM

Previous topic - Next topic

Eleglin

The different versions of this mod were not built for common premoderation.  ;)
No support by PM or Mail.

topbuyer

Quote from: Eleglin on September 23, 2007, 06:17:13 AM
The different versions of this mod were not built for common premoderation.  ;)


Can you guide me like. I can use any other mod for common premoderation.

Eleglin

You could wait for SMF 2.0, which will be the next version of SMF, because pre-moderation is on the feature list of 2.0.
I'm busy and can't look for this modification. Sorry. ;)
No support by PM or Mail.

topbuyer

No problem. Thanks for replies.

It is good that premoderation is part of SMf 2.0. I will use this mod till then. By the way any tentative date for smf 2.0 release officially?

Also, why warn button is not properly working on dilbermc them. Please suggest. (See enclosed image)

Eleglin

Quote from: topbuyer on September 23, 2007, 06:34:41 AM
Also, why warn button is not properly working on dilbermc them. Please suggest. (See enclosed image)
You should add an image (call him warn.gif)  in /icons (in your theme's folder )
No support by PM or Mail.

topbuyer

Quote from: Eleglin on September 23, 2007, 06:55:09 AM
Quote from: topbuyer on September 23, 2007, 06:34:41 AM
Also, why warn button is not properly working on dilbermc them. Please suggest. (See enclosed image)
You should add an image (call him warn.gif)  in /icons (in your theme's folder )

I couldn't able to see warn.gif in your module folder. Can you please redirect me towards that file. So, that I can upload it in my themes's icon folder.

Eleglin

I think this is an "error" since the default theme is Core (since SMF 1.1 RC3)
Before, it was Babylon and you can find an image called warn.gif in the package (it was done for this theme).
Since Core is the new default theme, I think we have forgotten to modify this image and its destination.
I will be looking for a new image, but you can add the image warn.gif you want in /icons, for the moment.  ;)
No support by PM or Mail.

hypercube

Can sumone please awnser my question... :D

Quote from: hypercube on September 23, 2007, 04:21:27 AM
I can't see the warning button under avater next to PM and all the other buttons. I use default theme and English language... :-[
But in admin panel I do see
-Warning Management
-Post Moderation Manager

Eleglin

No support by PM or Mail.


Eleglin

Keep mind that an installation with the package manager :
- don't add the translations on the languages files (except English (iso) )
- don't add the features on the language files for English-UTF8
- don't add the features on a modified theme (it adds only on default theme)
Please refer to Readme and modifications.xml (which are on the zip); You should do a manual installation, as described here.
No support by PM or Mail.

ButtonBash

Quote from: shaiss on August 21, 2007, 10:17:21 AM
Quote from: shaiss on August 15, 2007, 12:06:17 PM
I'm having a problem with the instal.  Files are failing.  I tried the SMF package parser, but get nothing.
heres my error files:
1. Execute Code VisualWarningPdb.php
2. Execute Modification ./index.php Test successful
3. Execute Modification ./Sources/ModSettings.php Test successful
4. Execute Modification ./Themes/default/Profile.template.php Test successful
5. Execute Modification ./Sources/Display.php Test successful
6. Execute Modification ./Themes/default/Display.template.php Test successful
7. Execute Modification ./Sources/Post.php Test failed
8. Execute Modification ./Themes/default/Post.template.php Test successful
9. Execute Modification ./Sources/Karma.php Test successful
10. Execute Modification ./Sources/Subs.php Test successful
11. Execute Modification ./Sources/Security.php Test successful
12. Execute Modification ./Themes/default/languages/Modifications.english.php Test successful
13. Execute Modification ./Sources/ManagePermissions.php Test successful
14. Execute Modification ./Themes/default/index.template.php Test successful
15. Execute Modification ./Sources/Load.php Test failed
16. Extract File ./Sources/VisualWarning11.php
17. Extract File ./Themes/default/VisualWarning.template.php
18. Extract File ./Themes/default/images/warnban.gif
19. Extract File ./Themes/default/images/warnpmod.gif
20. Extract File ./Themes/default/images/warnmute.gif
21. Extract File ./Themes/default/images/warnwarn.gif
22. Extract File ./Themes/default/images/members.gif
23. Extract File ./Themes/default/images/buttons/warn.gif


Please help as I'd like to get this installed on my site, hxxp:ocmoto.com [nonactive]
Thank you!
can someone please help me with this?

I'm getting the same issue. Test Failed with the post section.

topbuyer

Quote from: Eleglin link=topic=1860
21.msg1249772#msg1249772 date=1190548910

I think this is an "error" since the default theme is Core (since SMF 1.1 RC3)
Before, it was Babylon and you can find an image called warn.gif in the package (it was done for this theme).
Since Core is the new default theme, I think we have forgotten to modify this image and its destination.
I will be looking for a new image, but you can add the image warn.gif you want in /icons, for the moment.  ;)

What do you think. Should i put

http://www.dsboards.com/SMF/Themes/Mystic_Night/images/warn.gif

in icon folder your mod?

Thanks for help.

Eleglin

You can put the image you want.  ;D
No support by PM or Mail.

topbuyer


[SAP]Francis

#95
I have a problem, my forum became all white pages after I installed it.
Look by yourself Eleglin: http://francismori7.hyperphp.com/sfrpforum/index.php

The page's blank and stays like it is.

I Installed the mod for 1.1.4, but it all scewed up my forum :( :'(

Can you help me?!?!

Thanks,                                                                               Francis

Vehicles Forum

Founded By Francis Morissette

Eleglin

Il n'y a pas de problèmes du côté de ton forum, apriori. Chez moi, il apparait "normalement".
No support by PM or Mail.

Rumbaar

I noticed an update to 1.1.4, thx!

But I'm having issue with post.php file returning an error.  I've looked to do it manually, but there is one part in the modification code where it inserts the code to move a post to the holding mod area but I'm unsure if it's compatible with 1.1.4's version of post.php?   As the find text section is quite different (unlike most of the other find sections) and I'm hesitant to install.

The original post.php file for 1.1.4 has this:
$msgOptions['modify_time'] = time();
$msgOptions['modify_name'] = addslashes($user_info['name']);
}
}

modifyPost($msgOptions, $topicOptions, $posterOptions);


and the mod searches for this:
$msgOptions['modify_time'] = time();
$msgOptions['modify_name'] = addslashes($user_info['name']);
}

modifyPost($msgOptions, $topicOptions, $posterOptions);
}


As you can see the } are in a completely different place, so unsure of the actual position to manually add the code.  It indicates to add it after the searched code.

Thx in advance,
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

Eleglin

I have download the last version of SMF (1.1.4) and the last version of Visual Warning.

The original post.php contains (line 1565-1577) :
// This is an already existing message. Edit it.
if (!empty($_REQUEST['msg']))
{
// Have admins allowed people to hide their screwups?
if (time() - $row['posterTime'] > $modSettings['edit_wait_time'] || $ID_MEMBER != $row['ID_MEMBER'])
{
$msgOptions['modify_time'] = time();
$msgOptions['modify_name'] = addslashes($user_info['name']);
}

modifyPost($msgOptions, $topicOptions, $posterOptions);
}
// This is a new topic or an already existing one. Save it.

And Visual warning 1.41 modify this part:
$msgOptions['modify_time'] = time();
$msgOptions['modify_name'] = addslashes($user_info['name']);
}

modifyPost($msgOptions, $topicOptions, $posterOptions);
}

So it should be all right. ;)
And so... I don't understand why your original code is different :s

Have you installed other mods before ?

No support by PM or Mail.

Rumbaar

#99
Ah, I see it now.  Because there were two instances of:
$msgOptions['modify_time'] = time();
$msgOptions['modify_name'] = addslashes($user_info['name']);

in post.php I was looking at the second instance, not the first.  My first one had 'Reason for mod' addon so wasn't matching and I ignored it, assuming the second instance was the correct one.

Thank you for your time.

Also so I'm 100% certain, still new to this.  I add the code here:
// This is an already existing message. Edit it.
if (!empty($_REQUEST['msg']))
{
// Have admins allowed people to hide their screwups?
if (time() - $row['posterTime'] > $modSettings['edit_wait_time'] || $ID_MEMBER != $row['ID_MEMBER'])
{

********** New visual warning code here ***********

$msgOptions['modify_time'] = time();
$msgOptions['modify_name'] = addslashes($user_info['name']);
}

modifyPost($msgOptions, $topicOptions, $posterOptions);
}
// This is a new topic or an already existing one. Save it.
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

Advertisement: