News:

SMF 2.1.3 has been released! Take it for a spin! Read more.

Main Menu

Visual Warning Mod

Started by Eleglin, July 31, 2007, 08:53:40 AM

Previous topic - Next topic

Sub Zero`

Quote from: Eleglin on May 30, 2008, 03:15:10 PM
QuoteAnd also one problem - when i remove all warnings, the post still have the modified part, i.e: it's still showing the images and the text of that warning, so i need to edit the post every time manualy, any ideas why, is that a known bug?
No. When you warn, it modify the message. So this is normal.
Quote
My global mod can't warn people, nor can I find a place in his permissions to make it so he can.
This is not a feature. You should allow them for each section.



Huh? Like change permissions by board?

Johno69

Hi,

I've been getting...

8: Undefined index: return_to_post
File: /home/hustler/public_html/***/forum/Sources/Post.php
Line: 1617

any ideas?


L'AltroWeb

Hi i have test to install but i receive error with post.php.
Your pack search:
$context['show_spellchecking'] = !empty($modSettings['enableSpellChecking'] && function_exists('pspell_new');
Instead of: $context['show_spellchecking'] = !empty($modSettings['enableSpellChecking']) && function_exists('pspell_new');
;)

Johno69

Mine is already like that.. Maybe you have an old version?

L'AltroWeb

No! I have 1.1.5 and i have see also 1.1.5 fresh download from this site :)

PatrickPriest

#305
I am getting an error when trying to warn someone:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'm not having a very easy time dealing with it, to say the least. I'm sorry if t' at line 2
File: /home/othforum/public_html/smf/Sources/VisualWarning11.php
Line: 147


Also...

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 's married

I heard Chad mention in an interview someone about her husband but ' at line 2
File: /home/othforum/public_html/smf/Sources/VisualWarning11.php
Line: 147


If you notice in both examples above... the error starts at a ' mark that is in the post.

Sometimes I also get

Hacking attempt....


It was working fine.  And I don't even think anything changed... and all of a sudden this.

And sometimes when I warn people... it works.

I have noticed that it seems to be on posts that have a ' mark in it.  But I did a test on another post that has an ' mark in it... and it worked.

So I don't know!!!  I love this script and would love for it to work.

PatrickPriest

I got this error just now:

Please try again. If you come back to this error screen, report the error to an administrator.

PatrickPriest

Can any one please help me?

Eleglin

Quote from: Dark-Wolf on June 15, 2008, 01:30:59 PM
Hi i have test to install but i receive error with post.php.
Your pack search:
   $context['show_spellchecking'] = !empty($modSettings['enableSpellChecking'] && function_exists('pspell_new');
Instead of:    $context['show_spellchecking'] = !empty($modSettings['enableSpellChecking']) && function_exists('pspell_new');
;)
Fixed this bug on the modification.xml of 1.41. Can't find this error anywhere else. If someone finds this error on the pack again, he can let a message here.
Updated the pack with spanish, portuguese and brazilian translation. Thnaks to Joomlamz and Deoxys.

@patrickpriest.
Please give more information if you want some help :
version of your forum ?
other Mods installed ?
which version of the mod ? (1.34 or 1.41) ?
No support by PM or Mail.

Eleglin

No support by PM or Mail.

PatrickPriest

#310
Quote from: Eleglin on June 28, 2008, 08:12:31 AM
@patrickpriest.
Please give more information if you want some help :
version of your forum ?
other Mods installed ?
which version of the mod ? (1.34 or 1.41) ?
version of your forum ?  SMF 1.1.5
other Mods installed ?  Thumbnail Topic Mod, Staff Page Mod, Visual Warning Mod, Disable_Decrease_Post_Count_Option
which version of the mod ? 1.41

All these mods have been installed for a few days before this error started happening.  The only thing that changed was I added a "Super Moderator" membergroup and set their permissions allowing them to warn and approve posts.

Other than that one change... nothing else changed on that day the errors started showing up.

I have converted my forms from XMB to SMF.  I have noticed this error only happens on the posts that were converted.  And it only happens on posts that have a ' mark in it.  If a post has been made SINCE I converted... I don't get the error.  And if the post does not have a ' mark in it... it works.

Eleglin

And when you edit these messages, do you have an error ?
No support by PM or Mail.

PatrickPriest

I get the error when I submit the warning level, timeframe, and reason form.  So it doesn't set the warning... and the messages don't get edited.

CesarManara

#313
Hey, i got an error in the template when i install de mod, my fórum is 1.1.5. mod 141
Error in Template!
/Themes/default/languages/Modifications.brazilian.php

/Themes/default/languages/Modifications.brazilian.php on line 60

51: $txt['visual_current_level']='Nivel Actual:';
52: $txt['visual_topic_raised']='Tópico onde levantou:';
53: $txt['visual_time_raised']='Momento em que levantou:';
54: $txt['visual_reason_raised']='Motivo para elevar:';
55: $txt['visual_level_details']='Novo nivel detalhes';
56: $txt['visual_submit']='Submeter';
57: $txt['visual_new_level']='Novo Nivel:';
58: $txt['visual_warning_management']='Gestão de Aviso';
59: $txt['visual_list_desc']='This lists all users that currently have some form of warning (levels 1,2 or 3. Level 4 is not listed as these members have alre

60: $txt['visual_member']='Membro';

61: $txt['visual_level']='Nivel';
62: $txt['visual_reason']='Motivo';
63: $txt['visual_when']='Quando';
64: $txt['visual_text_warn']='Aviso';


=======
What i do?????????

Eleglin

#314
Edit the line 59.
Replace :
$txt['visual_list_desc']='This lists all users that currently have some form of warning (levels 1,2 or 3. Level 4 is not listed as these members have alre

by  :
$txt['visual_list_desc']='This lists all users that currently have some form of warning (levels 1,2 or 3. Level 4 is not listed as these members have already been banned! You can choose to mass reduce members here or click the member to adjust level accordingly';

I will fix this in a few minutes in the package.
Sorry, I haven't see this error in the brazilian translation.
If you could translate this line, I'll add it in the pack. ;)
No support by PM or Mail.

Eleglin

Quote from: PatrickPriest on June 28, 2008, 02:17:45 PM
I get the error when I submit the warning level, timeframe, and reason form.  So it doesn't set the warning... and the messages don't get edited.
Don't know what you should do. I think that the problem has a link with the conversion from XMB, but I'm not sure. Maybe you should ask in the topic of support for the converter ?
No support by PM or Mail.

BOS4O

hi
when i click in the admin menu on the Warning Management it brings me to the index page
and when i click on the warn button on the messages it brings me again into the index page
and i cant do nothing with this mod
can anione tell me what is the problem
i checked all the tables in the misql they are fine
what to do?

Shy

I ran the test for this mod, but I'm getting an error with Display.template.php. Would anybody know why this is?

I'm on 1.1.5 and I had a previous version of this mod prior to updating, which I think is the root of my problem.

Eleglin

Quote from: Shy on June 30, 2008, 03:39:22 AM
I ran the test for this mod, but I'm getting an error with Display.template.php. Would anybody know why this is?

I'm on 1.1.5 and I had a previous version of this mod prior to updating, which I think is the root of my problem.
I suppose you have uninstall the previous version before ?

Quotehi
when i click in the admin menu on the Warning Management it brings me to the index page
and when i click on the warn button on the messages it brings me again into the index page
and i cant do nothing with this mod
can anione tell me what is the problem
i checked all the tables in the misql they are fine
what to do?
No support by PM  O:)
Version of the mod : ?
Version of SMF : ?
Other mods : ?
No support by PM or Mail.

BOS4O

the version is the last version of the mod - 1.41  O:)
the version of the smf is - 1.1.5  O:)
other mods see the picture - http://lfs-bg.net/boss/Image_00007.JPG  O:)

Advertisement: