Advertisement:

Author Topic: Subjects truncated to max 20 chars when posting in Greek!  (Read 44346 times)

Offline Kavadias

  • Semi-Newbie
  • *
  • Posts: 24
  • Gender: Male
    • Gamesway.gr
Re: Subjects truncated to max 20 chars when posting in Greek!
« Reply #20 on: December 31, 2004, 09:12:49 AM »
well i just made a test post here and with the ISO-8859-1 the greek titles do not display correctly. However, since in my boards (RC2) i use ISO-8859-1 and both greek and english display right (this are the 2 languages i am interested ιn) i suppose that won't change in 1.0? Or not?
« Last Edit: December 31, 2004, 09:25:22 AM by Kavadias »

Offline spiros

  • Local Moderator
  • SMF Hero
  • *
  • Posts: 1,718
  • Gender: Male
  • A different point of view
    • spiros.doikas on Facebook
    • doikas on LinkedIn
    • @greektranslator on Twitter
    • Greek Translation
Re: Subjects truncated to max 20 chars when posting in Greek!
« Reply #21 on: December 31, 2004, 09:34:51 AM »
No it will not change. You can use iso-8859-7 or windows-1253 for Greek. I would not  recommend using iso-8859-1 because Greek characters will be converted to entities (with ensuing problems in subject field and others as well as the creation of 5x larger files).

The problem with iso-8859-7 is that the Greek capital A is not parsed correctly appearing as an apostrophe instead. This problem does not occur with windows-1253.

Offline Kavadias

  • Semi-Newbie
  • *
  • Posts: 24
  • Gender: Male
    • Gamesway.gr
Re: Subjects truncated to max 20 chars when posting in Greek!
« Reply #22 on: December 31, 2004, 11:27:03 AM »
Well, in my index.english.php i have set encoding to "ISO-8859-1" but whenever i get in my forum it automatically sets itself to "ISO-8859-7" and it displays everything (titles, A capital whatever) correctly in both english and greek. May i ask if anyone knows why this happens?

Offline spiros

  • Local Moderator
  • SMF Hero
  • *
  • Posts: 1,718
  • Gender: Male
  • A different point of view
    • spiros.doikas on Facebook
    • doikas on LinkedIn
    • @greektranslator on Twitter
    • Greek Translation
Re: Subjects truncated to max 20 chars when posting in Greek!
« Reply #23 on: December 31, 2004, 11:37:49 AM »
Maybe you have hardcoded the encoding in your theme template. Or if you switch to Greek then it uses the default encoding found in index.greek.php.

Or perhaps this is your browser encoding. What encoding do you get when you view source code?

Offline Kavadias

  • Semi-Newbie
  • *
  • Posts: 24
  • Gender: Male
    • Gamesway.gr
Re: Subjects truncated to max 20 chars when posting in Greek!
« Reply #24 on: December 31, 2004, 11:46:37 AM »
Page source has "iso-8859-1" encoding Ι use the default theme and i don't even have an index.greek.php i am not using the greek translation yet. No user has reported problems with encoding in any browser (mozzila, IE, etc.) and i want it to stay that way when i upgrade to 1.0 and that's why i am asking.

Offline spiros

  • Local Moderator
  • SMF Hero
  • *
  • Posts: 1,718
  • Gender: Male
  • A different point of view
    • spiros.doikas on Facebook
    • doikas on LinkedIn
    • @greektranslator on Twitter
    • Greek Translation
Re: Subjects truncated to max 20 chars when posting in Greek!
« Reply #25 on: December 31, 2004, 12:08:45 PM »
There should be no problem with SMF final. Just open the index.greek and index.english files and change the default encoding. However, the correct encoding for Greek is  iso-8859-7 or windows-1253. Try it with your forum as it is now and switch the page to iso-8859-1... You will see extended ASCII characters. iso-8859-1 does NOT support Greek! See http://www.htmlhelp.com/reference/charset/ and http://www.cs.tut.fi/~jkorpela/unicode/greek.html

Offline Kavadias

  • Semi-Newbie
  • *
  • Posts: 24
  • Gender: Male
    • Gamesway.gr
Re: Subjects truncated to max 20 chars when posting in Greek!
« Reply #26 on: December 31, 2004, 12:26:18 PM »
yes i know that. i can see that. but i don't understand how i have the default encoding set to "iso-8859-1" and everyones browser views it automatically in "iso-8859-7" correct, and without the capital A problem??  :/