News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Simple Machines Forum 1.1.4 and 1.0.12 released

Started by Compuart, September 23, 2007, 05:02:50 PM

Previous topic - Next topic

Gary

Gary M. Gadsdon
Do NOT PM me unless I say so
War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

al-trance

Alejandro Letran
electronik.net
Guatemala

www.electronik.net

SleePy

Simplemachines Cowboy,
Feel free to start a new topic in the support boards with help on this. So we can keep support out of this topic as much as possible. It gets very ugly in here when people ask and try to help others with support in a single topic about multiple things.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

madfiddler

[quote[The package you are trying to download or install is either corrupt or not compatible with this version of SMF.[/quote]

Running 1.1.3

m

shadow82x

Mad - That may be caused by your host. Download an upgrade/update .sql files and run upgrade.php.
Colin B
Former Spammer, Customize, & Support Team Member

SleePy

madfiddler,

Please ask in support, or since you are a charter member you can open a ticket (and even have us perform the upgrade) :D
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

aldo

I didnt know SMF could do something like that! lol. Cool.

I think there might be a small error on the downloads page(I didnt download there just looked lol) and where it says Small update and says Using v1.1.2? Shouldnt it say Using v1.1.3? ???

nitins60

*still i am seeing SMF 2.0 beta 1, SMF @ 2006, Simple Machines LLC
here, using English (Britan).

青山 素子

Quote from: aldo on September 25, 2007, 12:28:50 AM
I think there might be a small error on the downloads page(I didnt download there just looked lol) and where it says Small update and says Using v1.1.2? Shouldnt it say Using v1.1.3? ???

I let one of the devs know and they will fix it shortly.

I'm just happy to see the server back after that downtime. SMF is so popular, the weight of the update notifications just crushed the server.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


metallica48423

nitins60, Please start a new topic for any inquiries about the upgrade for easier tracking.
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you
Search
Settings Repair Tool

Ðyєgσv

Yeah, server down and I couldn't upgrade because of that ¬¬ Thanks to God now I could do it and everything went smoothly  O:)

PD: Now I have my random avatars here ^^


rsw686

I'm just curious to why some of the errors with fixes I've seen in threads weren't fixed in 1.1.4.

For example in source/search.php

This line
   if (!is_array($_REQUEST['brd']) && !empty($_REQUEST['brd']))

Should be
   if (!empty($_REQUEST['brd']) && !is_array($_REQUEST['brd']))

Otherwise you receive an error in the error log about it not being found as the if statement is backwards.

Take source/querystring.php shows an error on the error_log about $new_var being undefined. It's missing the $new_var = array(); line shown below in the function

// Trim a string including the HTML space, character 160.
function htmltrim__recursive($var, $level = 0)
{
   global $func;

   // Remove spaces (32), tabs (9), returns (13, 10, and 11), nulls (0), and hard spaces. (160)
   if (!is_array($var))
      return isset($func) ? $func['htmltrim']($var) : trim($var, " \t\n\r\x0B\0\xA0");

   // Reindex the array
   $new_var = array();

   // Go through all the elements and remove the whitespace.
   foreach ($var as $k => $v)
      $new_var[$k] = $level > 25 ? null : htmltrim__recursive($v, $level + 1);

   return $new_var;
}
The Reptile File
Everything reptile for anyone reptile friendly

Aquaria Talk
Community for freshwater and saltwater aquariums enthusiasts

rsw686

The other issue is that the patch provided in this post doesn't match the 1.1.4 source for source/display.php

The patch says to

<search for>
            'name' => $attachment['filename'],
            'downloads' => $attachment['downloads'],
            'size' => round($attachment['filesize'] / 1024, 2) . ' ' . $txt['smf211'],
            'byte_size' => $attachment['filesize'],
            'href' => $scripturl . '?action=dlattach;topic=' . $topic . '.0;attach=' . $attachment['ID_ATTACH'],
            'link' => '<a href="' . $scripturl . '?action=dlattach;topic=' . $topic . '.0;attach=' . $attachment['ID_ATTACH'] . '">' . $attachment['filename'] . '</a>',
</search for>

<replace>
            'name' => htmlspecialchars($attachment['filename']),
            'downloads' => $attachment['downloads'],
            'size' => round($attachment['filesize'] / 1024, 2) . ' ' . $txt['smf211'],
            'byte_size' => $attachment['filesize'],
            'href' => $scripturl . '?action=dlattach;topic=' . $topic . '.0;attach=' . $attachment['ID_ATTACH'],
            'link' => '<a href="' . $scripturl . '?action=dlattach;topic=' . $topic . '.0;attach=' . $attachment['ID_ATTACH'] . '">' . htmlspecialchars($attachment['filename']) . '</a>',
</replace>

However in the 1.1.4 file on line 1151 it shows it without htmlspecialchars. So which is correct?
The Reptile File
Everything reptile for anyone reptile friendly

Aquaria Talk
Community for freshwater and saltwater aquariums enthusiasts

JayBachatero

The correct one is the one with the htmlspecialchars.

Also if any one has any issues with the upgrade please make a new topic to keep track of things better.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Nikki Sixx

Any changes in SMF 1.1.4 to the default template files?

metallica48423

Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you
Search
Settings Repair Tool

metallica48423

rsw, the packages have been regenerated and the missing htmlspecialchars is now there.

For anyone who already upgraded, if you used the full packages from the download site, you may wish to download it again, or you can patch it yourself.

In /Sources/Display.php

find:

link' => '<a href="' . $scripturl . '?action=dlattach;topic=' . $topic . '.0;attach=' . $attachment['ID_ATTACH'] . '">' . $attachment['filename'] . '</a>',

Replace:
'link' => '<a href="' . $scripturl . '?action=dlattach;topic=' . $topic . '.0;attach=' . $attachment['ID_ATTACH'] . '">' . htmlspecialchars($attachment['filename']) . '</a>',


You are not affected by this if you upgraded using the package manager
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you
Search
Settings Repair Tool

nizoo

um I am kinda noob, just started with this.. where do I put the files? :P
thanks for the updates I guess ^^

Dragooon


Advertisement: