Advertisement:

Author Topic: General support topic for Aeva Media (Latest release: July 28, 2010)  (Read 2607048 times)

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 57,797
  • Gender: Male
    • Kindred-999 on GitHub
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4780 on: September 22, 2010, 10:03:26 AM »
it should be pointed out that some mods install "cleanly" while others changes the target code (sometimes unnecessarily, as in the case with both ADKblog and articles)

In those cases, the ORDER of installation matters...  unless you are willing to install the failures manually (which is what I usually do... in the process, making sure that the target code is not improperly changed by removing a tab or a space)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Storman™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,027
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4781 on: September 22, 2010, 10:42:51 AM »
Quote
In those cases, the ORDER of installation matters...

Yes I quite agree.

I also needed to work out in which order they were going to be installed as this was also quite crucial.
Any Backup method is bettter than no Backup method....

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4782 on: September 22, 2010, 12:28:38 PM »
If you can manage it, then install the one that gets updated most frequently last.
Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Oya

  • Guest
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4783 on: September 22, 2010, 12:38:36 PM »
If you can manage it, then install the one that gets updated most frequently last.

theres also a mod for 2.0 that helps you see the order things were installed in

Offline Kat9119

  • Full Member
  • ***
  • Posts: 482
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4784 on: September 23, 2010, 08:51:54 AM »
Read through all the posts...can't find my specific question/answer

Using the latest Lite version...

Using this only to embed my own FLV files. How do I change the color of the player? Its silver. I want it black & white
« Last Edit: September 23, 2010, 09:45:12 AM by Kat9119 »

Offline madman71

  • Full Member
  • ***
  • Posts: 652
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4785 on: September 23, 2010, 03:57:04 PM »
PROBLEM SOLVED


Running 1.1.11
Aeva 1.3a

Aeva stats:
SMF Version: SMF 1.1.11     PHP Version: 5.2.14
PHP's Safe Mode is disabled, so it won't cause any trouble to Aeva Media. Good thing.
FFMPEG: No
GD2: Yes bundled (2.0.34 compatible)
ImageMagick: Yes 6.2.8 (IMagick: No - MagickWand: No)



I just moved my from one server to another.  The only issue that im having is that uploading images produces this error:

using Imagemagick as my handler i get this:

Code: [Select]
ImageMagick error:

convert: unable to open image `/home/madman71/public_html/forum2/mgal_data/tmp/tmp_preview_542882148_photo.jpg': Permission denied.

and


Code: [Select]
ImageMagick error:

convert: unable to open image `/home/madman71/public_html/forum2/mgal_data/tmp/tmp_thumb_542882148_photo.jpg': Permission denied.

and finally this one:


Code: [Select]
2: filesize() [<a href='function.filesize'>function.filesize</a>]: stat failed for /home/madman71/public_html/forum2/mgal_data/tmp/photo.JPG
File: /home/madman71/domains/mysite.us/public_html/forum2/Sources/Aeva-Media.php
Line: 634

When i go look at the post, it looks like this:




There appears to be a permission issue somewhere.  I have checked all directories and files and they are the correct setting.  This is on a dedicated host.

Could this permission issue be with ImageMagick not having permission? I mean, im not sure if applications need permission to access certain files or directories, but that's just my guess.


Now when i change my image handler to G2

I get these errors:


Code: [Select]
2: filesize() [<a href='function.filesize'>function.filesize</a>]: stat failed for /home/madman71/public_html/forum2/mgal_data/tmp/tmp_preview_17980852_photo1.jpg
File: /home/madman71/domains/site.us/public_html/forum2/Sources/Aeva-Media.php
Line: 634

and


Code: [Select]
2: rename(/tmp/php5Vm0wO_thumb,/home/madman71/public_html/forum2/mgal_data/tmp/tmp_preview_17980852_photo1.jpg) [<a href='function.rename'>function.rename</a>]: Permission denied
File: /home/madman71/domains/site.us/public_html/forum2/Sources/Aeva-Media.php
Line: 339

and

Code: [Select]
2: rename(/home/madman71/public_html/forum2/mgal_data/tmp/tmp_thumb_17980852_photo1.jpg,/home/madman71/public_html/forum2/mgal_data/albums/A/Dir_1/14656_thumb_17980852_photo1_JPG4a7032bffc2998306233c733baa69680_extjpg) [<a href='function.rename'>function.rename</a>]: No such file or directory
File: /home/madman71/domains/site.us/public_html/forum2/Sources/Aeva-Subs.php
Line: 2136
Code: [Select]
2: rename(/tmp/php5Vm0wO_thumb,/home/madman71/public_html/forum2/mgal_data/tmp/tmp_thumb_17980852_photo1.jpg) [<a href='function.rename'>function.rename</a>]: Permission denied
File: /home/madman71/domains/site.us/public_html/forum2/Sources/Aeva-Media.php
Line: 339


looks like another sort of permission error



and when i look at the post,it's missing that generic "missing image icon"




before i moved the site, i didnt have Imagemagick installed, i guess it was using the default G2


I dont care which handler that i use, i just need to get this fixed.

any sugguestions?

« Last Edit: September 23, 2010, 04:51:59 PM by madman71 »

Oya

  • Guest
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4786 on: September 23, 2010, 04:10:41 PM »
yup its still permission issues

the user running the webserver (apache) or the user running imagick commands doesnt have ability to write to those folders

Offline madman71

  • Full Member
  • ***
  • Posts: 652
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4787 on: September 23, 2010, 04:19:30 PM »
ahhh, ok. I'll investigate further with those 2 programs.

thanks!

Offline madman71

  • Full Member
  • ***
  • Posts: 652
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4788 on: September 23, 2010, 04:51:22 PM »
problem now solved!

I learned something new today.


thanks for the tip,  Oya

Offline Bruno36

  • Full Member
  • ***
  • Posts: 570
  • Gender: Male
    • Scooter Chinois 4T
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4789 on: September 24, 2010, 02:34:10 PM »
Good evening!

I have an error message when I integrate video in a topic
(Integration off, limit reached)
(Intégration désactivée, limite atteinte)
http://www.scooter-chinois-4t.fr/forum/mecanique-et-entretien/changement-galet-sur-scooter-4t-chinois/msg6/#msg6
Bruno36 the French
SMF 2.0.9

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 57,797
  • Gender: Male
    • Kindred-999 on GitHub
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4790 on: September 24, 2010, 02:39:19 PM »
seems pretty clear... it's not a bug. You have reached the limit which you set for either the number of videos in a single topic/thread, or the number of videos displayed on a single screen.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline gamerzworld

  • Semi-Newbie
  • *
  • Posts: 21
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4791 on: September 24, 2010, 07:48:11 PM »
Posting a video from Vimeo will result in a "Fatal error: Cannot unset string offsets in /home/gtastunt/public_html/forums/Sources/Subs-Aeva.php on line 866" PHP error when they click post. It seems to stem from video title lookups. Perhaps the method you use for video title lookups for Vimeo videos has changed? Oh and I also noticed that Imeem is still in the site lists. The site was taken down some time ago.

Offline Loginsvarios

  • Semi-Newbie
  • *
  • Posts: 46
Change name in tab
« Reply #4792 on: September 25, 2010, 02:58:40 PM »
Greetings.

Is there a way to change the name ("Media") of the sections tab?

My forum is in Spanish and I want to change from "Media" to "Galería", by the way the Spanish translation of the official website says "Media" too.


Any help would be appreciated.

Offline YogiBear

  • SMF Hero
  • ******
  • Posts: 1,932
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4793 on: September 25, 2010, 04:45:16 PM »
There was a post on how to do this but one workaround is to install the mod Custom Tab by Deprecated (Hadesflames and JohnnyCcCcCc have also made extra tab mods) then name it to what you want and use the Gallery's URL so when someone clicks onto that tab it directs them to your Gallery.
 
Two tabs leading folk to your Gallery can't be bad.  :)
SMF v2.0.15  Mods : Ohara YouTube Embed v1.2.9,  Custom Tab v1.2 , Bakers' Dozen Pages v1.2 , SMFPacks Shoutbox v1.1,  Board Color & Icons v1.1 , Simple Image pload , Snow & Garland v1.4

Offline Loginsvarios

  • Semi-Newbie
  • *
  • Posts: 46
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4794 on: September 25, 2010, 08:51:41 PM »
Two tabs leading folk to your Gallery can't be bad.  :)
I think that would be too much "Gallery" for my users. xD

Any idea about how just rename the original tab?


P.D: Thanks for your answer.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 57,797
  • Gender: Male
    • Kindred-999 on GitHub
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4795 on: September 25, 2010, 09:01:20 PM »
all of the strings for Aeva are defined in a language file.... so changing the text should be simple as changing the file
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Loginsvarios

  • Semi-Newbie
  • *
  • Posts: 46
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4796 on: September 25, 2010, 09:32:09 PM »
all of the strings for Aeva are defined in a language file.... so changing the text should be simple as changing the file
I searched the word "Media" in all the files (from the original package and from the Spanish translation package of the official site) and it only appears 2 times:

· In the "install-2.0.xml" file
· In the "Modifications.spanish_es-utf8.php"

I changed it from "Media" to "Galería" (cleaned cache and refreshed with F5)... and nothing changes.

Oya

  • Guest
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4797 on: September 25, 2010, 09:55:21 PM »
Loginsvarios: also go to admin / maintenance / routine / empty file cache

Offline Loginsvarios

  • Semi-Newbie
  • *
  • Posts: 46
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4798 on: September 26, 2010, 06:20:05 AM »
Loginsvarios: also go to admin / maintenance / routine / empty file cache
Nothing, the tab still remains as "Media"...

I can't believe that such a simple thing could be so complicated.

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,503
  • Gender: Male
    • dragomano on GitHub
    • @dragomano on Twitter
    • Russian translations for SMF mods
Re: General support topic for Aeva Media (Latest release: July 28, 2010)
« Reply #4799 on: September 26, 2010, 06:51:06 AM »
Try find in Subs.php:
Code: [Select]
(isset($txt['aeva_gallery']) ? $txt['aeva_gallery'] : 'Media')and replace with:
Code: [Select]
'Galeria'