News:

Wondering if this will always be free?  See why free is better.

Main Menu

Anonymous Board Mod

Started by JMV290, November 04, 2007, 07:12:46 PM

Previous topic - Next topic

live627

Quote from: Robin1989 on February 03, 2011, 12:47:08 PM
or do you know of any paid alternatives as it is a mod i would pay a fair amount for
There is one for 20.00USD at http://dev.live627.com/ and is tested to work with SMF 2.0 RC3 and later.

If Kindred et al don't like this they can remove it.

Kindred

hopefully that mod for sale is not using my coding... i am willing to let someone take the mod over... but never paid.
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

live627

Quote from: Kindred on February 21, 2011, 04:46:40 PM
hopefully that mod for sale is not using my coding
It's not... as I said back in August I wasn't aware of your mod

memiller

Quote from: Kindred on February 21, 2011, 01:59:07 PM
That is odd.... I wonder why caching would interfere with this mod...

BTW: Try installing the mod for disabling the eval function....    that way we can see where the actual error is happening.


I have had that installed for a while.  I turn off eval and all I get is:

Notice: Undefined index: anonymousBoard in /usr/local/www/apache22/data/xxxxxxxx.org/forum/Themes/default/Post.template.php on line 624


Kindred

and what are lines 620-625 of your post.template.php?
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

memiller

Here are lines 613 to 633:

                // Show some useful information such as allowed extensions, maximum size and amount of attachments allowed.
                if (!empty($modSettings['attachmentCheckExtensions']))
                        echo '
                                                                        ', $txt['smf120'], ': ', $context['allowed_extensions'], '<$
                echo '
                                                                        ', $txt['smf121'], ': ', $modSettings['attachmentSizeLimit'$
                                                                </td>
                                                        </tr>';
        }

        // anonymous board mod
        if ( $context['anonymousBoard'] )
                echo '
                                                        <tr>
                                                                <td colspan="2">
                                                                        <b>' . $txt['Post_anonymous'] . '</b>
                                                                        <input type="checkbox" name="post_unanon" />
                                                                </td>
                                                        </tr>';



Line 624 is "        if ( $context['anonymousBoard'] )"


Kindred

ah. I see the problem.

naughty me...  I just commented on the same error in someone else's mod.


that line should be...
if (!empty($context['anonymousBoard'] ))

that will stop the error, but won't fix the caused problem (which is that the board is not recognizing that you should be able to post anonymously)

The error basically means that the context value is not being set, since it is not set, the system sees it as undefined... but since it is not set, the system won't know that the board is set to be anonymous.

argh.

well....   I may just have to update the darned mod in order to get rid of the problems. lol

Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Neek

man how come no one is willing to officially takeover this mod? there's demand for it!

if i had the know-how i would totally step up to the plate but i'm too dumb. if you're someone who has already supported it unofficially why not just do it officially? please?

wanting this for 2.0 RC5 badly...

live627


memiller

Kindred:
It is exactly as you predicted. After editing that line to check for empties, the error is no longer reported, but the symptoms remain the same: Anonymous works for replying to an existing topic, but starting a new topic throws the error.

BTW, if you do find time to update the mod, it will make some folks very happy.

Thanks again,
  Mark

summever

Hi there, I followed every step to update this mod, but i still got a error, which is said:

$txt['makeBoard_anonymous']='Make this board anonymous?'; $txt['Post_anonymous'] = 'Post this message with your username (NOT ANONYMOUS)';
Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in public_html/Sources/Subs-Boards.php on line 1519

what does it mean? Thank you so much!!

Kindred

#191
summever, sorry, I didn't see your post.
It looks like, however you did the edits, that your file is missing the newline between those statements. or perhaps missing a single quote in the line BEFORE that one.



For every one else....   GOOD NEWS!

JMV290 has agreed to take over this mod for 2.0! He says that he is close to getting his code updated and will be posting a 2.0 version shortly!   I have transferred the mod to his control (as you may note from the fact that he is now the original poster. :) )
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

MiY4Gi

Quote from: Kindred on July 14, 2011, 08:57:25 AM
For every one else....   GOOD NEWS!

JMB290 has agreed to take over this mod for 2.0! He says that he is close to getting his code updated and will be posting a 2.0 version shortly!   I have transferred the mod to his control (as you may note from the fact that he is not the original poster. :) )

AWESOME!!!!! My patience paid off. I see there's now a 2.0 compatible version on the mod page. GREAT STUFF!! Can't wait to try it out. And here I thought I'd have to wait a year for you to update the mod.  ;D

Check out my new website, MyAnimeClub.net. I plan to create the largest anime community, and most fun and user-friendly anime forum in the world. It's still in the development stage though.

Bugo


Kindred

I explained the process to you back then. You never contacted me and told me that you would take over distribution and support for the mod, so nothing was ever done. JMV290 DID do so....
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

MiY4Gi

I installed the mod, had to do a manual edit of the manageboards.php file for the following lines:

Code (Find) Select

$boardOptions['posts_count'] = isset($_POST['count']);
$boardOptions['override_theme'] = isset($_POST['override_theme']);


Code (Add after) Select


$boardOptions['anonymous_board'] = isset($_POST['anonymous_board']);


The Facebook Like mod added in a line between the ['posts_count"] and ['override_theme'} lines, so I added in new line just after the ['override_theme'] line. I'm pretty sure I did that correctly.

The problem is, the mod isn't working. I haven't noticed any changes in the board which I marked as Anonymous. I created a new topic, but there was no sign of the option to post un-anonymously, nor was my completed post anonymous. It's as if the mod wasn't installed at all.

Let me clear my cache and cookies and try again.

Check out my new website, MyAnimeClub.net. I plan to create the largest anime community, and most fun and user-friendly anime forum in the world. It's still in the development stage though.

MiY4Gi

It's still not working.  :(
Check out my new website, MyAnimeClub.net. I plan to create the largest anime community, and most fun and user-friendly anime forum in the world. It's still in the development stage though.

MiY4Gi

And where has this new developer gone? Is this like a hit and run?
Check out my new website, MyAnimeClub.net. I plan to create the largest anime community, and most fun and user-friendly anime forum in the world. It's still in the development stage though.

live627


MiY4Gi

Quote from: live627 on July 18, 2011, 03:47:26 AM
Would this one help? http://livemods.net/index.php?action=mods#56

Well, I'm sure your mod will work, but if you can get the same functionality for free, why pay? :D I'm not really in any hurry either since I'm just playing around with mods on my newly made forum. Once everything else is setup, only then will I consider paid mods, like the Advanced Prefix mod, and your Anonymous Board Mod.
Check out my new website, MyAnimeClub.net. I plan to create the largest anime community, and most fun and user-friendly anime forum in the world. It's still in the development stage though.

Advertisement: