Advertisement:

Author Topic: PM to New Registered Users  (Read 211420 times)

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: PM to New Registered Users
« Reply #20 on: February 08, 2005, 05:13:15 AM »
This may likely be caused by having other mods installed.

-[Unknown]

Offline diplomat.

  • SMF Friend
  • Full Member
  • *
  • Posts: 545
  • Gender: Male
  • avidSOUND
    • avidSOUND
Re: PM to New Registered Users
« Reply #21 on: February 08, 2005, 09:12:32 AM »
It already was 777. I'm using Smf in combination with mambo btw. I entered my adminpanel outside of Mambo before installing it as that should get better results... I Applied the mod and that file still said Failed. Nothing happened, no link in Admin it seems, nothing.

Same here...and it leaves a ghost of itself on the edit settings page.

Jim

add this to Modifications.english.php
Code: [Select]
$txt['send_welcomeIM'] = 'Send welcome personal message to new members';
$txt['welcomeIM_userid'] = 'User ID of sender<div class="smalltext">Leave blank to send with an unregistered name.</div>';
$txt['welcomeIM_subject'] = 'Subject of welcome message';
$txt['welcomeIM_body'] = 'Body of welcome message';
avidSOUND.com: Where Aspiring Musicians Can Be HEARD!

Offline bobert

  • Semi-Newbie
  • *
  • Posts: 26
  • Gender: Male
    • The Computer Guy
Re: PM to New Registered Users
« Reply #22 on: February 08, 2005, 09:13:39 AM »
Where would you add the code???
All the best,
Kyle

Offline diplomat.

  • SMF Friend
  • Full Member
  • *
  • Posts: 545
  • Gender: Male
  • avidSOUND
    • avidSOUND
Re: PM to New Registered Users
« Reply #23 on: February 08, 2005, 09:19:27 AM »
add it right before the ?>
avidSOUND.com: Where Aspiring Musicians Can Be HEARD!

Offline guider

  • Jr. Member
  • **
  • Posts: 268
Re: PM to New Registered Users
« Reply #24 on: February 08, 2005, 09:24:03 AM »
Nothing happens. Exactly where in admin should I see a link pop up?

Offline bobert

  • Semi-Newbie
  • *
  • Posts: 26
  • Gender: Male
    • The Computer Guy
Re: PM to New Registered Users
« Reply #25 on: February 08, 2005, 03:17:39 PM »
This kind of works. I can get everything to work now, and it sends to new members. BUT the labels still don't appear in the Admin area. The text boxes do, but the labels don't. Thanks.
All the best,
Kyle

Offline guider

  • Jr. Member
  • **
  • Posts: 268
Re: PM to New Registered Users
« Reply #26 on: February 08, 2005, 03:34:03 PM »
Where in admin are the boxes?

Offline bobert

  • Semi-Newbie
  • *
  • Posts: 26
  • Gender: Male
    • The Computer Guy
Re: PM to New Registered Users
« Reply #27 on: February 08, 2005, 03:37:28 PM »
It's under edit features and options... under this stuff:

Method of registration employed for new members     
Notify administrators when a new member joins    
Require reactivation after email change    
Send welcome email to new members

ok?
All the best,
Kyle

Offline guider

  • Jr. Member
  • **
  • Posts: 268
Re: PM to New Registered Users
« Reply #28 on: February 08, 2005, 04:23:45 PM »
Ah yes see it. What's that 0 mean?

Offline Kirby

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,040
  • Gender: Male
Re: PM to New Registered Users
« Reply #29 on: February 08, 2005, 04:31:35 PM »
thats the ID of the user that the PM is sent with

Offline guider

  • Jr. Member
  • **
  • Posts: 268
Re: PM to New Registered Users
« Reply #30 on: February 08, 2005, 05:41:48 PM »
I see. So 1=sent from Admin?

Offline guider

  • Jr. Member
  • **
  • Posts: 268
Re: PM to New Registered Users
« Reply #31 on: February 08, 2005, 05:58:14 PM »
I filled in 1 and registered a new member through adminpanel, but no new message?

Offline diplomat.

  • SMF Friend
  • Full Member
  • *
  • Posts: 545
  • Gender: Male
  • avidSOUND
    • avidSOUND
Re: PM to New Registered Users
« Reply #32 on: February 08, 2005, 06:36:47 PM »
make sure you have Send welcome personal message to new members checked
avidSOUND.com: Where Aspiring Musicians Can Be HEARD!

Offline guider

  • Jr. Member
  • **
  • Posts: 268
Re: PM to New Registered Users
« Reply #33 on: February 08, 2005, 06:42:11 PM »
Its checked. Did you create the new user through admin? If so, what could be wrong?

Offline diplomat.

  • SMF Friend
  • Full Member
  • *
  • Posts: 545
  • Gender: Male
  • avidSOUND
    • avidSOUND
Re: PM to New Registered Users
« Reply #34 on: February 08, 2005, 06:59:36 PM »
i tried it on my test forum first with registering regularly, i never registered thru the admin panel, but seems like it should still send the pm. :-\
avidSOUND.com: Where Aspiring Musicians Can Be HEARD!

Offline Kirby

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,040
  • Gender: Male
Re: PM to New Registered Users
« Reply #35 on: February 08, 2005, 07:04:27 PM »
i haven't tested it with admin account creation..i don't think it works though

Offline bobert

  • Semi-Newbie
  • *
  • Posts: 26
  • Gender: Male
    • The Computer Guy
Re: PM to New Registered Users
« Reply #36 on: February 08, 2005, 10:30:55 PM »
I doubt it would work through the admin panel. I think it referneces a different file. BTW, I still need help with getting the field descriptions to show up in the Admin Panel
All the best,
Kyle

Offline Kirby

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,040
  • Gender: Male
Re: PM to New Registered Users
« Reply #37 on: February 08, 2005, 11:14:31 PM »
It already was 777. I'm using Smf in combination with mambo btw. I entered my adminpanel outside of Mambo before installing it as that should get better results... I Applied the mod and that file still said Failed. Nothing happened, no link in Admin it seems, nothing.

Same here...and it leaves a ghost of itself on the edit settings page.

Jim

add this to Modifications.english.php
Code: [Select]
$txt['send_welcomeIM'] = 'Send welcome personal message to new members';
$txt['welcomeIM_userid'] = 'User ID of sender<div class="smalltext">Leave blank to send with an unregistered name.</div>';
$txt['welcomeIM_subject'] = 'Subject of welcome message';
$txt['welcomeIM_body'] = 'Body of welcome message';

that didn't work? remember Themes/default/Modifications.english.php
it should work o_O

Offline bobert

  • Semi-Newbie
  • *
  • Posts: 26
  • Gender: Male
    • The Computer Guy
Re: PM to New Registered Users
« Reply #38 on: February 08, 2005, 11:26:21 PM »
All fixed guys Thank you soo much! I have no idea what file I was edinting before, but it certainly wasn't this one. Also, you have to edit the file of the there you are on, which may not be 'default'
All the best,
Kyle

Offline Kirby

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,040
  • Gender: Male
Re: PM to New Registered Users
« Reply #39 on: February 08, 2005, 11:31:03 PM »
glad ya got it working