• Welcome to Simple Machines Community Forum. Please login or sign up.
January 21, 2022, 07:17:02 AM

News:

Wondering if this will always be free?  See why free is better.


MCLegendII.1

Started by Bulakbol, January 28, 2008, 07:44:55 PM

Previous topic - Next topic

arockets

This mod is great, thanks!

I have 2 questions:

1.  I went through the posts here to see if I could find the answer myself, but was unsuccessful.  Where do I look to find the group ID's?

2.  Is it possible to make them bold type?

Bulakbol

May 13, 2009, 04:58:22 PM #521 Last Edit: May 13, 2009, 05:07:51 PM by Bulakbol
@Blinker
Sorry, I have no time to look at the mod you are using.


@arockets
Go to Admin => Membergroups, then hover your mouse over the name of your membergroup. In your browser's status bar at the bottom of your browser, if you hover your mouse over the Administrator group, you'll see something like ... sa=members;groups=1.

To make the legend bold, edit your default/BoardIndex.template.php.
Code (find) Select
<span class="smalltext">[' . implode(']&nbsp;&nbsp;[', $context['membergroups']) . ']</span>
Code (replace) Select
<span class="smalltext">[<b>' . implode('</b>]&nbsp;&nbsp;[<b>', $context['membergroups']) . '</b>]</span>
Please do not PM me for support · My Mods and Theme · SMF Coding Guidelines · Modifications Approval Guidelines

MDragon

I do not seem to have this:

"Admin -> Features and options -> Membergroup legend display arrangement"

in my options.  Once I get to Features and Options I cannot find "Membergroup legend display arrangement"

The mod works but I'm unable to edit to add new membergroups because I don't have this option.

Bulakbol

@MDragon
Version 1.1.8. Open your Sources/ModSettings.php and look for
// Stats, compression, cookies.... server type stuff.
Before that line, there should be
// MCLegendII
array('text', 'arrange_mclegend'),
'',


Make sure those lines exist.
Please do not PM me for support · My Mods and Theme · SMF Coding Guidelines · Modifications Approval Guidelines

Roger Rabbit

June 02, 2009, 04:05:04 AM #524 Last Edit: June 02, 2009, 04:15:29 AM by Roger Rabbit
good i'm using mystic jade themes and i checked the one you have mentioned above and is exist...however, i can't still find word "Membergroup legend display arrangements".

Thanks in advance.


nevermind about my question...i found the solution....

thanks for this great mod... ;)

musicmad10

Quote from: Bulakbol on May 20, 2009, 05:49:18 AM
@MDragon
Version 1.1.8. Open your Sources/ModSettings.php and look for
// Stats, compression, cookies.... server type stuff.
Before that line, there should be
// MCLegendII
array('text', 'arrange_mclegend'),
'',


Make sure those lines exist.
hi i have the same problem as McDragon, and I've checked for those lines in the modsettings.php and they are there. is there any other way of editing this mod?
Also should the usernames be in colour when people post on the forum? because thats not happening for me?

Bulakbol

@Roger Rabbit
8) Congratz!

@musicmad10
I am not sure what causes not to show up. Maybe the readme file is incorrect. Go to Admin -> Features and options -> Basic Features. Then look for Membergroup legend display arrangement. text box.
Regarding the member colors, install this mod.
Member Color Link
Please do not PM me for support · My Mods and Theme · SMF Coding Guidelines · Modifications Approval Guidelines

Diamond1444

Can someone please tell me how I can get this to work with the Default Multi Colour Theme?

Bulakbol

@Diamond1444
Did you try to install this mod? What files failed the search test? If no errors, then all you have to do is a simple edit to your theme's BoardIndex.template.php.
Please do not PM me for support · My Mods and Theme · SMF Coding Guidelines · Modifications Approval Guidelines

Diamond1444

It installed fine and it works on the Core theme.  I don't know what to edit in the template.  If you can tell me, I'll sure try.  Thanks!

Bulakbol

Edit the BoardIndex.template.php of your theme manually.
Please do not PM me for support · My Mods and Theme · SMF Coding Guidelines · Modifications Approval Guidelines

Diamond1444

But what am I taking out or putting in?  That's where I'm confused.  Sorry.

Bulakbol

@Diamond1444
You can compare the code here.
http://custom.simplemachines.org/mods/index.php?action=parse;mod=1077;attach=72903;smf_version=1.1.8

If you need assistance, attach the file in question and we'll see what we can do.
Please do not PM me for support · My Mods and Theme · SMF Coding Guidelines · Modifications Approval Guidelines

Diamond1444

Oh, if you could I would really appreciate it!  I just can't find it - and I can't find the line to modify to make it bold either.  If you can help that would be wonderful.  Thank you!

Bulakbol

@Diamond1444
Your edited BoardIndex.template.php is attached. Use this file after installation. Make a backup of the original file first.
Please do not PM me for support · My Mods and Theme · SMF Coding Guidelines · Modifications Approval Guidelines

Diamond1444

Thank you so much!!! :D

mquin

It seems that this mod only works on certain themes, i'm using "Uncomplicated v1", and it doesn't show the legend at the bottom, any help to add it to the current theme?

Thanks,

Mquin
Hello all, I have a site that runs SMF, and it has software that myself and a friend make, if you would like to test them out please visit the site http://synytx.net/ [nofollow]

Kyzer

Could you tell me how to install this mod on the World of Warcraft Theme?
Runic WoW World of Warcraft Gaming Forums

Bulakbol

@Diamond1444
You are welcome. Thank you too for using/trying this mod.

@mquin and Kyzer
Go to Admin => Current Theme => Themes Settings, then disable (untick checkbox) Show group key on board index.

@mquin
Version 2.0 RC1 theme. In your BoardIndex.template.php,
Code (find) Select
if (!empty($settings['show_group_key']) && !empty($context['membergroups']))

echo '

<br />[' . implode(']&nbsp;&nbsp;[', $context['membergroups']) . ']';

Code (replace) Select
if (!empty($context['membergroups']))
echo '<div style="padding-top: 2px; margin-top: 2px; border-top: 1px solid #c6c6c6;">
[' . implode(']&nbsp;&nbsp;[', $context['membergroups']) . ']', '</div>';




@Kyzer
Version 2.0 RC1 theme. Go to package manager, click on the MCLegendII RC1 [Install] link, scroll down the page, if test are successful, tick the checkbox for World Of Warcraft. Click [Install Now] button.
Please do not PM me for support · My Mods and Theme · SMF Coding Guidelines · Modifications Approval Guidelines

Narheru

Hello^^!
I want to install this mod on theme Outline 115. How can I do it?
I have SMF 1.1.9

Advertisement: