News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

What Have You Done Since The Bridge Is Gone?

Started by Jiveturkey, February 13, 2008, 06:13:25 PM

Previous topic - Next topic

Jiveturkey

I'm still running with an older version of Joomla and using the bridge.  I've been searching for a solution for months now but haven't really come up with anything useful.

A bridge isn't even required in my case.  I don't have Joomla users and a working Wrapper would actually be the easiest way for me to move on.  Unfortunately the Wrapper's Auto Height option just doesn't work.

What is everyone else doing?  Is there a simple solution for sites like mine that I'm just over looking?



www.coastercommunity.com

locutusweb

You could go for a stand alone forum. Just built in your joomla template header in the header of SMF.

Jiveturkey

I've seen others mention that but I don't have any idea where to start.  Is it just a matter of copying some HTML code into the SMF header?

Kindred

no... it is somewhat more complicated than that....
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Jiveturkey

That's what I keep hearing.  Are there instructions anywhere?

青山 素子

Try looking over the Online Manual and also in the graphics board here. The simplest edit would be to make SMF appear wrapped, which would involve editing only index.template.php.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


Jiveturkey

This looks like a great option and it looks like it can be done by someone with little to no coding skills.

Thanks a ton!!!

I wonder if there are similar instruction for Gallery2?

Ronny

I've modified joomla.php (passw hash), upgraded to the latest J 1.0.14, still using the smf_bridge (unwrapped).
Later I will migrate to J1.5.1 with the very promissing JFusion_plugin. So Joomla and SMF still connected :-)

AbBh

I tried the Joomlahacks bridge after being told that it was supposed to be "better". I wanted to migrate to Joomla 1.5 so I was converting it for Joomla 1.5, but thats really messed up. It modifies both SMF and Joomla which is neither necessary nor ideal. So I decided to modify Oristo's bridge and am using it with Joomla 1.5.
hxxp:www.simplycricket.net [nonactive]

arillas

Quote from: Ronny on February 20, 2008, 01:09:57 PM
I've modified joomla.php (passw hash), upgraded to the latest J 1.0.14, still using the smf_bridge (unwrapped).
Later I will migrate to J1.5.1 with the very promissing JFusion_plugin. So Joomla and SMF still connected :-)
That's very interesting can you tell us how to do that too? it sounds to be a nice solution. (If there are no security risks) 

arillas

Having searched the forum here, I installed localy my old bridged joomla-smf and upgrated to 1.015 .
The only think that does not work is that the joomla users are not anymore syncronised and any functions that are featured for joomla registered members do not work either.
It llooks that if you are using joomla only to add and manage your content withour any user ineractivity , you can still use the brigde that from now is running only for showing the login logout module for the smf members as well as the ability to have your forum wrapped in to your joomla.
I tried to register a new member and it worked perfectly, I haven;t tried yet the password reminder. the other think that would not work is the "whosonline" module from joomla.

Please tell me if I'm wrong 

[MaxX]

Quote from: arillas on February 24, 2008, 01:48:44 PM
Quote from: Ronny on February 20, 2008, 01:09:57 PM
I've modified joomla.php (passw hash), upgraded to the latest J 1.0.14, still using the smf_bridge (unwrapped).
Later I will migrate to J1.5.1 with the very promissing JFusion_plugin. So Joomla and SMF still connected :-)
That's very interesting can you tell us how to do that too? it sounds to be a nice solution. (If there are no security risks) 

I would like to know more about that too! Can you upload the modified file somewhere? Also what did you do with josHashPassword($password) ? I could not find where it is being called.

Do check your PM :)

t-readyroc

It actually looks like JFusion [nofollow] will work out-of-the-box with 1.5.1 & 1.1.4 [nofollow].  I'd actually love to hear from anyone else who's done a 1.0.x/1.1.4/bridge > 1.5.1/1.1.4/JFusion upgrade.  My hosting's currently only offering the 1.5.1 upgrade path from a 1.0.13 install  ::)

M70


Slack


baijianpeng

I will wait for some instructions on how to make a bridge between Joomla! 1.5.x and SMF 2.0.x .

For now, it seems the latest JSMF 2.0.2.1 brdige can work for Joomla! 1.0.15 and SMF 1.1.4 very well.
JoomlaGate: The way to the World of Joomla!

http://www.joomlagate.com

kai920

Unfortunately a couple of my other components require Joomla (Joomla Tags, Jomcomment) so switching back to Mambo is not really an option for me :(

arillas

Quote from: arillas on February 24, 2008, 03:13:34 PM
Having searched the forum here, I installed localy my old bridged joomla-smf and upgrated to 1.015 .
The only think that does not work is that the joomla users are not anymore syncronised and any functions that are featured for joomla registered members do not work either.
It llooks that if
you are using joomla only to add and manage your content withour any user ineractivity , you can still use the brigde that from now is running only for showing the login logout module for the smf members as well as the ability to have your forum wrapped in to your joomla.
I tried to register a new member and it worked perfectly, I haven;t tried yet the password reminder. the other think that would not work is the "whosonline" module from joomla.

Please tell me if I'm wrong 

I tried that online and it works fine!
the password reminder worked and members are registering , loging in posting , etc 
the only think I can not fix is that on he mod_smf_login module If I click on the login or register link it gives a slightly wrong link.

instead of http://website.com/joomlapage/component/option,com_smf/Itemid,165/action,login
it gives:
http://website.com/joomlapage/http://website.com/joomlapage/component/option,com_smf/Itemid,165/action,login

Similar  for the registration link
instead of:
http://website.com/joomlapage/component/option,com_smf/Itemid,165/action,register/lang,en/
it gives:
http://website.com/joomlapage/http://website.com/joomlapage/component/option,com_smf/Itemid,165/action,register/lang,en/
EVERY OTHER LINK that the bridge makes works fine!
any ideas where to look for fixing this?

Superdaantje

I went back to Mambo.

The future is bright the future is Mambo
Greetz
Superdaantje.nl

.
Joomlabridge.org SMF Bridge Support, Downloads and Joomla Video Tutorials

SlammedDime

SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Advertisement: