News:

Wondering if this will always be free?  See why free is better.

Main Menu

AvatarOnBoard

Started by Bulakbol, February 18, 2008, 10:39:03 PM

Previous topic - Next topic

D.Joe

Quote from: phantomm on June 30, 2012, 02:50:47 AM
This was for showing avatar from topic starter, because by default mod shows avatar from last poster. This edits aren't required.
All you need is in reply #468 :)
Not unique table/alias: 'mav'
File: /home/rasserve/public_html/forum/Sources/Subs-BoardIndex.php
Line: 78

:-\

Adrek

can you attach this file?
Polskie wsparcie SMF na simplemachines.org

the simplest solution is most likely the right one

D.Joe

I solved, i got another 2 problems : how do i remove the noavatar on redirects and how do I remove last post in child board's description

Adrek

Quote from: D.Joe on July 05, 2012, 12:43:46 PM
I solved
How did you solved it?

Quote from: D.Joe on July 05, 2012, 12:43:46 PM
how do i remove the noavatar on redirects
I don't use this mod anymore, so pure guess...:
In BoardIndex.template:
Code (Find) Select

if (!$modSettings['disable_avatar'])

Code (Replace with) Select

if (!$modSettings['disable_avatar'] && !$board['is_redirect'] && !empty($board['last_post']['id']))
Polskie wsparcie SMF na simplemachines.org

the simplest solution is most likely the right one

D.Joe

Quote from: phantomm on July 05, 2012, 01:41:34 PM
How did you solved it?
There was some duplicates.
And how about removing 'last post' from child boards

xeon365

Would also like to get $topic['last_post']['member']['avatar']

to $topic['first_post']['member']['avatar']

only it has no data for that.

And have the avatar on the left side of the subject title, preferably in a new table cell... I can't understand why this isn't part of SMF, was looking around for ages on how to get this done on SMF, as its so populiarzed by XenForo

Anyway hopefully some more code bits to get it working would be awesome.. better yet a packaged mod.

ps most awful and hard to get right looking captcha I have ever seen smf..

xeon365

seriously no one can fix this mod up ?

Adrek

There's nothing to fix. Mod works as author wanted to...
Polskie wsparcie SMF na simplemachines.org

the simplest solution is most likely the right one

xeon365

Then how about 'improve'

first poster avatar is what some of us actually want..

TheListener

Quote from: xeon365 on July 10, 2012, 11:05:12 PM
Then how about 'improve'

first poster avatar is what some of us actually want..

The mods author hasn't been active for a long time so that will not happen soon.

Arantor

Quote from: xeon365 on July 10, 2012, 11:05:12 PM
Then how about 'improve'

first poster avatar is what some of us actually want..

People being nice is what some others of us actually want.
Holder of controversial views, all of which my own.

xeon365

"The mods author hasn't been active for a long time so that will not happen soon."

That's a shame, I can see why people dump smf.

TheListener

Quote
That's a shame, I can see why people dump smf.

Nobody said anything about being dumped.


BaghdadGhost

Hi all,

I tried phantomm changes on 2.0.2. its shows avatars and all good except these two errors in error log


http://localhost/smf/index.php?
8: Undefined index: disable_avatar
File: .../Themes/theme/BoardIndex.template.php (main sub template - eval?)
Line: 174

this line

if (!$modSettings['disable_avatar'])



http://localhost/smf/index.php?board=1.0
8: Undefined index: disable_avatar
File: .../Themes/theme/MessageIndex.template.php (main sub template - eval?)
Line: 286

this line


if (!$modSettings['disable_avatar'])

any suggestions?


BaghdadGhost

OK I got it. this error is related to a missing steps during manual installation. those steps were not mentioned with the manual edit installation. If you want this mod to work with 2.0.2 without any errors, after you do all edits run these two queries


SHOW COLUMNS FROM {$db_prefix}settings
LIKE 'disable_avatar'




INSERT IGNORE {$db_prefix}settings
VALUES ('disable_avatar', '0'),
('board_avatar_width', '40'),
('board_avatar_height', '0'),
('display_childboards', '0')


make sure to replace {$db_prefix} with your actual database prefix.

-------

Adrek

ups.. I forgot about that ::)

Added to my post, thanks ;)
Polskie wsparcie SMF na simplemachines.org

the simplest solution is most likely the right one

BaghdadGhost

Quote from: phantomm on August 09, 2012, 03:15:21 AM
ups.. I forgot about that ::)

Added to my post, thanks ;)

Not a problem.

thank you also for making it possible to work with smf 2

bestfriendavinash

When it will be released as mod for smf 2.0.2 as well?

TheListener

Quote from: bestfriendavinash on August 10, 2012, 11:54:23 AM
When it will be released as mod for smf 2.0.2 as well?

The mod works on 2.0.2 already.

Please read the mod emulate link in my signature.

bestfriendavinash

Quote from: Old Fossil on August 11, 2012, 08:39:17 PM
Quote from: bestfriendavinash on August 10, 2012, 11:54:23 AM
When it will be released as mod for smf 2.0.2 as well?

The mod works on 2.0.2 already.

Please read the mod emulate link in my signature.

didn't worked for me..  :(

Advertisement: