Advertisement:

Author Topic: SimplePortal  (Read 1572140 times)

Offline teos55

  • Jr. Member
  • **
  • Posts: 373
  • Gender: Male
    • Culturel heritage photography blog
Re: SimplePortal - 2.3.3 Released!
« Reply #3900 on: May 18, 2011, 11:07:45 AM »
 As mentioned earlier this is an error free system with proper mods installed.
This is the list of mods applied.
--------------------------------------------
1.   Auto Email Inactive Users    1.7   
2.   Attachments Positioning    1.2   
3.   Tapatalk SMF Plugin    1.2.0   
4.   SimplePortal    2.3.3   
5.   SMF Gallery Lite    3.0.3b   
6.   Child Dropdown for Board Index    1.1   
7.   Hide Info Center From Guests    1.0   
8.   Google Translator Flags    1.0   
9.   httpBL    2.5.1      10.   
10.   Simple Audio Video Embedder    1.1.4   
11.   Center the Navagation Bar    1.0   
12.   Global Headers Footers    2.0   
13.   DisableTemplateEval    1.2     
14.   Stop Spammer    2.3.9     
15.   SMF Sitemap    1.2.2 
--------------------------------------------
  Will be providing test admin account details via PM
All the best

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: SimplePortal - 2.3.3 Released!
« Reply #3901 on: May 18, 2011, 12:02:42 PM »
On this page, the same block works OK:
http://karavanturk.org/index.php?page=page4847

So I suspected the shoutbox . I did disable your shoutbox block momentarily on the portal page, and saw that the [.img.] tags were then interpreted correctly on your forum. Then, I went to your list of shoutboxes, and for the shoutbox on the portal page, I enabled the [.img.] tag. Now your portal page works correctly.

Here is the reason for the problem:
* function parse_bbc is what interprets all the tags in posts and anywhere else. parse_bbc uses a lot of computer time.
* because the shoutbox refreshes itself frequently, and parse_bbc is used to parse the shouts, the shoutbox can be a problem for the server
* For this reason, many tags are disabled when the shoutbox is rendered, including the [img] tag.
* For some reason, this behavior is continued in the custom BBC block.

Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Offline teos55

  • Jr. Member
  • **
  • Posts: 373
  • Gender: Male
    • Culturel heritage photography blog
Re: SimplePortal - 2.3.3 Released!
« Reply #3902 on: May 18, 2011, 12:40:20 PM »
  Good work AngelianBelle, thanks alot.

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: SimplePortal - 2.3.3 Released!
« Reply #3903 on: May 18, 2011, 03:57:12 PM »
A side effect is that you may now put images in the shoutbox, too.
Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Offline King N

  • Semi-Newbie
  • *
  • Posts: 77
Re: SimplePortal - 2.3.3 Released!
« Reply #3904 on: May 21, 2011, 11:14:05 AM »
I see that there is a way for having a custom registration page using this mod
any help on achieving it

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: SimplePortal - 2.3.3 Released!
« Reply #3905 on: May 23, 2011, 08:27:34 AM »
You can do a custom registration page, but it is a little tricky and, perhaps, a little bit ugly.
A little while back, I did help a SimplePortal user set up a custom registration block. This code might work on your page.

I would invite you to come on over to http://SimplePortal.net, have a search for "registration block".  Right now, SimplePortal.net's website appears to be down. But I am certain that the SimplePortal team will work with its host to get the problems resolved soon.
Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Offline King N

  • Semi-Newbie
  • *
  • Posts: 77
Re: SimplePortal - 2.3.3 Released!
« Reply #3906 on: May 23, 2011, 12:33:37 PM »
Thanks for that

Offline King N

  • Semi-Newbie
  • *
  • Posts: 77
Re: SimplePortal - 2.3.3 Released!
« Reply #3907 on: May 23, 2011, 12:37:38 PM »
Will I get help for scripting it there?

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: SimplePortal - 2.3.3 Released!
« Reply #3908 on: May 23, 2011, 01:46:29 PM »
There's an old topic on doing a registration block that will help you get started. If you need more help than you find there, you should be able to find help in the customization boards here at simplemachines.org.
Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Offline teos55

  • Jr. Member
  • **
  • Posts: 373
  • Gender: Male
    • Culturel heritage photography blog
Re: SimplePortal - 2.3.3 Released!
« Reply #3909 on: May 26, 2011, 04:42:42 AM »
SMF 1.1.13 default theme Simple 2.3.3

 Noticed that shoutbox time zone is -1 to my actual time. There is no parm afaik  to enter the
zone difference .
 What to check ?

   

Offline Madzgo

  • Sophist Member
  • *****
  • Posts: 1,070
    • Urban Themes
Re: SimplePortal - 2.3.3 Released!
« Reply #3910 on: May 26, 2011, 10:27:05 AM »
Is there anyway to make Good Post/Bad Post voting options on SP articles??

Offline GlitchPC

  • Full Member
  • ***
  • Posts: 429
  • Gender: Male
  • Gotta glitch?
    • Glitch PC - Free Computer Help
Re: SimplePortal - 2.3.3 Released!
« Reply #3911 on: May 27, 2011, 03:59:49 PM »
197 pages is a lot of pages to read...so, I just wanted to ask 2 questions:

     1.  Is this mod compatible with SMF 2.0 RC5 with the following addons:
          a)  Welcome Topic Mod    2.1
          b)  SMF Staff Page    1.7
          c)  Referrals System  3.0.2
          d)  Stop Forum Spam  0.9
          e)  Facebook_Likev.1.4  1.4

     2.  I installed SMF in my root directory...not in a "forum" directory.  Will this mod still work...and are there any other issues I may have to consider before uploading and installing this mod?

Offline teos55

  • Jr. Member
  • **
  • Posts: 373
  • Gender: Male
    • Culturel heritage photography blog
Re: SimplePortal - 2.3.3 Released!
« Reply #3912 on: May 30, 2011, 05:41:00 AM »
 No recommendation for the time difference for shoutbox upto now...  Am I the only person facing this ?
My time zone is GMT+2  and shoutbox is GMT+1  Any seetings ?

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: SimplePortal - 2.3.3 Released!
« Reply #3913 on: May 31, 2011, 01:04:50 PM »
SMF 1.1.13 default theme Simple 2.3.3
Noticed that shoutbox time zone is -1 to my actual time. There is no parm afaik  to enter the zone difference .
I think shoutbox time should be controlled by the time zone each user selects in profile preferences.  This will require investigation...

Is there anyway to make Good Post/Bad Post voting options on SP articles??
SP articles are just regular SMF topics. So if you have any good post/bad post mods installed, they will still work.

     1.  Is this mod compatible with SMF 2.0 RC5 with the following addons:
          a)  Welcome Topic Mod    2.1
          b)  SMF Staff Page    1.7
          c)  Referrals System  3.0.2
          d)  Stop Forum Spam  0.9
          e)  Facebook_Likev.1.4  1.4

     2.  I installed SMF in my root directory...not in a "forum" directory.  Will this mod still work...and are there any other issues I may have to consider before uploading and installing this mod?
1. SimplePortal is not tested with any of these mods.  It may well work fine with all of them. I recommend trying it out on a "test" forum to avoid any little surprises. There is always the possibility that installation of one mod will require manual installation steps for another mod, as well -- something else that might best be sorted out on a test forum.

2. SimplePortal works fine in that situation. Once you install SimplePortal, /index.php BECOMES your portal page.
Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Offline teos55

  • Jr. Member
  • **
  • Posts: 373
  • Gender: Male
    • Culturel heritage photography blog
Re: SimplePortal - 2.3.3 Released!
« Reply #3914 on: June 01, 2011, 02:32:57 PM »
 Thanks AngelinaBelle,
  The time difference comes from my profile. Most probably daylite time difference from UTC.
Thansk alot.

Offline smtek

  • Jr. Member
  • **
  • Posts: 175
    • TheTekWar
Re: SimplePortal - 2.3.3 Released!
« Reply #3915 on: June 04, 2011, 09:51:53 AM »
I installed simple portal and added a shout box, after i disabled the portal now the shoutbox is not visible in forum. Is there anyway to add shoutbox to forum?
http://thetekwar.com

^ Your entry to the best tech community

Offline teos55

  • Jr. Member
  • **
  • Posts: 373
  • Gender: Male
    • Culturel heritage photography blog
Re: SimplePortal - 2.3.3 Released!
« Reply #3916 on: June 04, 2011, 06:00:52 PM »
SMF 1.1.13  default theme

  Is there a way to redirect the member directly to the main portal page, rather then to forum at the initial
login ?

  Portal mode= Front page is set.   

  initial login goes to h t t p: // m y s i t e.org/index.php?action=forum
« Last Edit: June 04, 2011, 06:08:26 PM by teos55 »

Offline MC73

  • Full Member
  • ***
  • Posts: 408
  • Gender: Male
    • Cuyler Games
Re: SimplePortal - 2.3.3 Released!
« Reply #3917 on: June 04, 2011, 06:24:13 PM »
I installed simple portal and added a shout box, after i disabled the portal now the shoutbox is not visible in forum. Is there anyway to add shoutbox to forum?

Go the the General settings in the Admin Simple Portal and change the Portal mode to integration. The portal will not show, but you can still add block to the rest of the forum, such as the SP Shout.
Over 1100 Online Flash Games 

Offline teos55

  • Jr. Member
  • **
  • Posts: 373
  • Gender: Male
    • Culturel heritage photography blog
Re: SimplePortal - 2.3.3 Released!
« Reply #3918 on: June 05, 2011, 04:51:26 AM »
 Accidentaly "disable port redirection" in the general settings was left ticked. Unticked, now redirects to
portal.

Solved.


SMF 1.1.13  default theme

  Is there a way to redirect the member directly to the main portal page, rather then to forum at the initial
login ?

  Portal mode= Front page is set.   

  initial login goes to h t t p: // m y s i t e.org/index.php?action=forum

Offline teos55

  • Jr. Member
  • **
  • Posts: 373
  • Gender: Male
    • Culturel heritage photography blog
Re: SimplePortal - 2.3.3 Released!
« Reply #3919 on: June 10, 2011, 01:18:28 PM »
URGENT !!!

SMF 1.1.13   default theme,  SP 2.3.3

  All of a sudden, main page failed loading in the middle of the process , getting message ;

"mysql server has gone away

load.php  line 2040"


 The failing block to load is "recent posts and topics"

I removed the block, and main page recovered.

I recreated the same block with the same parms.

Failed again.


 Tested with smf "unread posts" or " unread replies"  they work properly, so nothing wrong with smf, I think.

Hosting firm states that, there is nothing wrong with the server, increased :

wait_timeout=xx
connect_timeout=xx

 values for me to test, but not resolved.


  What can be broken all of a sudden ?, working with SP2.3.3 for a long time with no error up to now...

nb. for test, I put the newly created "recent posts" block to the end of the page, now fails exactly at the phase of loading
this block.

FOUND the culprit :  removed shoutbox entries ...

  Now every block works properly. 

So the question is :  How any entry in shoutbox,  can cause the main portal page load failure ?
« Last Edit: June 10, 2011, 01:31:56 PM by teos55 »