Advertisement:

Author Topic: SimplePortal  (Read 1572204 times)

Offline urgent

  • Newbie
  • *
  • Posts: 6
Re: SimplePortal - 2.3.3 Released!
« Reply #4040 on: July 28, 2011, 05:37:10 PM »
urgent,
I am sorry I missed your original post.
Manual installation can be tricky.  If you know which SMF files you edited, it should be enough to replace them.
These files will include index.php, some in the Sources folder, and some in your Themes folder.

Is there some reason you elected not to use the package manager to install the mod?
If only some of the tests failed, it is often easier to first do the install, then fix up the files that failed their test.

np thanks for responding. I did manual installation because I had other mods installed and remember trying to install an earlier module and it failing.

The thing is other links work, like the admin section works fine. When I try clicking on category or post links, it just goes to the homepage.

This link works and goes to the admin section:
index.php?action=admin;area=corefeatures;d07e5399375=924d3660194834c1591126fbbdf22a39

But this link generated from the simpleportal recent post doesn't and just refreshes the homepage:
index.php?topic=1.msg1;topicseen#new

same with this one for the categories:
index.php?board=1.0

Thanks.


Offline urgent

  • Newbie
  • *
  • Posts: 6
Re: SimplePortal - 2.3.3 Released!
« Reply #4041 on: July 28, 2011, 05:40:11 PM »
urgent,
I am sorry I missed your original post.
Manual installation can be tricky.  If you know which SMF files you edited, it should be enough to replace them.
These files will include index.php, some in the Sources folder, and some in your Themes folder.

Is there some reason you elected not to use the package manager to install the mod?
If only some of the tests failed, it is often easier to first do the install, then fix up the files that failed their test.

np thanks for responding. I did manual installation because I had other mods installed and remember trying to install an earlier module and it failing.

The thing is other links work, like the admin section works fine. When I try clicking on category or post links, it just goes to the homepage.

This link works and goes to the admin section:
index.php?action=admin;area=corefeatures;d07e5399375=924d3660194834c1591126fbbdf22a39

But this link generated from the simpleportal recent post doesn't and just refreshes the homepage:
index.php?topic=1.msg1;topicseen#new

same with this one for the categories:
index.php?board=1.0

Thanks.

also I forgot to add I replaced the source and packages directory with a backup, and the index.php and SSI.php files with a backup and it still has the same result.

Do you think I should start with a clean install? Thanks.

Offline AllanD

  • Sr. Member
  • ****
  • Posts: 763
  • Gender: Male
  • It's All Good
    • KnD Hosting
Re: SimplePortal - 2.3.3 Released!
« Reply #4042 on: July 28, 2011, 07:06:45 PM »
How would i make a forum menu option appear.
Intalled great no test failed or anything

http://mympz.com/index.php
Check out this great sites.
KnD Hosting

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: SimplePortal - 2.3.3 Released!
« Reply #4043 on: July 29, 2011, 07:36:05 AM »
urgent,

It sounds like you had an incomplete install of SimplePortal. This is not too surprising, consider the number of edits it makes.
It is a big mod. If you were able to install all of your other mods using the package manager, grabbing JUST THE PHP FILES from a full install of your version of the mod (SMF 2.0, right?) would work.
You might even find it convenient to uninstall your other mods first -- though the SimplePortal edits could SOMETIMES cause interference there.
If you had to do a lot of manual work to install your mods, then this "EASY WAY" might turn in to a lot of work.


Here's the hard way:
1) install SimplePortal (ignore all the errors)
2) uninstall SimplePortal (take note of the errors)
3) manually clean up where the package manager found errors.
4) search for any remaining SimplePortal code. Generally, you can find it by searching all your php files for "portal" and "sp_"
5) Make ABSOLUTELY CERTAIN you have gotten rid of every last line of SimplePortal code.
6) Install SimplePortal. Make careful note of all the errors. SMF 2.0 makes it easy to figure out WHICH edit is causing the problem.
7) Manually accomplish the edits the Package Manager installer could not figure out.
Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Offline AllanD

  • Sr. Member
  • ****
  • Posts: 763
  • Gender: Male
  • It's All Good
    • KnD Hosting
Re: SimplePortal - 2.3.3 Released!
« Reply #4044 on: July 29, 2011, 10:52:21 AM »
No need to help got this sorted out.
Check out this great sites.
KnD Hosting

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: SimplePortal - 2.3.3 Released!
« Reply #4045 on: July 29, 2011, 11:01:53 AM »
CrazieGrafix,

I'm glad you got this sorted.  I hadn't figured out yet what kind of button menu that Crip theme used.
Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Offline AllanD

  • Sr. Member
  • ****
  • Posts: 763
  • Gender: Male
  • It's All Good
    • KnD Hosting
Re: SimplePortal - 2.3.3 Released!
« Reply #4046 on: July 29, 2011, 11:51:18 AM »
ended up being a conflict with the mod that removes the help button from the menu.
Check out this great sites.
KnD Hosting

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: SimplePortal - 2.3.3 Released!
« Reply #4047 on: July 29, 2011, 12:50:16 PM »
Good! Glad you found it!
Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Offline rgecy

  • Jr. Member
  • **
  • Posts: 197
    • SideImagingSoft.com
Re: SimplePortal - 2.3.3 Released!
« Reply #4048 on: August 01, 2011, 12:28:04 AM »
I am trying to install 2.3.3 and keep getting this error:

Duplicate column name 'member_name'
File: /home/content/r/g/e/rgecy1/html/forums/Packages/temp/install2.php
Line: 500

I was running 2.0 RC2 and SP 2.3.1 and upgraded to SMF 2.0

Any ideas how I can fix this?

Robert

Offline rgecy

  • Jr. Member
  • **
  • Posts: 197
    • SideImagingSoft.com
Re: SimplePortal - 2.3.3 Released!
« Reply #4049 on: August 01, 2011, 10:12:50 PM »
Anyone? Sorry for being impatient!

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: SimplePortal - 2.3.3 Released!
« Reply #4050 on: August 02, 2011, 08:06:33 AM »
I am not sure why you are having this problem.
install2.php is trying to change the name of the column memberName to member_name, but column member_name already exists.

The easiest possible workaround would be to just drop the table sp_shouts.  The SimplePortal install would create a new, empty shouts table, which would solve this problem.

If you wish to keep the shouts, you can get into MySQL and drop the column memberName. That would also end the installer's confusion.
Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: SimplePortal - 2.3.3 Released!
« Reply #4051 on: August 03, 2011, 06:25:25 PM »
Is there a way to edit shouts to keep them clean on a family site?

Sometimes we have to clean up shouts due to language etc.

Thanks


TheListener

  • Guest
Re: SimplePortal - 2.3.3 Released!
« Reply #4052 on: August 03, 2011, 08:29:58 PM »
Not sure if the forums word filter comes in use here.

This link may help.

http://simpleportal.net/index.php?topic=9235.0

Gives a modification where the complete shoutbox log can be emptied.

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: SimplePortal - 2.3.3 Released!
« Reply #4053 on: August 03, 2011, 08:32:57 PM »
rollingrock:

Administrator should find a little delete icon all the way on the right-hand side of the shout.
It looks like this:

Click that, and delete the shout.

Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: SimplePortal - 2.3.3 Released!
« Reply #4054 on: August 03, 2011, 10:47:01 PM »
rollingrock:

Administrator should find a little delete icon all the way on the right-hand side of the shout.
It looks like this:

Click that, and delete the shout.



well duh!!!!   Mouse over and presto...I am an idiot.  (you can quote me)   Thanks for the tip.   Got it and now I feel like a total tool.   

Cheers

RR


Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: SimplePortal - 2.3.3 Released!
« Reply #4055 on: August 03, 2011, 10:49:32 PM »
I will add, an Edit feature would also be nice.   TP had that and our mods liked it.   Is there a feature request area? 

This is my first go with Simple Portal, I converted from TP.   Very easy to use and good looking.   Makes things very easy.

My hats off the the team that made it.



MarkLeevE

  • Guest
Re: SimplePortal - 2.3.3 Released!
« Reply #4056 on: August 04, 2011, 04:34:39 AM »
I'll replace Tinyportal with Simple Portal.. Thanks

Offline Inti31

  • Jr. Member
  • **
  • Posts: 247
    • Chevrolet Epica & Malibu Community
Re: SimplePortal - 2.3.3 Released!
« Reply #4057 on: August 08, 2011, 09:09:12 AM »
simpleportal works absolut fantastic - I just miss one feature on pages - I would like to know how often a page has been visited.
SMF has that feature integrated for every topic, means it shows in brackets the number of how many people have read the topic "(Read x times)".

maybe a feature which could be in version 2.4?

I put this to the right place also...
http://simpleportal.net/index.php?topic=9386.msg49227#msg49227

cheers Inti31

problem solved: http://simpleportal.net/index.php?topic=9384.msg49246#msg49246 - thx grafitus
« Last Edit: August 08, 2011, 11:27:18 PM by Inti31 »
my forum
my testforum

my mods - which I only made them work for 2.0 Gold:
Topics Filter v3.2 SMF 2.0 Gold
MemberNumber

Offline Angelina Belle

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,586
Re: SimplePortal - 2.3.3 Released!
« Reply #4058 on: August 08, 2011, 09:10:48 AM »
That is the perfect place for the suggestion.  Thanks!
Never attribute to malice that which is adequately explained by stupidity. -- Hanlon's Razor

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: SimplePortal - 2.3.3 Released!
« Reply #4059 on: August 08, 2011, 01:21:45 PM »
Installed Simportal but it changed the order of my boards.

For some reason, the order is changed yet when I check in the admin under boards the order is correct.

Something I am missing to fix that?