Advertisement:

Author Topic: SimplePortal  (Read 1503142 times)

Offline Bob Perry of Web Presence Consulting

  • Sophist Member
  • *****
  • Posts: 1,005
  • Gender: Male
  • (T)ogether (E)veryone (A)chieves (M)ore
    • Bobert921 on Facebook
    • https://www.linkedin.com/in/bperry921/ on LinkedIn
    • @bperry921 on Twitter
    • Web Presence Consulting
Re: SimplePortal
« Reply #5400 on: February 24, 2019, 09:28:02 PM »
Is there a way to make the search button appear on the right instead of the middle?



Since you are using SP, absolutely... it would require you to set it up in a side panel block, if it is already in say one of the two upper middle ones, just move it to the right side panel area, if you are talking about the built in search function, you still set up a search block in the side panel and disable the built in one I think?
Best Regards,
Bob Perry



"The world is moving so fast these days that the man who says it can't be done is generally interrupted by someone doing it." Elbert Hubbard

Offline GigaWatt

  • The Smiley Guy
  • Support Specialist
  • SMF Hero
  • *
  • Posts: 2,104
  • Gender: Male
    • Macedonian electronics forum
Re: SimplePortal
« Reply #5401 on: February 26, 2019, 09:04:55 PM »
Yeah, but it's a center block. Sure, a centered Search button would actually look good on one of the right or left blocks, but not on a center block :-\.

And I've set the one in the example pic as a Header block.

Could you explain in more detail? I don't think I'm getting this :-\. It's the first time I'm actually setting up a portal of any kind :P :D.
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,182
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: SimplePortal
« Reply #5402 on: February 26, 2019, 09:55:30 PM »

Add css attributes to the custom body style of the block.

ie.
Code: [Select]
width: 25em;float: right;

My SMF Mods & Plug-Ins

WebDev
Simple Portal Support

Request politely & demand nothing.

Offline GigaWatt

  • The Smiley Guy
  • Support Specialist
  • SMF Hero
  • *
  • Posts: 2,104
  • Gender: Male
    • Macedonian electronics forum
Re: SimplePortal
« Reply #5403 on: February 28, 2019, 10:14:11 PM »
Thanks for the help, but that just shrinks the search field and aligns it to the right. The search button is still centered and under the search field, but relative to the search field, not the whole block.

I could post a pic if you'd like, make things easier to understand ;).
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,182
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: SimplePortal
« Reply #5404 on: March 01, 2019, 11:56:15 PM »

Do you want it on the right but still underneath the textbox or beside the textbox?

My SMF Mods & Plug-Ins

WebDev
Simple Portal Support

Request politely & demand nothing.

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,182
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: SimplePortal
« Reply #5405 on: March 02, 2019, 12:32:14 AM »

Your previous post seems to indicate that you want the search button beside the text box.
Sinan used a line break in the XHTML code instead of just css, therefore you will need to edit that code for the block.



file: ../Sources/PortalBlocks.php

find:
Code: [Select]
echo '
<form action="', $scripturl, '?action=search2" method="post" accept-charset="', $context['character_set'], '">
<div class="sp_center">
<input type="text" name="search" value="" class="sp_search" /><br />
<input type="submit" name="submit" value="', $txt['search'], '" class="button_submit" />
<input type="hidden" name="advanced" value="0" />
</div>
</form>';

replace:
Code: [Select]
echo '
<form action="', $scripturl, '?action=search2" method="post" accept-charset="', $context['character_set'], '">
<div class="sp_center">
<input type="text" name="search" value="" class="sp_search" />
<input style="display: inline;" type="submit" name="submit" value="', $txt['search'], '" class="button_submit" />
<input type="hidden" name="advanced" value="0" />
</div>
</form>';



file: ../Themes/default/css/portal.css

find:
Code: [Select]
input.sp_search
{
width: 95%;
}

replace with:
Code: [Select]
input.sp_search
{
width: 85%;
}

My SMF Mods & Plug-Ins

WebDev
Simple Portal Support

Request politely & demand nothing.

Offline GigaWatt

  • The Smiley Guy
  • Support Specialist
  • SMF Hero
  • *
  • Posts: 2,104
  • Gender: Male
    • Macedonian electronics forum
Re: SimplePortal
« Reply #5406 on: March 22, 2019, 11:57:27 PM »
Do you want it on the right but still underneath the textbox or beside the textbox?

Sorry for the late reply :-\.

And no... on the right but next to the search box, not underneath it (like on a regular Google seach box ;)).

EDIT: Damn... just noticed that Google moved the search button to the center beneath the search box... I guess this was done a while ago, but I just noticed it :P :D.

Your previous post seems to indicate that you want the search button beside the text box.

Yes, that is what I was aiming for ;).

"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Offline 4everBlue

  • Semi-Newbie
  • *
  • Posts: 25
  • Gender: Male
  • impossible is nothing!
    • pngio
Re: SimplePortal
« Reply #5407 on: March 23, 2019, 07:44:57 PM »
Hi, in the simple portal admin main page.

What does this mean - "Article view template active:" ?

Offline monbade

  • Newbie
  • *
  • Posts: 4
Re: SimplePortal
« Reply #5408 on: April 24, 2019, 10:53:05 PM »
I was told to post this here. Hoping someone can help. My domain provider did an upgrade on my forum and when it was finished my simple portal was gone. I re-downloaded it to my forum, installed it and now am getting this error. Let me explain that my site was set up by a friend for me as i know little of programing and just enough to mess it up but i am learning. Unfortunately the person who did set it up has vanished off the net. I installed the simple portal (still waiting on my activation code from them for their site) and when i load the front page of my site thats what comes up so i removed it and tried two more times and the same error.
This is the error i get. Can anyone help me fix it.

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND ( payment_date <= -3600 )
AND (payment_status = 'Completed' OR paymen' at line 3
File: /home/newfe3/public_html/forum/Sources/DonationBlock.php
Line: 171

BTW i looked for the manual and have no idea where to find it

Monbade

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,182
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: SimplePortal
« Reply #5409 on: April 24, 2019, 10:59:26 PM »
Quote
File: /home/newfe3/public_html/forum/Sources/DonationBlock.php

That file is not related to Simple Portal.

My SMF Mods & Plug-Ins

WebDev
Simple Portal Support

Request politely & demand nothing.

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,182
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: SimplePortal
« Reply #5410 on: April 24, 2019, 11:17:02 PM »

@monbade:

After doing a little digging, I believe the Treasury modification contains a file with that name.
ref. https://custom.simplemachines.org/mods/index.php?mod=916

Try posting in that mod's thread for support.
Unfortunately it looks a bit dated.

My SMF Mods & Plug-Ins

WebDev
Simple Portal Support

Request politely & demand nothing.

Offline astralmonkey

  • Newbie
  • *
  • Posts: 4
Re: SimplePortal
« Reply #5411 on: May 04, 2019, 04:51:24 PM »
How do I have a library for articles and ebooks on simpleportal?
I can't seem to figure this out. The articles that comes with simpleportal isn't what I am looking for because it pulls from the forum.

Offline Oldiesmann

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,868
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • https://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: SimplePortal
« Reply #5412 on: May 07, 2019, 08:38:18 PM »
SimplePortal doesn't really have a true articles system. For something like that you may want to try TinyPortal, or, if you don't want a portal, the SMF Articles mod.
Michael Eshom
Cincy Space - now open!

Offline Replikacep

  • Jr. Member
  • **
  • Posts: 399
  • Gender: Male
    • Orjinal Cin Kore Telefon lari Rom ve Destek
Re: SimplePortal
« Reply #5413 on: May 08, 2019, 05:23:19 PM »
SimplePortal doesn't really have a true articles system. For something like that you may want to try TinyPortal, or, if you don't want a portal, the SMF Articles mod.
Simpleportal  When will the update for version 2.1
other portals updated  this was not updated.

Offline Oldiesmann

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,868
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • https://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: SimplePortal
« Reply #5414 on: May 08, 2019, 10:42:57 PM »
SimplePortal doesn't really have a true articles system. For something like that you may want to try TinyPortal, or, if you don't want a portal, the SMF Articles mod.
Simpleportal  When will the update for version 2.1
other portals updated  this was not updated.

https://web-develop.ca/index.php?action=downloads;area=stable_eh_portal;file=2 ;)
Michael Eshom
Cincy Space - now open!

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,305
Re: SimplePortal
« Reply #5415 on: July 23, 2019, 07:13:57 PM »
Having a problem with SP blocking access to forum with most urls. 

 http://rustybowtie.com/index.php?action=forum - works
 http://www.rustybowtie.com, www.rustybowtie.com, http://rustybowtie.com, rustybowtie.com - sometimes work, mostly don't.

All urls work when SP is uninstalled or disabled.  Running in 2.0.15, upgraded from SP 2.3.5 -> 2.3.7, same.

Offline Sverige

  • Semi-Newbie
  • *
  • Posts: 20
Re: SimplePortal
« Reply #5416 on: July 24, 2019, 12:12:11 PM »
hello   :)

just installed this and everything seems to work but, where did my forum go?

also how do i remove the welcome message?

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,182
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: SimplePortal
« Reply #5417 on: July 24, 2019, 08:47:46 PM »

@Sir Osis of Liver :

Check your portal mode settings. Perhaps you have it set to standalone mode in error?



@Sverige :
It sets itself to front page mode by default.
You are viewing the home page which is strictly blocks.
Go into the SP admin to edit blocks and change your settings to how you want things to behave.

My SMF Mods & Plug-Ins

WebDev
Simple Portal Support

Request politely & demand nothing.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,305
Re: SimplePortal
« Reply #5418 on: July 24, 2019, 11:07:27 PM »
No, checked that last night, it was set for front page, standalone url is blank.  I've enabled SP for front page, try the above links.  We're on GoDaddy linux box, php 5.6.40, don't see anything wonky in cpanel.



Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,182
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: SimplePortal
« Reply #5419 on: July 24, 2019, 11:58:15 PM »

At the moment what comes to mind is a block causing some sort of loop.
I would start with disabling blocks one at a time and testing the home portal page each time.
This will allow you to figure out which block is causing the PHP loop.
More than likely it is a custom PHP block.

My SMF Mods & Plug-Ins

WebDev
Simple Portal Support

Request politely & demand nothing.