Advertisement:

Author Topic: SimplePortal  (Read 1507744 times)

Offline Dwev

  • Jr. Member
  • **
  • Posts: 223
Re: SimplePortal
« Reply #5440 on: September 11, 2019, 02:55:17 AM »
Tried both variations (from urkalot and Chen Zhen) and this time I simply don't see anything.

The block is visible, but the image isn't.

Could it be that the CSS on the site is overriding something?

Offline lurkalot

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,496
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: SimplePortal
« Reply #5441 on: September 11, 2019, 03:00:09 AM »
Tried both (form urkalot and Chen Zhen) and this time I simply don't see anything.

The block is visible, but the image isn't.

Could it be that the CSS on the site is overriding something?

This might be a stupid question, and please disregard if it is,  but you have switched the block on?  I'm assuming you have to with this portal.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,854
    • StoryBB/StoryBB on GitHub
Re: SimplePortal
« Reply #5442 on: September 11, 2019, 04:05:05 AM »
Tried both variations (from urkalot and Chen Zhen) and this time I simply don't see anything.

The block is visible, but the image isn't.

Could it be that the CSS on the site is overriding something?

Is your site HTTPS and the image link to HTTP? If so that won’t work (the image proxy doesn’t naturally attach to portal blocks)
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Online @rjen

  • Full Member
  • ***
  • Posts: 509
  • Gender: Male
Re: SimplePortal
« Reply #5443 on: September 11, 2019, 06:21:58 AM »
If you provide the link to the actual site that may help understanding the issue.
Running SMF 2.0 with Tinyportal 1.6.4 at www.fjr-club.nl
Testing SMF 2.1 RC2 with Tinyportal at http://test2.fjr-club.nl/

Offline sirfpsycho

  • Semi-Newbie
  • *
  • Posts: 66
Re: SimplePortal
« Reply #5444 on: September 20, 2019, 09:43:09 AM »
Hi, using simple portal. I added Top Posters. But it counts all the topic and post both. I want to show only Topic posters count and its username. But currently it is counting replies in topic too.

Also in Topic posters, I want  my custom icon instead of avatar. Like 1st topic posters has cup icon. 2nd has another icon like this screenshot. Which mod can be used for it?

Offline Dwev

  • Jr. Member
  • **
  • Posts: 223
Re: SimplePortal
« Reply #5445 on: September 21, 2019, 07:05:29 AM »
Sorry for the late reply, I was abroad and internet over there wasn't very good.

The site is https, and so is https://www.w3schools.com/tags/smiley.gif
And yes, the block is turned on (the block is visible, the content isn't).

And it can be seen here: (link removed).
(bottom right on the front page, the name of the block is "Test")
 
If I use an inspector on that block I see that the code there is correct:
Code: [Select]
<img src="https://www.w3schools.com/tags/smiley.gif" alt="Smiley face" style="height: 2.625em;width: 2.625em;">
I tried it also with an image on the server off the site, still no dice.

Edit: link removed as requested by OP.
« Last Edit: September 27, 2019, 03:54:16 AM by lurkalot »

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,854
    • StoryBB/StoryBB on GitHub
Re: SimplePortal
« Reply #5446 on: September 21, 2019, 07:15:40 AM »
The sp-right column has a class of lastpost, and the default theme is set to hide images in .lastpost img, so it's hidden.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline sirfpsycho

  • Semi-Newbie
  • *
  • Posts: 66
Re: SimplePortal
« Reply #5447 on: September 21, 2019, 07:33:30 AM »
Any help for me?  : :-\

Offline Dwev

  • Jr. Member
  • **
  • Posts: 223
Re: SimplePortal
« Reply #5448 on: September 21, 2019, 08:54:11 AM »
The sp-right column has a class of lastpost, and the default theme is set to hide images in .lastpost img, so it's hidden.

Thanks, thought that I was going crazy.
(by the way, I just made the block invisible again, so no point in looking there anymore)

@ Arantor (or anyone else): I suppose that it's this bit in index.css?

Code: [Select]
.topic_table td.lastpost
{
background-image: none;
}

@ sirfpsycho: sorry, don't the answer to your question, otherwise I would give it right away.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,854
    • StoryBB/StoryBB on GitHub
Re: SimplePortal
« Reply #5449 on: September 21, 2019, 09:03:27 AM »
No, it's the bit that says .lastpost img and contains 'visibility: none'.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline sirfpsycho

  • Semi-Newbie
  • *
  • Posts: 66
Re: SimplePortal
« Reply #5450 on: September 22, 2019, 10:56:43 PM »
any help for me?  :(

Offline sirfpsycho

  • Semi-Newbie
  • *
  • Posts: 66
Re: SimplePortal
« Reply #5451 on: September 23, 2019, 01:11:48 AM »
I have two more issue.

2) Right Block, In Recent Posts/Topics, It shows like:

New post by Cole

But if any user reply in new post it shows the replier name at the last but it should show the topic starter name. How to fix?

3) In Top Poster section, Avatar is not showing. Uploaded avatar is showing fine but avatar added via url is not showing.
It goes like this:
sitename.com/avatars/avatar-url.gif

that is why it is not showing. how to fix it?

Offline sirfpsycho

  • Semi-Newbie
  • *
  • Posts: 66
Re: SimplePortal
« Reply #5452 on: September 26, 2019, 05:26:50 AM »
Help me please. 🙄

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,185
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: SimplePortal
« Reply #5453 on: September 26, 2019, 04:40:02 PM »

For some of what you requested, you may find something useful in the plugins & blocks section of the Simple Portal archive.
ref.
https://simpleportal.net/index.php?board=55.0

Try "Advanced Unread Posts" which includes a php file that you can edit for specifics if needed.
This way you won't need to tamper directly with the SP source code or templates.

My SMF Mods & Plug-Ins

WebDev
Simple Portal Support

Request politely & demand nothing.

Offline sirfpsycho

  • Semi-Newbie
  • *
  • Posts: 66
Re: SimplePortal
« Reply #5454 on: September 26, 2019, 11:09:30 PM »

For some of what you requested, you may find something useful in the plugins & blocks section of the Simple Portal archive.
ref.
https://simpleportal.net/index.php?board=55.0

Try "Advanced Unread Posts" which includes a php file that you can edit for specifics if needed.
This way you won't need to tamper directly with the SP source code or templates.

I installed Advanced Unread Posts, but it still shows the commenters name at the end. But is must show topic author name.

Offline sirfpsycho

  • Semi-Newbie
  • *
  • Posts: 66
Re: SimplePortal
« Reply #5455 on: September 26, 2019, 11:10:11 PM »
Hi, using simple portal. I added Top Posters. But it counts all the topic and post both. I want to show only Topic posters count and its username. But currently it is counting replies in topic too.

Also in Topic posters, I want  my custom icon instead of avatar. Like 1st topic posters has cup icon. 2nd has another icon like this screenshot. Which mod can be used for it?

@Chen Zhen, what about this post?

Offline KBExit

  • Semi-Newbie
  • *
  • Posts: 13
Re: SimplePortal
« Reply #5456 on: September 28, 2019, 02:12:20 PM »
I'm looking to see if I can add a block to a board and not have it show up in the topic?

I looked at the "Custom Display Options: " and haven't been able to accomplish this.
The value I entered is "-~action|post, -~action|topic, -~action|display" but I'm not accomplishing this result.

Offline KBExit

  • Semi-Newbie
  • *
  • Posts: 13
Re: SimplePortal
« Reply #5457 on: September 28, 2019, 04:33:28 PM »
I'm looking to see if I can add a block to a board and not have it show up in the topic?

I looked at the "Custom Display Options: " and haven't been able to accomplish this.
The value I entered is "-~action|post, -~action|topic, -~action|display" but I'm not accomplishing this result.

Looks like I cannot edit my post...
Anyways I fixed it!
Code: [Select]
-~action|post,-~action|post2,-~topicWorked!

Offline sirfpsycho

  • Semi-Newbie
  • *
  • Posts: 66
Re: SimplePortal
« Reply #5458 on: September 28, 2019, 09:51:44 PM »
any help for me please  O:)

Offline KBExit

  • Semi-Newbie
  • *
  • Posts: 13
Re: SimplePortal
« Reply #5459 on: September 28, 2019, 10:07:49 PM »
I have two more issue.

2) Right Block, In Recent Posts/Topics, It shows like:

New post by Cole

But if any user reply in new post it shows the replier name at the last but it should show the topic starter name. How to fix?

3) In Top Poster section, Avatar is not showing. Uploaded avatar is showing fine but avatar added via url is not showing.
It goes like this:
sitename.com/avatars/avatar-url.gif

that is why it is not showing. how to fix it?

On the topic for the recent posts / topics block...
By any chance, are you already using the board news block? If not, I can probably help you modify the board news block since it retains the "original author" for each post instead of who replied last.

Edit:
Actually, have you taken a look into the PortalBlocks.php in the sources directory? You can modify each block that's standard in SimplePortal there to your liking if you understand PHP decently.