Advertisement:

Author Topic: Language Error from Upgrade  (Read 33104 times)

Offline Eliana Tamerin

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 5,611
  • Gender: Female
Language Error from Upgrade
« on: March 17, 2008, 10:15:01 PM »
I have not yet been able to reproduce this. I'll try on my localhost.

I upgraded a forum from 1.1.4 (clean minus the installation of tinyportal and felblog, which were both removed prior to upgrade) to 2.0 beta 3 public today.

As I was going over the user preferences, I noticed the drop down language selection under Account Settings was set on Persian. I quickly changed that to English, but when I did so, numerous text strings disappeared, likely all of the text strings new to 2.0.

I'm not sure if this is the manner which I uploaded the files (didn't want to bother with a stand-alone ftp program, so I used Cpanel's filemanager (new one in v11), extracted the upgrade archive to a different folder and moved the new files into the current forum.

Also possible that it was due to the extremely sluggish upgrade process. Possible that's due to my host having some problems over the past few day.

I'd love to chalk this one up to "human error/act of the internet" but I don't want to leave it as such if this is being experienced by others.

And yeah, this should go in bug reports, but I'd want to confirm it as such before it's moved.
Do NOT PM me for support.

SimplePortal 2.3.6 is OUT!
SimplePortal Project Manager
Download | Docs
SimplePortal: Power of Simplicity!

Offline Dragooon

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,738
  • Gender: Male
  • I'm batman
    • ShitizGarg on Facebook
    • Dragooon on GitHub
    • dragooon on LinkedIn
    • SMF-Media
Re: Language Error from Upgrade
« Reply #1 on: March 17, 2008, 10:27:21 PM »
Did you overwrote the language files properly?
Try deleting all the language files and uploading new ones from a default SMF package
Language files are in /Themes/default/languages.

Also make sure that you use Default Theme - Core,

Offline SleePy

  • Let there be light!
  • Site Team Lead
  • SMF Master
  • *
  • Posts: 30,412
  • Gender: Male
  • Thats his happy face.
    • jdarwood007 on GitHub
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: Language Error from Upgrade
« Reply #2 on: March 17, 2008, 10:28:11 PM »
The language files are not ready for SMF 2.0 Beta 3 yet. Having these in your language folder will cause issues.

Make sure the languages folder got updated with the new english language files.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub

Offline Eliana Tamerin

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 5,611
  • Gender: Female
Re: Language Error from Upgrade
« Reply #3 on: March 17, 2008, 10:52:36 PM »
Ok, well then perhaps the upgrade could delete them? I installed this installation from Fantastico, which installs ALL of the language files by default.

I'll restore the language files from the install archive and see if that works.
Do NOT PM me for support.

SimplePortal 2.3.6 is OUT!
SimplePortal Project Manager
Download | Docs
SimplePortal: Power of Simplicity!

Offline SleePy

  • Let there be light!
  • Site Team Lead
  • SMF Master
  • *
  • Posts: 30,412
  • Gender: Male
  • Thats his happy face.
    • jdarwood007 on GitHub
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: Language Error from Upgrade
« Reply #4 on: March 17, 2008, 11:33:16 PM »
You can simply put your forum into maintenance mode 2 (via Settings.php in FTP or File Manager).
First making a backup. Then remove the old languages folder and finally uploading the new languages folder. This would be the quickest way to do this.

We know about the Fantastico issue. Sadly these things take time and then once they are fixed your host needs to update their cpanel to get the fix..
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub

Offline Eliana Tamerin

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 5,611
  • Gender: Female
Re: Language Error from Upgrade
« Reply #5 on: March 17, 2008, 11:46:28 PM »
Ok, I'm quite certain this was just a botched upload. No bug here, I think.
Do NOT PM me for support.

SimplePortal 2.3.6 is OUT!
SimplePortal Project Manager
Download | Docs
SimplePortal: Power of Simplicity!

Offline metallica48423

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,842
  • Gender: Male
  • Professional Multislacker!
    • Zentendo
Re: Language Error from Upgrade
« Reply #6 on: March 17, 2008, 11:47:54 PM »
Let us know if you get this fixed :)
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

Quote
Microsoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"

Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

Offline Eliana Tamerin

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 5,611
  • Gender: Female
Re: Language Error from Upgrade
« Reply #7 on: March 17, 2008, 11:51:25 PM »
No need, it was on a forum I used for testing purposes.

I'll just be sure to use a real FTP program next time.
Do NOT PM me for support.

SimplePortal 2.3.6 is OUT!
SimplePortal Project Manager
Download | Docs
SimplePortal: Power of Simplicity!

Offline metallica48423

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,842
  • Gender: Male
  • Professional Multislacker!
    • Zentendo
Re: Language Error from Upgrade
« Reply #8 on: March 18, 2008, 12:13:24 AM »
ok, i'll mark it solved then.

Thanks :)
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

Quote
Microsoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"

Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool