Advertisement:

Author Topic: Super Newbie Question: Icons not loading in Firefox  (Read 6058 times)

Offline clindner

  • Semi-Newbie
  • *
  • Posts: 17
Super Newbie Question: Icons not loading in Firefox
« on: March 27, 2008, 02:03:41 PM »
Sorry if this has been answered to death, but I'm a first day newbie and couldn't find answers by searching..

My installation went really smoothly (nice job SMF team!) and everything is working fine.  However, in FF the page sort of loads with about half the icons and background button graphics in a more or less random fashion.   In the post editing view, the editing buttons and smilies are about half there.  If I use IE, it loads them all every time.

Also, I will say that it is working fine on this board in FF.  My host has PHP 5 in Fast mode.  They also offer Flex mode, could it be something with that?

Thanks!

Offline clindner

  • Semi-Newbie
  • *
  • Posts: 17
Re: Super Newbie Question: Icons not loading in Firefox
« Reply #1 on: March 27, 2008, 03:28:39 PM »
So, no one has run across this?


Offline SlammedDime

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,280
  • School of Air Ride
    • matt.zuba on Facebook
    • @mattzuba on Twitter
Re: Super Newbie Question: Icons not loading in Firefox
« Reply #2 on: March 27, 2008, 03:50:23 PM »
Please try and wait at least 24 hours before bumping your topics.  We are all only volunteers here and try to answer questions as quickly as possible.

The best thing you could do right now is provide a link to your site. :)
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Offline clindner

  • Semi-Newbie
  • *
  • Posts: 17
Re: Super Newbie Question: Icons not loading in Firefox
« Reply #3 on: March 28, 2008, 10:44:27 AM »
Here's the link:

http://www.realitastic.com/forum/index.php [nofollow]

I didn't know how this might've helped in the issue.  It is still occuring.

Sometimes all the icons load perfectly, sometimes less than half.   No messages in the error log.


Offline heavyccasey

  • Jr. Member
  • **
  • Posts: 212
Re: Super Newbie Question: Icons not loading in Firefox
« Reply #4 on: March 28, 2008, 12:49:27 PM »
Well, it looks fine to me.

Offline clindner

  • Semi-Newbie
  • *
  • Posts: 17
Re: Super Newbie Question: Icons not loading in Firefox
« Reply #5 on: March 28, 2008, 01:30:19 PM »
Yeah, the system seems to be working fine. 

However, using firefox on a Mac and on a PC, from two different access locations, I am having the problem.

Just to make sure I am clear on the problem, I'll state it another way...

If I load any page, or post a new topic or reply to a topic, many of the icons do not load at least 50% of the time.  Some times, everything loads perfectly.  Other times, random icons, smiles, user star rating, menu buttons, etc. do not load.

I do not see that problem when I post here.


Offline SlammedDime

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,280
  • School of Air Ride
    • matt.zuba on Facebook
    • @mattzuba on Twitter
Re: Super Newbie Question: Icons not loading in Firefox
« Reply #6 on: March 28, 2008, 02:54:31 PM »
I browsed your site in both FF and IE6 and IE7 and every page always fully loaded.

Are there any errors in your hosting error log (not SMF's error log).
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Offline clindner

  • Semi-Newbie
  • *
  • Posts: 17
Re: Super Newbie Question: Icons not loading in Firefox
« Reply #7 on: March 28, 2008, 04:18:49 PM »
No errors in hosting log.  I just ran it through a couple of times until I got the image loading problem, then checked the log.  Nothing there.

I am on NFS, and I can (I think) easily change between  PHP 4, PHP 5 Fast and PHP 5  Flex.   I am on PHP 5 Fast now, should I try changing?


Offline Oldiesmann

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,872
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • https://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: Super Newbie Question: Icons not loading in Firefox
« Reply #8 on: March 28, 2008, 06:14:28 PM »
The PHP version/configuration really shouldn't have any effect on whether or not images load. I'm not sure what could be causing your issue, but I wasn't able to reproduce it either (Firefox 3 Beta 4 on Vista Home Premium).
Michael Eshom
Cincy Space - now open!

Offline clindner

  • Semi-Newbie
  • *
  • Posts: 17
Re: Super Newbie Question: Icons not loading in Firefox
« Reply #9 on: March 28, 2008, 11:55:55 PM »
Thanks to all for checking it out.  My problems have come using FF 2. 

Very strange, as no one that is using it has had the problem either.


Offline Rumbaar

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,805
  • Gender: Male
  • Inherent Omniscience
    • Rumbaar.net
Re: Super Newbie Question: Icons not loading in Firefox
« Reply #10 on: March 31, 2008, 04:25:21 AM »
Yeah I've just viewed your forum in FireFox 2 and had no issues with images not displaying.

Does it only happen when you are logged in?  If so do you have code/features that are only displayed to logged in members that might be causing the issue?
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

Offline clindner

  • Semi-Newbie
  • *
  • Posts: 17
Re: Super Newbie Question: Icons not loading in Firefox
« Reply #11 on: April 05, 2008, 11:45:51 AM »
I think I found the reason for this error.

My server limits the max number of simultaneous connections per client.   I had installed some accelerators in the browser that had increased the maximum number above that.

Once I changed the setting back to less than the server maximum, the problem went away...