Advertisement:

Author Topic: Remove Old Posts  (Read 5260 times)

Offline MothMan

  • Jr. Member
  • **
  • Posts: 212
Remove Old Posts
« on: March 28, 2008, 01:10:04 PM »
Hi all.  I'm trying out the 2.0 Beta 3 Public install (installed by Upgrading from 1.1.4) , no mods installed.

When trying out the "Remove Old Posts" ability in admin panel...  I enter the number of days, select "Any Sort of Topics", select "All Boards" ...  and click Remove Now...  I get the pop up asking me to confirm, which I do... I am then given an error message stating:

             Unable to verify referring url.  Please go back and try again.

Offline SleePy

  • Site Team Lead
  • SMF Master
  • *
  • Posts: 30,333
  • Gender: Male
  • Thats his happy face.
    • jdarwood007 on GitHub
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: Remove Old Posts
« Reply #1 on: March 28, 2008, 11:17:04 PM »
I am unable to reproduce this.
Did you view another forum page in another tab? If it can't find the old url correct url in your session this would happen.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub

Offline MothMan

  • Jr. Member
  • **
  • Posts: 212
Re: Remove Old Posts
« Reply #2 on: March 31, 2008, 03:45:37 PM »
Thanks for the response.

I just tried again, making sure I only had the forum open in a single tab, and got the same error.

Something obviously went wrong during my install...

Offline Rumbaar

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,805
  • Gender: Male
  • Inherent Omniscience
    • Rumbaar.net
Re: Remove Old Posts
« Reply #3 on: April 05, 2008, 09:29:53 PM »
Can you link to your install?  You accessing it via a redirector or frame?
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

Offline MothMan

  • Jr. Member
  • **
  • Posts: 212
Re: Remove Old Posts
« Reply #4 on: April 07, 2008, 04:31:44 PM »
The test forum is here:  http://www.othersi.com/beta_forum/

As for how I'm accessing it... I don't have any frames or anything going on... just directly accessing it in a standard browser (Firefox) window.

Offline metallica48423

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,842
  • Gender: Male
  • Professional Multislacker!
    • Zentendo
Re: Remove Old Posts
« Reply #5 on: April 07, 2008, 04:38:07 PM »
First, what are your cookie settings in admin > server settings > feature configuration?

are you using database stored sessions?

Lets try clearing all of your cookies and cache out of your brower... then completely close your browser...

This will force a new session for you.

also, is there anything in the error log?
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

Quote
Microsoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"

Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

Offline MothMan

  • Jr. Member
  • **
  • Posts: 212
Re: Remove Old Posts
« Reply #6 on: April 11, 2008, 03:53:03 PM »
First, what are your cookie settings in admin > server settings > feature configuration?

Default Login Cookie length - 60

Local Storage of Cookies - off

Use Subdomain independent cookies - off

Max users online when optimizing - 0

auto fix broken tables - on

compressed output - off

use database driven sessions - on

allow browsers to go back to cached pages - on

Seconds before unused session timeout - 3500


Error log...  I emptied the log, then tried to Remove Old Posts, and the resulting entry in the error log is:

    Type of error: User

http://www.othersi.com/beta_forum/index.php?action=admin;area=maintain;sa=admintask;activity=maintain_old

Unable to verify referring url. Please go back and try again.

Offline MothMan

  • Jr. Member
  • **
  • Posts: 212
Re: Remove Old Posts
« Reply #7 on: April 11, 2008, 03:55:50 PM »
Also, I tried removing all cookies in my browser, that didn't help.

I'm not sure how to clear my cache (Firefox 2.0.0.13)

Offline metallica48423

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,842
  • Gender: Male
  • Professional Multislacker!
    • Zentendo
Re: Remove Old Posts
« Reply #8 on: April 11, 2008, 04:33:33 PM »
Try turning off database driven sessions, then clear all private data from firefox (under the tools menu on firefox)
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

Quote
Microsoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"

Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

Offline MothMan

  • Jr. Member
  • **
  • Posts: 212
Re: Remove Old Posts
« Reply #9 on: April 11, 2008, 06:20:35 PM »
Thanks.

I tried that, the problem still occurs.

Interestingly, when I turned off database driven sessions, and clicked Save, I was given the following message:

Session verification failed. Please try logging out and back in again, and then try again.

I went back to the features page, and saw that the database driven features were turned off, however.

Turning it on/off gave me the above error each time.

I'm assuming something didn't transfer/update properly for me.

It's not the end of the world, I'm only running the beta as a test.  My working forums are still  1.1.4.

Just curious as to what went wrong, as I will, once beta is over, want to update to 2.0.

Offline SleePy

  • Site Team Lead
  • SMF Master
  • *
  • Posts: 30,333
  • Gender: Male
  • Thats his happy face.
    • jdarwood007 on GitHub
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: Remove Old Posts
« Reply #10 on: April 20, 2008, 01:35:03 PM »
The one when turning off database driven sessions is known.
Are you using any mods?
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub

Offline MothMan

  • Jr. Member
  • **
  • Posts: 212
Re: Remove Old Posts
« Reply #11 on: May 08, 2008, 06:14:17 PM »
SleePy,  sorry for the slow reply.

I have no packages installed on my test forum.  When I upgraded with the upgrade package, my mods were all removed.

As a side note, I installed the latest patch for the beta forum, and the same error still occurs.

Offline MothMan

  • Jr. Member
  • **
  • Posts: 212
Re: Remove Old Posts
« Reply #12 on: May 08, 2008, 06:16:18 PM »
Hmm... I just noticed, when looking at my file versions, some of my Language files are listed as out of date.

ModSettings.english.php = 1.1

Profile.english_orig.php = 1.1

index.english_orig.php = 1.1.2


I don't know if that's relevant, or is normal.

Offline Rumbaar

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,805
  • Gender: Male
  • Inherent Omniscience
    • Rumbaar.net
Re: Remove Old Posts
« Reply #13 on: May 08, 2008, 06:21:54 PM »
Those three files are no longer used by SMF 2.*, so no need to worry about them.
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]