• Welcome to Simple Machines Community Forum. Please login or sign up.
December 05, 2021, 01:51:37 PM

News:

Join the Facebook Fan Page.


Package Installation > Fatal Error!

Started by chris-j-d, April 02, 2008, 04:04:59 PM

Previous topic - Next topic

chris-j-d

I hope I'm in the right forum.

The past few days I've tried out a lot of forum software and so far SimpleMachines seems the best to me. Thanks to all behind the project!

But I have a problem. I can upload new packages to my server space, but when I run the installation routine I always get this message:

FATAL ERROR - Allowed memory size of 33554432 bytes exhausted (tried to allocate 71 bytes)

Similar routines e.g. in Joomla run smoothly.

What I'm asking is, if there's an alternative way install packages. I could easily change write permissions to any files by myself. I just need to know which files and how to get around this built-in routine.

Thanks for your time!

shadow82x

Hi and welcome to SMF. :D

Great to see you joined the forum.


This seems more like a host issue. Take a look at these search results - http://www.simplemachines.org/community/index.php?action=search2;search=FATAL+ERROR+-+Allowed+memory+size+of+
Colin B
Former Spammer, Customize, & Support Team Member

chris-j-d

Wow! Thanks for your quick reply!

However, the reason why I posted here is because I couldn't find a solution for my problem after 2 hours of research in this forum. All discussed memory errors occur in other situations than mine. Besides one:

http://www.simplemachines.org/community/index.php?topic=100959.msg652813#msg652813 (see problem 2)

But this post is from 2006 and his problem was never solved ...  :'(

Herman's Mixen

this is a memory setting in php.ini your host need to add extra memory to it ;)
Met vriendelijke groet, The Burglar!

 House Mixes | Mixcloud | Any Intelligent fool can make things bigger, more complex, and more violent.
It takes a touch of genius - and a lot of courage - to move in the opposite direction. - Albert Einstein

Former Godfather of our dutch community ;)

chris-j-d

It's probably not insufficient memory but the fact that for some reason SMF is not able or allowed to change write permissions to files. Therefore I look up the files that have to be writable in the .xml's of the mod and change permissions myself. This works in most cases, but not in the Custom Profile Field Mod (see my new post http://www.simplemachines.org/community/index.php?topic=232354.0).

metallica48423

If you're using SMF 2.0, you have no reason to install the custom profile field mod -- it is built in to the system by default.

Some php configurations seem to incorrectly report a memory error on a permissions  issue, its something i see only sporadically, however.  If it truly is a memory issue though, then likely you would want your host to increase the php memory allocation.  If they have it under-allocated it will also cause this error.  Some hosts may gimp this value simply to prevent resource overuse.
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

Advertisement: