• Welcome to Simple Machines Community Forum. Please login or sign up.
December 01, 2021, 04:07:25 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Installation error?

Started by pensoftware, April 03, 2008, 06:00:22 PM

Previous topic - Next topic

pensoftware

I keep getting these weird installation errors.  First it was the "Unable to find members table!" error, then I went into the upgrade file and changed it so it wouldn't show.  It successfully got past it and then it says, "Executing: "Adding permission profiles for boards." (16 of 27).

Database Updates Complete! Click Continue to Proceed.
!!
Error!
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 5
".

What should I do? O.o

Aleksi "Lex" Kilpinen

Just to clear that message of yours a bit, a fresh install or an upgrade?
What did you change in the upgrade file?

When does the error occur? you click proceed, or what?
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

flyer222

April 04, 2008, 02:18:11 PM #2 Last Edit: April 04, 2008, 02:21:27 PM by flyer222
LexArma: I got the same error today 4-4-08! it will not let you proceed so the continue is not an option. myself I did a clean install and played with 2.0 a bit and and no apparent problems. I got this error when trying to upgrade an ex sisting database for a 1.1.4 installation I am sure it is the same for the original poster.
Would like to know an answer for this problem myself.

Aleksi "Lex" Kilpinen

Ok, I'm still a bit unfamiliar with the 2.0 upgrade, so I have no real ideas where to start.. But I'm sure someone else here has already memorised the script, so you just hang in there :)
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

flyer222

As a follow up to my earlier comment, to over come this issue I went back and just started the install over again and it sped right through to completion. I did not check start where it left off but let it run all the way through the installation.
First note, the error occurs at board permission. I went into my SQL and found a duplicate in the structure. I removed one of the duplicates then redefined the 3 index's, went back and re ran install one more time to over write everything and walla, my database was successfully upgraded and the site is running fine so far.
I hope this is useful.

metallica48423

pensoftware, did you make sure you ran the forum maintenance before starting the upgrade?
Justin O'Leary
Ex-Project Manager
Ex-Lead Support Specialist

QuoteMicrosoft wants us to "Imagine life without walls"...
I say, "If there are no walls, who needs Windows?"


Useful Links:
Online Manual!
How to Help us Help you   
Search
Settings Repair Tool
     

Advertisement: