Advertisement:

Author Topic: what is needed  (Read 5444 times)

Offline lightning_strike

  • Semi-Newbie
  • *
  • Posts: 24
what is needed
« on: April 03, 2008, 09:51:42 PM »
we need an unistall 2.0  to convert the data base back to a 1.114 compat

babjusi

  • Guest
Re: what is needed
« Reply #1 on: April 03, 2008, 10:11:43 PM »
we need an unistall 2.0  to convert the data base back to a 1.114 compat

I presume that you upgraded your 1.1.4 forum to the 20 B3 P and now want to roll back, right?

Did you backup the database of the 1.1.4 prior to the upgrade?

Offline brianjw

  • SMF Hero
  • ******
  • Posts: 2,157
  • Gender: Male
Re: what is needed
« Reply #2 on: April 03, 2008, 10:57:26 PM »
You would need the database back to 1.1.4 in order to do this. There is no physical way to do this unless you manually rewrote your database back to 1.1.4 style and overwrited all of your files in SMF except for Settings_bak.php and Settings.php.

Offline lightning_strike

  • Semi-Newbie
  • *
  • Posts: 24
Re: what is needed
« Reply #3 on: April 04, 2008, 04:43:08 PM »
yes I did back up my site and data base  but I have been running it on 2.0 since the 17th  have over 100 new members and 1000's of new posts and attachments

any why to get a list of changes so I can manully conver the data base back  I am going blind thru the data base  finding the changes and changing the sql as I go


Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,549
  • Gender: Male
    • Kindred-999 on GitHub
Re: what is needed
« Reply #4 on: April 04, 2008, 04:47:51 PM »
there is no way to change a 2.0 back to 1.1.x

either you stick with 2.0 at this point, or restore your previous backup and lose the last x days of data.

I suppose you COULD try going through the upgrade SQL files...   but I seriously doubt anyone on the team will be working on a downgrade utility.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

babjusi

  • Guest
Re: what is needed
« Reply #5 on: April 04, 2008, 04:48:02 PM »
yes I did back up my site and data base  but I have been running it on 2.0 since the 17th  have over 100 new members and 1000's of new posts and attachments

any why to get a list of changes so I can manully conver the data base back  I am going blind thru the data base  finding the changes and changing the sql as I go



To roll back to the 1.1.4., you must install a fresh 1.1.4 forum and restore the most recent backup that you made from before you upgraded your forum to the 2.0. (i.e. the backup when your forum was still 1.1.4 version). But note, that all the posts, topics, members etc that were added 2hile you were using the 2.0 will be lost

Edit: Kindred beat me to it

Offline lightning_strike

  • Semi-Newbie
  • *
  • Posts: 24
Re: what is needed
« Reply #6 on: April 04, 2008, 05:11:31 PM »
so your telling me  if I back up the database from 2.0 as it is now
and then up it to a new data base  and then change the tables back to the 1.14 version 

or

edit the sql of the 2.0 back up to reflect the 1.14 tables  it won't work
??????

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,549
  • Gender: Male
    • Kindred-999 on GitHub
Re: what is needed
« Reply #7 on: April 04, 2008, 05:20:44 PM »
you could try either one of those...   but we have no way for you to do it... so you're pretty much on your own

Why not just stay with 2.0?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline brianjw

  • SMF Hero
  • ******
  • Posts: 2,157
  • Gender: Male
Re: what is needed
« Reply #8 on: April 04, 2008, 06:13:10 PM »
Kindred, 2.0 is still has many bugs and is in beta and isn't recommended to use on live sites. ;)

lightning_strike,
If you wish to keep your members that you've had you would yes, have to manually go through the .sql file and downgrade it by hand.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,549
  • Gender: Male
    • Kindred-999 on GitHub
Re: what is needed
« Reply #9 on: April 04, 2008, 07:47:59 PM »
brian... I know the status of 2.0

I am using it on a live site, myself, however....
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

babjusi

  • Guest
Re: what is needed
« Reply #10 on: April 04, 2008, 09:20:45 PM »
Kindred, 2.0 is still has many bugs and is in beta and isn't recommended to use on live sites. ;)

Kindred knows it better than you and me that the 2.0 still has bugs ;)

@lightning_strike, what is the reason that you want to downgrade? Is it because of some bugs you came across?

Offline lightning_strike

  • Semi-Newbie
  • *
  • Posts: 24
Re: what is needed
« Reply #11 on: April 05, 2008, 07:42:13 PM »
well  I have down a down grade and got everything back  maybe a few attachments mis  not sure

I loaded a fresh 1.14   then went to the database   on two computers  I displayed the new data base  and with the other I went thru ever table  found the upgrades  and changed them back    then went to the admin panel and switched back to the old data base and everything came back  still have a few packages  but  I amd my users are glad to be back

I went back  becuase too many thing did not work  and all the packages that the users liked were gone  plus  had a lot of permission issues

if any one needs help to go back  you can get me at
www.wauchsam.com [nofollow]

thanks for everything guys