• Welcome to Simple Machines Community Forum. Please login or sign up.

Thumbnail on Topic Listing

Started by SMFHacks.com Team, April 04, 2008, 01:05:48 PM

Previous topic - Next topic

Jade Elizabeth

Quote from: JF3000 on June 16, 2016, 03:07:59 AM
Well I tried a linked image and nothing showed up. Seems redudent showing an image if one is attached. If attachments are disabled this mod doesn't work at all.

Yeah you have to have an uploaded image in the board to show them.
Once proud Documentation Writer and Help Squad Leader | Check out my new adult coloring career: Color With Jade/Patreon.

Jade Elizabeth

Another bug....if the image isn't the first thing you attach it wont show no matter what :(.
Once proud Documentation Writer and Help Squad Leader | Check out my new adult coloring career: Color With Jade/Patreon.

tanawat

if i won't show picture from attachment.
but use from Photo Sharing Websites.

how to modify code.


i see this web
http://aqua.c1ub.net/forum/index.php?board=5.0
can do.

plese

vbgamer45

If one is found over the other it would use that instead.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

tanawat

ohh Thankyou.  :D

i'm not observe.
this mod so cool.

confuseamuse

Can an edit be made to this mod so that it creates a thumbnail based on any images within the first post instead of adding an attachment?

So if you add an image in the [img][/img] tags or any image file via attachment, it crops it and places it in the thumbnail section. If no image exists in the topic at creation, it uses the default image icons (or default thumbnail etc.).

Could that adjustment be made?

vbgamer45

I think someone did that before check all topics of this page.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

confuseamuse

Quote from: vbgamer45 on August 07, 2017, 11:04:55 AM
I think someone did that before check all topics of this page.

There are issues in my MessageIndex.template.php after install:


Database Error
Expression #31 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'assembly.big.id_attach' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by
File: /var/www/vhosts/cajican.org/httpdocs/Sources/MessageIndex.php
Line: 464


Here is the aforementioned line (and 5 lines below/above it):

echo '
<script type="text/javascript"><!-- // --><![CDATA[
if (typeof(window.XMLHttpRequest) != "undefined")
aJumpTo[aJumpTo.length] = new JumpTo({
sContainerId: "message_index_jump_to",
sJumpToTemplate: "<label class=\"smalltext\" for=\"%select_id%\">', $context['jump_to']['label'], ':<" + "/label> %dropdown_list%",
iCurBoardId: ', $context['current_board'], ',
iCurBoardChildLevel: ', $context['jump_to']['child_level'], ',
sCurBoardName: "', $context['jump_to']['board_name'], '",
sBoardChildLevelIndicator: "==",
sBoardPrefix: "=> ",
sCatSeparator: "-----------------------------",
sCatPrefix: "",
sGoButtonLabel: "', $txt['quick_mod_go'], '"
});
// ]]></script>


The section I'm referring to is:
sJumpToTemplate: "<label class=\"smalltext\" for=\"%select_id%\">', $context['jump_to']['label'], ':<" + "/label> %dropdown_list%",

vbgamer45

You have to change your mysql mode
sql_mode=only_full_group_by
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

confuseamuse

What is it set to by default when SMF makes the database?

EDIT: The answer is this:
sql_mode=ONLY_FULL_GROUP_BY,NO_ZERO_IN_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

I'm not confident in mysql so I won't alter it until I understand the reason why the mode needs to be changed, just in case it breaks the forum.

vbgamer45

I am not certain as well check on google. It shouldn't break anything though
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

tanawat

August 14, 2017, 04:56:09 AM #451 Last Edit: August 14, 2017, 05:29:00 AM by tanawat
i wont to set display Thumbnail (for each boards) in database
I can not find it.  Could you tell me whare is it?

(Usually i will seting in database Because a lots of boards.)

Thank.  :D


vbgamer45

There is an entry in the smf_setings table

When you modify each board there is an option on that page.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

wzol

I use a responsive them with divs without tables: https://custom.simplemachines.org/themes/index.php?lemma=2873

Could you help me to add this mod to this theme - I have tried my best, but it seems too hard for me  :-[

vbgamer45

I am not good at that either. It really would be a per theme edit.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

wzol

I see, could you at least tell me what is that two replace modifications doing in the theme? The second bigger seems like doing the main picture placement, but what is the first?

confuseamuse

I have an issue with this mod (again). Completely different to the last time I tried to install it.


         LIMIT ' . ($pre_query ? '' : '{int:start}, ') . '{int:maxindex}',
458: array(
459: 'current_board' => $board,
460: 'current_member' => $user_info['id'],
461: 'topic_list' => $topic_ids,
462: 'is_approved' => 1,
463: 'find_set_topics' => implode(',', $topic_ids),
464: 'topic_prefix' => (isset($_REQUEST['prefix']) ? $_REQUEST['prefix'] : ''),
465: 'clone_topics' => $clone_topics,
466: 'start' => $start,
==>467: 'maxindex' => $maxindex,


Line 467 has an error for some reason.

vbgamer45

Whats the error you might have to do a manual install if the code is different.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

confuseamuse

Quote from: vbgamer45 on August 23, 2017, 09:07:57 AM
Whats the error you might have to do a manual install if the code is different.

Probably will do that at a later date.

confuseamuse

I manually installed the mod and it didn't break the forum. That's progress I guess.

However, it doesn't display any images. I don't have attachments on, so the only way this would work is if I have the "[img][/img]" tag version working correctly.

Also, the message index table is borked, so I need to use CSS to fix it, though I haven't seen a new column added where the images are supposed to go.

Advertisement: