Advertisement:

Author Topic: Session verification failed. Error!  (Read 21276 times)

Offline evgenydeep

  • Semi-Newbie
  • *
  • Posts: 99
Re: Session verification failed. Error!
« Reply #20 on: May 26, 2008, 06:44:43 AM »
Also, I noticed, when I try to login, then first time it shows "incorrect login", then at second time I log-in without problems. I think this is due to session issue either.

During login following errors logged in DB:
2: session_start() [&lt;a href='function.session-start'&gt;function.session-start&lt;/a&gt;]: Cannot find save handler files   <br />/home/forumgr/public_html/smf/Sources/Load.php<br />1950

Password incorrect - &lt;span class=&quot;remove&quot;&gt;deep&lt;/span&gt;

2: session_start() [&lt;a href='function.session-start'&gt;function.session-start&lt;/a&gt;]: Cannot find save handler files   <br />/home/forumgr/public_html/smf/Sources/Load.php<br />1950

2: session_destroy() [&lt;a href='function.session-destroy'&gt;function.session-destroy&lt;/a&gt;]: Trying to destroy uninitialized session<br />File: /home/forumgr/public_html/smf/Sources/Subs-Auth.php<br />Line: 174

2: session_start() [&lt;a href='function.session-start'&gt;function.session-start&lt;/a&gt;]: Cannot find save handler files   <br />File: /home/forumgr/public_html/smf/Sources/Load.php<br />Line: 1950


Offline Night09

  • SMF Hero
  • ******
  • Posts: 1,940
  • Gender: Male
Re: Session verification failed. Error!
« Reply #21 on: May 26, 2008, 10:21:52 AM »
All I can say then is if your sure SMF is installed ok each time and these errors appear then your host doesnt support SMF fully.

I can install an SMF domain on my own server here in 2 mins with no errors and have run forums hosted on my own server since I found SMF.

This problem is beyond me and hopefully someone with a better level of SMF may have a solution.

Offline evgenydeep

  • Semi-Newbie
  • *
  • Posts: 99
Re: Session verification failed. Error!
« Reply #22 on: May 26, 2008, 12:28:44 PM »
Finally: I'm tired to found where is problem, so I roll-back my previous working php.ini
and all become workable again.
My guess why it was so: Last time, when I edit php.ini I use CPanel WHM  to save it.
WHM saved almost all parameters existent in php.ini in double quotes. I roll back to the same php.ini, but without double quotes, and all become workable....
"magic @#$% quotes" :)

Offline sebasso

  • Semi-Newbie
  • *
  • Posts: 23
Re: Session verification failed. Error!
« Reply #23 on: June 01, 2008, 11:38:03 PM »
im back here ... with the same problem ...

i read evgenydeep found the solution ... but i dont understand what he say ... whm?

can you please help me?

Offline Night09

  • SMF Hero
  • ******
  • Posts: 1,940
  • Gender: Male
Re: Session verification failed. Error!
« Reply #24 on: June 02, 2008, 07:57:15 AM »
What evgenydeep says is Cpanel WHM has added double quote marks to php.ini file when he saved it.

Rolling back the file to the previous state before has removed the errors on the forums.

Check your own php.ini for quotation to make sure it is not this causing the  errors on your own forums.

Offline sebasso

  • Semi-Newbie
  • *
  • Posts: 23
Re: Session verification failed. Error!
« Reply #25 on: June 04, 2008, 12:04:54 AM »
i try but nothing happens ... i try in one forum that has a php.ini file ... i change the " to ' ... but nothings happens ... then i try in one forum that dont has a php.ini file ... but in a superior directory was the file .. so i change the " to ' .. but nothing happens ..

I change both files with the notepad application ...

Offline Night09

  • SMF Hero
  • ******
  • Posts: 1,940
  • Gender: Male
Re: Session verification failed. Error!
« Reply #26 on: June 04, 2008, 09:41:27 AM »
I registered on the forums and found a couple of intresting problems

Firstly when I clicked register I was actually prompted to download Index.php and had to retry which it then registered.

Secondly it seems you are logged properly in until you try to post:

Quote
                              The following error or errors occurred while posting this message:                                                                                       Your session timed out while posting. Please try to re-submit your message.                            

The main problem is you cannot access admin to change or work on settings related to the forum.You need some of the config settings changing to do with cookies and sessions but these would have to be done via ftp and manual edits. This might be a lot of work and I would have to be sure you could get to the correct settings to change them.

Another thing  I am wondering if the hosts php/sql is up to date and can run 1.1.4 or 1.1.5 .

The reason for this is because you have just changed host and hit these problems but for a fresh install it seems a bit excessive to have a forum crippled in this way without actually being modded ect.

Can you actually confirm with the host that the server your on is actually capable of running SMF forums as this would eliminate them as an issue possibly.You have installed SMF fresh so there really shouldnt be major issues instantly upon install.

If they confirm it is supposed to run SMF then something to do with install may be causing it.I would then switch to something like SmartFTP or similar to be sure the FTP program your using now isnt causing the problems during upload to the site. Iwill then look for the correct settings you can try to modify to see if it resolves this.


Offline sebasso

  • Semi-Newbie
  • *
  • Posts: 23
Re: Session verification failed. Error!
« Reply #27 on: June 04, 2008, 10:58:08 PM »
thanks for your help ... i use smartFTP and my host is hostmonster ..

right now im askin to support the information of the server ... later i will post it

Offline sebasso

  • Semi-Newbie
  • *
  • Posts: 23
Re: Session verification failed. Error!
« Reply #28 on: June 05, 2008, 12:04:13 AM »
they say that the server is capable of running smf forums ..

support told me that i clear my cookies and cache .. because we were trying in a forum that the same support creates and works for some days .. until crash ... i clear my cookies and cache and in a magical way ... all works fine! ... :S .. im confuse because i have tryed that and nothing works until now :S!

Offline Night09

  • SMF Hero
  • ******
  • Posts: 1,940
  • Gender: Male
Re: Session verification failed. Error!
« Reply #29 on: June 05, 2008, 04:30:35 AM »
The main thing is it is fixed now and working.

It could have been an issue for the database on the server causing each install to fail but it is pretty strange that it works this time round and after you spoke to the server admin. ;)

Offline xjessie007

  • Semi-Newbie
  • *
  • Posts: 46
Re: Session verification failed. Error!
« Reply #30 on: October 18, 2008, 11:11:04 AM »
Hi,

I was suddenly getting the "Session verification failed. Please try logging out and back in again, and then try again." message too. In my case, the reason for this message was very stupid (I forgot to update database name in Settings.php when migrating my forum from one environment to the other one), but in my search for a fix, I discovered a few things about sessions.

a) Sessions are stored in your database in the Sessions table (if you have dbase sessions enabled). You can dump this table without problems. In case you decide to manually dump this table, make sure you also delete records from log_online and log_errors. These two tables seem to hold session related data as well (i.e. data related to sessions on your Sessions table).
b) I had some files related to sessions in my temporary folder where I store temp files from my web server. Find out where your server stores temp files and clean that up.
c) Clean up your cookies. Those can store some data related to this.
d) If you are worried about deleting the content of the Sessions table, you can force all sessions to expire by setting the databaseSession_lifetime variable on the Settings table to one.
e) In case you have bad luck, and you can't even log into your admin interface to disable database sessions, you can hack that settings by setting the databaseSession_enable variable to zero in your Settings database table.
f) If nothing helps, you can edit your Security.php file and disable checks related to checking sessions. Find the checkSession() function and uncomment all the stuff that checks for sessions validity.

e) and f) will not fix your problem, but it will at least get you into the system to do more research.

Note at the end: As I mentioned, I got into this error when I forgot to update the database name in the Settings.php file when migrating the forum. Of course, I do not know exactly what triggers this message on your end, but the principle is that SMF works with sessions in many ways. It seems to pass them in _GET, _POST, from DATABASE, from COOKIES, etc. If it runs into a situation where your sessiondata in one source is not the same like from the other source, it returns the message. This can happen for example when your hosting provider cleans the sessions temp folder with you logged in. In this case, you would be able to log back in after sessiondata elsewhere expires.

I am completely new to SMF, so I might be wrong in some places, but I hope this helps at least a little.

-------------
www.maxi-pedia.com - Maxi-Pedia: Your resource for finance & IT!
www.finance-management.cz - Central European Center for Finance and Management
www.maxi-pedia.com/forum - Maxi-Pedia Forum: Place to discuss your finance & IT questions.
« Last Edit: October 18, 2008, 11:24:42 AM by xjessie007 »
When traveling to the Schengen zone (most of Europe), remember that some nationals need so called Schengen visa. Schengen visa is a travel document.
Check the schengen visa travel guide

Offline mumus

  • Newbie
  • *
  • Posts: 1
Re: Session verification failed. Error!
« Reply #31 on: September 06, 2009, 08:17:22 AM »
Hi.

I had the same problem with the session expired and could not get password reset email.

I opened setting.php and

$webmaster_email = 'noreply@xxxxxxxx.com';      # Email address to send emails from. (like noreply@yourdomain.com.)

The noreply word was my domain before, so I put norelpy and now everything works.
Least for now. :-)

Regards.

andieexotic

  • Guest
Re: Session verification failed. Error!
« Reply #32 on: October 21, 2009, 11:56:57 PM »
I found a solution!!

Some templates that you install have extra pages. THESE PAGES ARE NOT NEEDED! Simply delete everything in any custom templates except for:

images
languages
theme_info.xml
style.css
license.txt
index.template.php
index.php
Recent.template.php
Post.template.php
MessageIndex.template.php
Display.template.php
BoardIndex.template.php

this should work, it did for me. Plus, this is the easiest solution so far, because if there are errors or malfunctions because of this, you can just reinstall the theme! :]