Advertisement:

Author Topic: How do I forcibly allow WYSIWYG support for Firefox 3.1 and 4.0?  (Read 2621 times)

Offline LLStarks

  • Jr. Member
  • **
  • Posts: 162
Topic.

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: How do I forcibly allow WYSIWYG support for Firefox 3.1 and 4.0?
« Reply #1 on: June 29, 2008, 11:15:46 PM »
You can download the Firefox source code, make the necessary changes to allow the javascript and stuff thats needed to support it. Compile your source and release the new package to the open source community. :)

Seriously though, why are you trying to do this on a product that's not even beta? It already works on FF3.
IchBin™        TinyPortal
Coding Guidelines       

Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: How do I forcibly allow WYSIWYG support for Firefox 3.1 and 4.0?
« Reply #2 on: June 30, 2008, 09:19:42 AM »
The easiest thing to do would probably be just to change your useragent. I don't think firefox 3.1 will have many major rendering changes so it should work. I believe 4.0 is having more js improvements though
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline LLStarks

  • Jr. Member
  • **
  • Posts: 162
Re: How do I forcibly allow WYSIWYG support for Firefox 3.1 and 4.0?
« Reply #3 on: July 06, 2008, 06:28:15 PM »
Unfortunately, I am not satisfied with these answers. I remember in the past that one could edit the useragents SMF recognized. Can I still do this? If so, how?

Offline LLStarks

  • Jr. Member
  • **
  • Posts: 162
Re: How do I forcibly allow WYSIWYG support for Firefox 3.1 and 4.0?
« Reply #4 on: July 11, 2008, 06:56:21 PM »
bump

Offline SleePy

  • Site Team Lead
  • SMF Master
  • *
  • Posts: 30,283
  • Gender: Male
  • Thats his happy face.
    • jdarwood007 on GitHub
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: How do I forcibly allow WYSIWYG support for Firefox 3.1 and 4.0?
« Reply #5 on: July 30, 2008, 01:42:18 AM »
Does the WYSIWYG editor not working for FF 3.1/4.0.

The source code I quickly glanced at doesn't look like it restricts any version of Firefox for the WYSIWYG editor.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub