Advertisement:

Author Topic: Can not Upload Attachments  (Read 2158 times)

Offline bgarrity

  • Newbie
  • *
  • Posts: 4
Can not Upload Attachments
« on: July 23, 2008, 03:47:23 PM »
Hello All

When I try to upload a photo in profiles or any other file attachment I get following:

"The attachments upload directory is not writable. Your attachment or avatar cannot be saved."

I have read other threads with this problem but none of the solutions have helped.  I have tried chmod settings of 777, 766 and 755,  I have checked ownership with SSH.  I made sure php.ini had temp directory as /tmp.  Tried different theme. Nothing has worked

I also noted that if I tried to create a new directory for the files in Attachment Settings that when I click on the Attachments Directory - the status for the original attachment directory and the new directory I just created is:

"Does Not Exist"  even though the path for both is correct.  In fact in the the original attachmenbts directory it lists 3 under files so it knows that there are files there but still says the directory does not exist.

It seems the program does not fully recognize these directories, which explains why it thinks the directory is not writable.

Any help would be greatly appreciated.

Offline Rumbaar

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,805
  • Gender: Male
  • Inherent Omniscience
    • Rumbaar.net
Re: Can not Upload Attachments
« Reply #1 on: July 24, 2008, 06:45:25 AM »
Can you check your forums paths via repair_settings.php tool.  Then also check the Attachment path is 100% correct for your server settings.
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

Offline bgarrity

  • Newbie
  • *
  • Posts: 4
Re: Can not Upload Attachments
« Reply #2 on: July 24, 2008, 06:09:00 PM »
Thank you - thank you

I think I ran that before but this time when I ran it the attachment path was listed as: a:2:{i:1;s:38:

So I put in correct path and it did not work, but then I went into admin and found the path was not there anymore so I entered it back in there and the combination of doing it in repair and manually in admin fixed it.

Now if I could just have those 10 hours of my life back - :)

Offline Rumbaar

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,805
  • Gender: Male
  • Inherent Omniscience
    • Rumbaar.net
Re: Can not Upload Attachments
« Reply #3 on: July 24, 2008, 06:28:33 PM »
Yeah, it's a shame when it doesn't work the first time and little tricky things like that seem to sap our time.  Glad you got it fully functional again :)
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]