Advertisement:

Author Topic: Help me pls.. Nobody can log into forum  (Read 6039 times)

Offline hhoban

  • Semi-Newbie
  • *
  • Posts: 25
Help me pls.. Nobody can log into forum
« on: August 13, 2008, 09:09:24 AM »
Forum was working fine yesterday and today when I go to log in this is what I get. I didn't change anything yesterday we all just posted to it. What do I have to fix to get in. No mods have been added.. the only thing that happened yesterday was we posted to it.

In firefox I get this:
Can't open file: 'smf_log_online.MYI' (errno: 145)
File: /forum/Sources/Subs.php
Line: 2575

Internet Explorer:
Can't open file: 'smf_sessions.MYI' (errno: 145)
« Last Edit: August 13, 2008, 02:17:52 PM by hhoban »

Offline hhoban

  • Semi-Newbie
  • *
  • Posts: 25
Re: Help me pls.. Nobody can't log into forum
« Reply #1 on: August 13, 2008, 10:49:13 AM »
The rest of the site is working fine. Its just the forum. Can someone please let me know what I need to do to get this fixed. This is what you see when you go to the address now. At least an hour ago you saw the template. Its getting worse and I am not doing anything.




http://www.canadianwarrants.com/forum/index.php

Offline mike_sw

  • Semi-Newbie
  • *
  • Posts: 39
  • Gender: Male
Re: Help me pls.. Nobody can't log into forum
« Reply #2 on: August 13, 2008, 12:37:48 PM »
It's mysql at fault here. Optimize the tables from Admin -> Forum Maintenance -> Common Tasks -> Optimize All Tables

Offline hhoban

  • Semi-Newbie
  • *
  • Posts: 25
Re: Help me pls.. Nobody can't log into forum
« Reply #3 on: August 13, 2008, 12:57:37 PM »
How do I do that when I can't even get to the log on page for the forum?

What changed that caused this? I sure don't want to wake up to this again.

Offline hhoban

  • Semi-Newbie
  • *
  • Posts: 25
Re: Help me pls.. Nobody can log into forum
« Reply #4 on: August 13, 2008, 02:51:04 PM »
I have run the repair tool. I have accessed the sql server and run a repair and now I am getting 500 Internal Server Error. This is just getting worse. The whole rest of the site is working fine except the forum.

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: Help me pls.. Nobody can log into forum
« Reply #5 on: August 13, 2008, 02:57:52 PM »
I'd say it might be because of mod_security. Having problems with mod_security?

Offline hhoban

  • Semi-Newbie
  • *
  • Posts: 25
Re: Help me pls.. Nobody can log into forum
« Reply #6 on: August 13, 2008, 03:00:58 PM »
No, I don't even have a moderator. There are two admins and I definitely have no problem there.

I can see all the files through ftp and nothing has been altered since yesterday when we were on. Got up this morning to this so I just need help in what to do to get access again.

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: Help me pls.. Nobody can log into forum
« Reply #7 on: August 13, 2008, 03:02:14 PM »
No, I don't even have a moderator. There are two admins and I definitely have no problem there.

I can see all the files through ftp and nothing has been altered since yesterday when we were on. Got up this morning to this so I just need help in what to do to get access again.

mod_security has nothing to do with moderators. Please read the link I provided.

Offline hhoban

  • Semi-Newbie
  • *
  • Posts: 25
Re: Help me pls.. Nobody can log into forum
« Reply #8 on: August 13, 2008, 03:21:56 PM »
Did that. Still nothing. Server for the forum is Yahoo and they don't have it. If they just decided to implement it I wouldn't be the only one that just encountered this problem. I am sure there would have been a lot more but anyway. .htaccess uploaded and still no access.

Offline hhoban

  • Semi-Newbie
  • *
  • Posts: 25
Re: Help me pls.. Nobody can log into forum
« Reply #9 on: August 13, 2008, 07:13:24 PM »
I really would appreciate if someone could give me more ideas on what to do. This forum has been down all day now and its nothing to do with my server and I haven't installed any mods for over a month and I am out of ideas.

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: Help me pls.. Nobody can log into forum
« Reply #10 on: August 13, 2008, 07:17:15 PM »
Please don't bump your topics up in under 24 hours. We're all volunteers here.

`smf_log_online` is apparently damaged, but can be repaired or re-created.
Login to phpMyAdmin and run the following queries.

Code: [Select]
REPAIR TABLE `smf_log_online`
Code: [Select]
OPTIMIZE TABLE `smf_log_online`

Offline hhoban

  • Semi-Newbie
  • *
  • Posts: 25
Re: Help me pls.. Nobody can log into forum
« Reply #11 on: August 13, 2008, 09:39:46 PM »
I apologize.. this is just getting so frustrating...

Okay I ran those codes on the smf_log_online and its not getting any errors now. Then I clicked on the whole database. I optimized any tables that gave me the option but when I click on these two here are the errors I get

SQL query: Edit

SHOW KEYS FROM `smf_sessions` ;

MySQL said: Documentation
#1105 - File './data/smf_sessions.MYD' not found (Errcode: 13)

found this to fix the smf_sessions error

http://www.simplemachines.org/community/index.php?topic=169957.msg1084493#msg1084493





 SQL query: Edit

SHOW KEYS FROM `smf_log_errors` ;

MySQL said: Documentation
#1105 - File './data/smf_log_errors.MYD' not found (Errcode: 13)

Now I just need to know how to fix the smf_log_error

thanks
« Last Edit: August 14, 2008, 12:47:47 AM by hhoban »

Offline hhoban

  • Semi-Newbie
  • *
  • Posts: 25
Re: Help me pls.. Nobody can log into forum
« Reply #12 on: August 15, 2008, 07:56:27 PM »
I am still having problems. I have to open mysql and repair something about 10 times a day right now. Its something different every time but the one error that is contant is:

File './data/smf_log_errors.MYD' not found (Errcode: 13)

Now if someone could please tell me how to rebuild that file like my other error was fixed from this thread below I would very much appreciate it and I would be out of everyone's hair. No matter how many times I repair and optimize its not going away. I have searched everywhere and I can't find the same error posted so I can just use someone else's fix to clean this mess up.

http://www.simplemachines.org/community/index.php?topic=169957.msg1084493#msg1084493
« Last Edit: August 15, 2008, 07:58:41 PM by hhoban »

Offline mike_sw

  • Semi-Newbie
  • *
  • Posts: 39
  • Gender: Male
Re: Help me pls.. Nobody can log into forum
« Reply #13 on: August 16, 2008, 04:46:12 AM »
That message tells you that it can't find the physical file where the smf_log_errors table is kept. Please verify you still have the tables in your smf database. 

Offline hhoban

  • Semi-Newbie
  • *
  • Posts: 25
Re: Help me pls.. Nobody can log into forum
« Reply #14 on: August 16, 2008, 10:02:12 AM »
It shows its still there in the database but when I click on it I get the same error. Is there any way to rebuild. I do have a backup of it but its a month old.

Offline 青山 素子

  • Server Team
  • SMF Super Hero
  • *
  • Posts: 17,068
  • 戦場ヶ原、蕩れ!
    • srvrguy on GitHub
    • @motokochan on Twitter
    • Nekomusume Moe
Re: Help me pls.. Nobody can log into forum
« Reply #15 on: August 16, 2008, 02:00:58 PM »
You will probably need to contact your host. It appears there is a problem with their database server.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.