Advertisement:

Author Topic: 500 - Internal Server Error attempting to open My Messages as admin  (Read 6897 times)

Offline johanvg

  • Newbie
  • *
  • Posts: 7
This only happens with my admin account. Normal users don't seem to be affected. I'm running SMF 2.0 Beta 3.1 on Lighty so a .htaccess file isn't the issue.

I have the following packages installed:

-===================================-
 Mod Name     Version     
1.    Auto Embed Video/Audio Clips 3.1.2
2.    Advanced Reputation System 1.4.1    
3.    Top 10 Posters Today And This Week Stats 1.1    
4.    Clickable Avatars 1.0.1    
5.    Enhance Recent Post 1.0    
6.    Advanced AJAX Shoutbox 1.21    
7.    vBulletin Style Meta Tags 1.1    
8.    SMF Sitemap 1.3.0
-===================================-

I tried the various options in Forum Maintenance. Only the Optimize Tables option actually did something:

-===================================-
Optimize all tables to improve performance.
Your database contains 63 tables.
Attempting to optimize your database...
Optimizing smf_admin_info_files... 5.97 kb optimized.
Optimizing smf_log_online... 4.51 kb optimized.
Optimizing smf_sessions... 150.42 kb optimized.

3 table(s) optimized.
-===================================-

No dice though. Any ideas?
« Last Edit: September 18, 2008, 06:07:48 AM by johanvg »

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: 500 - Internal Server Error attempting to open My Messages as admin
« Reply #1 on: August 22, 2008, 07:16:53 PM »
Do you have any new PMs in your inbox? Any errors in the Forum Error Log?

Offline DirtRider

  • SMF Hero
  • ******
  • Posts: 1,415
  • Gender: Male
  • Just Looking
    • TriumphTalk
Re: 500 - Internal Server Error attempting to open My Messages as admin
« Reply #2 on: September 02, 2008, 02:52:16 PM »
Read my workaround on this one it may work for you as well         

Ok here is the sequence of events that started this. My admin 2 send a member a PM and got the error however it did not kill his inbox. The member that was sent the PM got the error and could not use his inbox. Admin 2 then sent me admin 1 a PM and it gave me the error and I could not use my inbox at all.
I then started doing a number of tests from another admin account (Admin 3) to my test user account it work 100% both ways.

I kept getting notifications of PM in my admin 1 account that I could not open. I then started testing from my admin 3 to my admin 1 account. Kept getting the error on admin 1 PM box. Then all of a sudden my admin 1 started working and I could open my PM.

I notice however that the PM I could open was now on a new page in my inbox. I have 44 pages of PM’s in my box. I then tried to go back to page 33 to try and read the PM’s that had been sent to me and got the server error again. I returned back to page 44 and it displayed. I then went to page 32 no problem can read it. However each time I try and read page 33 I get the error.

I started sending my admin 2 PM’s and once he started a new page he could read his latest PM’s but not the previous page as in my admin 1 account.

So it is now working but I still have no idea what actually caused this problem to start with.   :P       
« Last Edit: September 02, 2008, 03:06:40 PM by DirtRider »
http://www.triumphtalk.com

"The real question is not whether machines think but whether men do. "

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: 500 - Internal Server Error attempting to open My Messages as admin
« Reply #3 on: September 02, 2008, 03:00:00 PM »
Your link leads to a topic in the Charter section..

Offline DirtRider

  • SMF Hero
  • ******
  • Posts: 1,415
  • Gender: Male
  • Just Looking
    • TriumphTalk
Re: 500 - Internal Server Error attempting to open My Messages as admin
« Reply #4 on: September 02, 2008, 03:07:06 PM »
Sorry here we go

Ok here is the sequence of events that started this. My admin 2 send a member a PM and got the error however it did not kill his inbox. The member that was sent the PM got the error and could not use his inbox. Admin 2 then sent me admin 1 a PM and it gave me the error and I could not use my inbox at all.
I then started doing a number of tests from another admin account (Admin 3) to my test user account it work 100% both ways.

I kept getting notifications of PM in my admin 1 account that I could not open. I then started testing from my admin 3 to my admin 1 account. Kept getting the error on admin 1 PM box. Then all of a sudden my admin 1 started working and I could open my PM.

I notice however that the PM I could open was now on a new page in my inbox. I have 44 pages of PM’s in my box. I then tried to go back to page 33 to try and read the PM’s that had been sent to me and got the server error again. I returned back to page 44 and it displayed. I then went to page 32 no problem can read it. However each time I try and read page 33 I get the error.

I started sending my admin 2 PM’s and once he started a new page he could read his latest PM’s but not the previous page as in my admin 1 account.

So it is now working but I still have no idea what actually caused this problem to start with.   :P       
http://www.triumphtalk.com

"The real question is not whether machines think but whether men do. "

Offline johanvg

  • Newbie
  • *
  • Posts: 7
Re: 500 - Internal Server Error attempting to open My Messages as admin
« Reply #5 on: September 16, 2008, 06:05:21 AM »
Do you have any new PMs in your inbox? Any errors in the Forum Error Log?

Yes. I regularly see My Messages [1] at the top of the forum so I assume that the mailbox is functioning. I have never been able to open it though. There are 75 pages of errors in the forum error log, mostly related to Sitemap.php. AFAIK it never worked - even before the installation of any mods.

Offline greyknight17

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 14,890
  • Gender: Male
    • Kevin's Resource Center
Re: 500 - Internal Server Error attempting to open My Messages as admin
« Reply #6 on: October 03, 2008, 03:14:31 PM »
Is this issue resolved? What never worked? The sitemap or the personal messages? If sitemap, did you try removing it?

Offline johanvg

  • Newbie
  • *
  • Posts: 7
Re: 500 - Internal Server Error attempting to open My Messages as admin
« Reply #7 on: October 03, 2008, 03:57:08 PM »
The issue was resolved by changing Profile\Personal Messaging\Display Personal Messages to "One at a time". Apparently there was a single corrupt message in the bunch.

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: 500 - Internal Server Error attempting to open My Messages as admin
« Reply #8 on: October 15, 2008, 06:58:45 PM »
If this is solved feel free to mark it as solved by changing the message icon in your initial post to a green "check".