• Welcome to Simple Machines Community Forum. Please login or sign up.
September 20, 2021, 03:50:10 AM

News:

Join the Facebook Fan Page.


Problema upload avatar

Started by atreiou, January 27, 2005, 05:50:18 AM

Previous topic - Next topic

atreiou

Ho installato da zero la 1.0.1, e riscontro un errore quando qualcuno tenta di caricare un proprio avatar, più precisamente l'errore è :

"La directory di upload degli allegati non è scrivibile. Il tuo allegato o avatar non può essere salvato"

gli allegati è una funzione attualmente disabilitata per gli utenti, può influenzare l'upload degli avatar ?
a quale cartella si riferisce il messaggio di errore? qualche chmod dovrei dare? 777 ?

edi67

1° E' ovvio che se tu disabiliti l'upload degli avatar da parte degli utenti essi non potranno uplodare i loro avatar quindi va abilitata

2° devi perforza impostare la directory avatars come anche le altre directory del tuo forum al CHMOD 777
CrazyZone - My SMF Forum


From the difficult the hardening of the man you can see

atreiou

January 27, 2005, 06:50:02 AM #2 Last Edit: January 27, 2005, 06:52:36 AM by atreiou
no no intendevo che l'opzione di upload dei files nei post è disabilitata... non l'upload degli avatar...
infatti nel profilo utente il campo per il browsing dei files in locale si vede.. e può essere selezionato

edi67

i files sono una cosa gli avatar unìaltra l'una non incide nell'altra
CrazyZone - My SMF Forum


From the difficult the hardening of the man you can see

atreiou

Quote from: edi67 on January 27, 2005, 06:51:55 AM
i files sono una cosa gli avatar unìaltra l'una non incide nell'altra

ottimo...

cmq confermo che la cartella avatars è già chmoddata a 777 ma l'upload continua a non funzionare, altre idee ?

edi67

dal Pannello di Amminsitrazione vai su Modifica Preferenze e Opzioni  poi su Avatars poi spunta questa linea: Autorizza gli Utenti a fare l' upload dei propri avatars
CrazyZone - My SMF Forum


From the difficult the hardening of the man you can see

atreiou

Quote from: edi67 on January 27, 2005, 07:00:21 AM
dal Pannello di Amminsitrazione vai su Modifica Preferenze e Opzioni  poi su Avatars poi spunta questa linea: Autorizza gli Utenti a fare l' upload dei propri avatars

scusa forse faccio fatica a spiegarmi...

tale opzione è già abilitata...
infatti il campo di upload nel profilo si vede...
se tale opzione fosse disabilitata, non avrei neanche modo di ottenere il msg di errore, no ?


edi67

il tuo unico problema allora sembra essere quelo dei permessi CHMOD non abilitati nella cartella Avatars.

CrazyZone - My SMF Forum


From the difficult the hardening of the man you can see

FaSan

L' upload degli avatar è gestito come Attach, quindi è quella la cartella da chmod(dare ;) )


FaSan

atreiou

anche attachements è già a 777 ma continua a non funzionare...  ::)

FaSan

Ottimo direi.

Ha controllato che le Path siano giuste ? ;)

atreiou

Quote from: FaSan on January 27, 2005, 08:26:11 AM
Ottimo direi.

Ha controllato che le Path siano giuste ? ;)

si le path sono corrette...
infatti sono le stesse che vengono utilizzate dal forum per far scegliere tra gli avatar precaricati....
e quelli funzionano..  :-[

FaSan

Invece no... è la path della directory attachments che devi controllare ;)

atreiou

caspita ! avevi troppo ragione !
era rimasta la path del vecchio server...
originariamente infatti avevo upgradato da yabbi....
ora tutto risolto

ti devo una birra ! ;D

Nemis

ma perchè gli avatar uploadati dai utenti finiscono nella dir attachment ? (e rinominati in avatar_numero. )
non è meglio finiscan nella dir avatar? magari con il nik utente

FaSan

Perchè è logico che sia così...

Se io invio il mio avatar potrei anche non volere che lo usi anche qualcun'altro... che poi si possa usare lo stesso usando altri metodi è chiaro, ma è anche inevitabile.

Il nostro forum però rispetta "le regole del gioco" ;)


FaSan

Advertisement: