• Welcome to Simple Machines Community Forum. Please login or sign up.
January 26, 2022, 04:00:03 AM

News:

Check out the SMF Function DB!


Update all 1.1.6

Started by AllyJ, September 21, 2008, 02:44:15 PM

Previous topic - Next topic

AllyJ

Ciao ragazzi,
avrei da farvi una domanda...
quando accedo al pannello admin,mi dice che è raccomandabile aggiornare la board alla 1.1.6

Come faccio?
Ho 2 o 3 mod installate...le perdo tutte se aggiorno?
Grazie per le eventuali spiegazioni...

|SabiN|

Per fare l'update basta che leggi bene il messaggio di avviso che ti appare appunto nella pagina admin (c'e' un link in quel messaggio, se ci clicchi ti porta all'installazione di un mob "1.1.6")
Per i mod, devi controllare se sono compatibilita' con la 1.1.6, ti consiglio, dopo aver controllato la compatibilita', di sisastallarli, istallare laggiornamento, e riistallare i mob.

AllyJ

Quindi se le mie mod installate sono compatibili con la 1.1.6,devo in ogni caso disinstallarle e aggiornare?
Non è che perdo anche i file di traduzione in italiano di quelle mod?

Darknico

prova con la patch dall'admin, se nn da errore vai tranqui e installa ;)
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


AllyJ

Ehm...non ho ben capito che devo fare xD

Darknico

vai in admin, vedrai l'avviso di aggiornamento, clicccaci e ti portera nel package manager, dove ti farà installare la patch di aggiornamento
se nn da errori, eseguila e sei apposto
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


AllyJ

Ok,per qualunque problema,scriverò in questo topic ;)
Grazie Dark!

PS:allora lascio le mod installate?se è così,non perdo nessun file in italiano delle mod?

Darknico

Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


AllyJ

Bene...allora provvedo ad aggiornare la board ;)

kanaka

essendo in ignorante totale di SMF non so come aggiornare la mia, oltre che avere varie versioni di SMF installate, dalla 1.1 alla 1.1.5 e pure la 1.1 RC2. chi mi può aiutare ad aggiornare il nostro forum, sono mesi che va male oltre che a bloccarsi completamente... grazie 1000 in anticipo...

Darknico

se hai la 1.1.5 usa la patch dall'admin
se invece hai versioni precedenti una un large upgrde che trovi in area download
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

October 26, 2008, 12:07:53 PM #11 Last Edit: October 26, 2008, 12:19:24 PM by kanaka
grazie Darknico, ci provo, ma sono veramente ignorante, come si fa, scarico la large update e poi lo uppo sul forum e li la eseguo, e come faccio ad eseguirla?  grazie mille, ci stò mettendo tanto per capire come funziona, ma fino ad ieri facevo   solo i backup di MySql e del forum...
PS se vado in admin, non vedo(forse perchè troppo inesperto) il package manager, ovvero l'unica cosa che compare è il confronto delle versioni tra le nuove e quelle installate sul forum. Un' altra finestra mi avvisa delle versioni più recenti ma se clicco li sopra mi porta in SMF...

Darknico

Quote from: kanaka on October 26, 2008, 12:07:53 PM
grazie Darknico, ci provo, ma sono veramente ignorante, come si fa, scarico la large update e poi lo uppo sul forum e li la eseguo, e come faccio ad eseguirla?

dopo che lo carichi via ftp copme hai fatto per l'install, quindi sostituirà tutti i file, lancia il file upgrade.php


Quote from: kanaka on October 26, 2008, 12:07:53 PM
PS se vado in admin, non vedo(forse perchè troppo inesperto) il package manager, ovvero l'unica cosa che compare è il confronto delle versioni tra le nuove e quelle installate sul forum. Un' altra finestra mi avvisa delle versioni più recenti ma se clicco li sopra mi porta in SMF...

è una delle prime opzioni dell'admin
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

October 26, 2008, 04:23:06 PM #13 Last Edit: October 26, 2008, 04:26:37 PM by kanaka
scusami, se vuoi darmi del pirla testadura fai pure, ma lo uppo dentro una cartella oppure una volta scompattato in locale uppo il suo contenuto, e da che applicazione lancio update.php da esplora risorse o da che? potrebbe darmi dei problemi con i mod? Mi scuso ancora ma non ci capisco una mazza!!! abbi pazienza

PS: grazie ancora, non saprei come fare senza i tuoi consigli

Darknico

non hai visto ke l'upgrade è uguale all'installa, intendo il contenuto
quindi carica esattamente come hai fatto quando hai installato
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

Quote from: Darknico on October 27, 2008, 04:46:06 AM
non hai visto ke l'upgrade è uguale all'installa, intendo il contenuto
quindi carica esattamente come hai fatto quando hai installato
scusami, mi sono espresso male, lo uppato nella sua cartella dopo il de-zippaggio, quindi in pratica ho solo aggiunto una cartella al forum, devo spostare fuori dalla sua stessa cartella il contenuto, giusto!!?
Per eseguirlo come faccio, da esplora risorse me lo apre come wordpad, e dal sito come faccio???

Darknico

ma scusa, come carichi via ftp?
cmq basta che elimi quella cartella e ricarchi, che problema c'è?
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

o via cuteFTP o con esplora risorse di windows...
quindi se lo uplodo così senza cartella l'aggiornamento è già stato fatto.

Darknico

Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

October 27, 2008, 06:38:44 PM #19 Last Edit: October 27, 2008, 07:00:04 PM by kanaka
Quote from: Darknico on October 27, 2008, 11:19:02 AM
dopo aver uppato fai http://tuoindirizzo/upgrade.php e segui il procedimento
Grazzissimo, ora inizo a capire un poco come funziona...

PS: ultimissima cosa... se avessi bisogno di aiuto per ultreriori cose che vanno male mi aiuteresti? in privato ti fornirei ila possibilità di poter operare sul nostro forum

kanaka

L'upgrade è andato bene, ci sono alcuni menu in inglesema non sarà un problema, unica cosa ne menu: ADMIN>MNUTENZIONE DEL FORUM>DETAILED VERSION CHECK
mi compare il seguente messaggio:
Modelli in uso                   1.0   1.1
BoardIndex.template.php   1.1 RC2   1.1
Coppermine.template.php   ??   ??
Display.template.php   1.1 RC2   1.1
Help.template.php                   1.0   1.1
MessageIndex.template.php   1.1 RC2   1.1
index.template.php                   1.1 RC2   1.1
come posso rimediare o correggere il problema..
Grazie per l'immensa pazienza e per il supporto(facendo pure io l'ADMIN, non so neppure perchè mi ci sia infilato) che mi fornisci, spero di poter ricambiare

Darknico

in privato non supporto, mi spiace
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

Quote from: Darknico on October 28, 2008, 04:53:27 AM
in privato non supporto, mi spiace
ok, ma mi puoi dire cosa posso fare per correggere l'errore che ti ho descritto?


Darknico

per i menu in inglese scarica la  traduzione completa e aggiornata qui
http://www.smitalia.net/community/index.php

per le versioni bisogna aggiornare credo i template, a quanto vedo hai fatto l'aggiornamento dalla 1.1rc2 alla 1.1.6
usi un tema non di default vero?se imposti il default dovrebbe essere ok
se è ok allora aggiorna il tuo tema

guarda qui
http://www.simplemachines.org/community/index.php?topic=82003.0

a te interessa solo quetsa parte
QuoteTemplate changes from SMF 1.1 RC2 to 1.1 RC3
Template Changes from SMF 1.1 RC3 to 1.1 Final
Template Changes from SMF 1.1.1 to 1.1.2
Template Changes from SMF 1.1.2 to 1.1.5

quindi buon lavoro XD
oppure controlla se esiste gia la versione aggiornata del tema
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

dove devo vedere per controllare se ci sono versioni aggiornate dei temi?
azz mi stà creando 30 pagine di errore al giorno... e sempre la chat che fa riferimento al template di dana7.. se non ho capito male...

Darknico

i temi devono essere aggiornati...
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

Darknico, i due errori che mi mandano in tilt il forum sono questi di seguito:

8: Undefined index: chatAlt
File: /web/htdocs/www.gilera-bi4.it/home/public/forum/Themes/7dana_smf/BoardIndex.template.php (eval?)
Line: 378

8: Undefined index: chatStats
File: /web/htdocs/www.gilera-bi4.it/home/public/forum/Themes/7dana_smf/BoardIndex.template.php (eval?)
Line: 374


che mi consigli?

Assimo

Puoi postare la parte di codice di BoardIndex.template.php dalla riga 370 alla riga 380? In questo modo possiamo capire dove sta l'errore.

kanaka

ECCOVELO:

// Chat Stats
   if($modSettings['chatShowUsers'] == true){
   echo '
   <tr>
      <td class="catbg" colspan="2">', $txt['chatStats'], '</td>
   </tr><tr>
      <td class="windowbg" width="20" valign="middle" align="center">
      <a href="', $scripturl, '?action=chat">
            <img src="', $settings['images_url'], '/chatIcon.gif" alt="', $txt['chatAlt'], '" border="0" /></a>
      </td>
      <td class="windowbg2" width="100%">
         There are currently ' . $modSettings['chatNumUsers'] . ' people talking in the chat room.<br /> ' .
         '<div class="smalltext">' . $modSettings['chatUsersList'] . '</div>';
   }
spero che mi possiate aiutare...

Darknico

manca la traduzione
mi link la mod che hai installato?
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

appunto essendo ignorante del tutto in questo campo non so neppure installare le mod...

Darknico

ma la mod è gia installata???
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

October 29, 2008, 03:19:51 PM #32 Last Edit: October 29, 2008, 03:23:02 PM by kanaka
Quote from: Darknico on October 29, 2008, 12:48:02 PM
ma la mod è gia installata???
ferma, la mod è la 1.1.6? e poi veramente non so come fare... sono nella c***a

kanaka

la mod è installata, così come la chat integrata, ma continua a dare errore come sopra...

Darknico

Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

November 01, 2008, 05:03:17 PM #35 Last Edit: November 01, 2008, 05:10:27 PM by kanaka
Scusami ma non mi è chiaro:

Template changes from SMF 1.1 RC1 to 1.1 RC2
Template changes from SMF 1.1 RC2 to 1.1 RC3
Template Changes from SMF 1.1 RC3 to 1.1 Final
Template Changes from SMF 1.1.1 to 1.1.2
Template Changes from SMF 1.1.2 to 1.1.5

devo fare tutti passaggi?

e poi che mod intendi, la chat? o cos'altro?
non sono pratico e già l'aver aggiornato al 1.1.6 e inserito la lingua italiana per me è stato un passo da gigante... il tema che uso è 7Dana 1.1 RC2 con i colori modificati, dove lo posso trovare, ho provato a guardare su SMF, ma senza risultato.

kanaka

Lo so che sono una palla al piede, ma rispondetemi...  per cortesia

kanaka

possibile che io sia così logorroico????

Assimo

Quote from: kanaka on November 01, 2008, 05:03:17 PM
e poi che mod intendi, la chat? o cos'altro?
La chat.

Comunque devi mettere le stringhe di traduzione in uno dei file. Se ci dai il link della mod che stai usando qui su simplemachines, ti diciamo dove trovare la traduzione.

kanaka

http://custom.simplemachines.org/mods/index.php?mod=60
la chat è questa si è installata bene...ma mi da sempre i 2 errori

Darknico

manca una parte di traduzione, se il resto l'hai gia messa

file /Themes/default/languages/index.italian.php


$txt['chatAlt'] = 'Chat';
$txt['chatStats'] = 'Chat Stats';
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

quelle due stringhe non ci sono, se le devo mettere dimmi dove vanno, grazie ancora nico...

edi67

Quote from: kanaka on November 05, 2008, 05:06:26 PM
quelle due stringhe non ci sono, se le devo mettere dimmi dove vanno, grazie ancora nico...

te l'ha già detto dove vanno nel file file /Themes/default/languages/index.italian.php
CrazyZone - My SMF Forum


From the difficult the hardening of the man you can see

kanaka

Quote from: edi67 on November 06, 2008, 03:53:56 AM
Quote from: kanaka on November 05, 2008, 05:06:26 PM
quelle due stringhe non ci sono, se le devo mettere dimmi dove vanno, grazie ancora nico...

te l'ha già detto dove vanno nel file file /Themes/default/languages/index.italian.php
li c'ero arrivato, ma in che posizione all'interno del file /Themes/default/languages/index.italian.php vanno messe, o le scrivo dove capita????!!!

Darknico

esattamente, dove ti pare xD
devi solo inserirle, alla fine, all'inizio, in mezzo, in questo caso non ha importanza...

nn hai mai messo stringhe di traduzione??
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

no, non so neppure dove trovarle, ho cambiato tema ora uso class red, ma trovare le corrispondenze tra colore da cambiare e posizione, è quasi impossibile...

ora ho risolto(non compare più nel forum, la chat, ed alcuni link mancano) i vecchi errori ma ne compaiono altri su diverse righe ma lo stesso errore:
8: Undefined variable: txt
File: /web/htdocs/www.gilera-bi4.it/home/public/forum/Themes/default/languages/Who.italian.php (eval?)
Linea: 59


8: Undefined variable: txt
File: /web/htdocs/www.gilera-bi4.it/home/public/forum/Themes/default/languages/Who.italian.php (eval?)
Linea: 41


8: Undefined variable: txt
File: /web/htdocs/www.gilera-bi4.it/home/public/forum/Themes/default/languages/Who.italian.php (eval?)
Linea: 16


8: Undefined variable: txt
File: /web/htdocs/www.gilera-bi4.it/home/public/forum/Themes/default/languages/Who.italian.php (eval?)
Linea: 15


8: Undefined variable: scripturl
File: /web/htdocs/www.gilera-bi4.it/home/public/forum/Themes/default/languages/Who.italian.php (eval?)
Linea: 14


Assimo

November 06, 2008, 06:16:06 PM #46 Last Edit: November 06, 2008, 06:18:26 PM by Assimo
Scommetto che se metti il tema di default e la lingua inglese spariscono, vero?

Usa il package parser, sottoponendogli il file zip. Ti dirà che file devi modificare del tuo tema e cosa devi aggiungere.(attento, devi modificarne anche la versione in italiano!). se un certo file manca, ignora quella parte e passa alla successiva.

Darknico

ma allora non hai messo nessuna traduzione dentro -.-
manca ancora:

ModSettings.italian.php


$txt['chatTitle'] = 'Integrated Chat Settings';
$txt['chatLanguage'] = 'Choose the language of your board';
$txt['chatRoomName'] = 'Type in the name of your chat room';
$txt['chatAppend'] = 'Type in 3 or 4 letters to append to every user name. This prevents duplicate names from the server, ex _app';
$txt['chatWidth'] = 'Type in the Width of the chat applet (default 700)';
$txt['chatHeight'] = 'Type in the Height of the chat applet (default 500)';
$txt['chatPassword'] = 'If you want to put a password on your room put it here, otherwise use NULL';
$txt['chatUpdateInterval'] = 'How often do you want the chat stats updated, in seconds';
$txt['chatRoomsTab'] = 'If you do not want a list of other chat rooms to appear uncheck, otherwise check';
$txt['chatAds'] = 'Leave checked to help support the chat server and show ads. Otherwise uncheck';
$txt['chatShowUsers'] = 'List the number of users and their names in chat on the board index';
$txt['chatShowTop'] = 'Show the number of users logged in and who they are at the top of the site';


help.italian.php
$txt['whoall_chat'] = 'Entering the <a href="' . $scripturl . '?action=chat">Chat Room</a>.';

Who.italian.php

$helptxt['chatRoomName'] = ' This is the name of your chat room name. Make sure it does not exist on the server first. Then once you have gone in the room double click on it to register yourself and your other mods.';
$helptxt['chatLanguage'] = ' You can change language or color with this. Possible language entries are spanish.prm,dutch.prm,german.prm,turkey.prm,nepal.prm,french.prm,greek.prm,finnish.prm,Thai.prm,italian.prm,port.prm,malaysian.prm,polish.prm . Possible colors are white.prm,black.prm,brown.prm';
Italian SMF - Supporto Italiano per la board SMF - Ci trovate tutti li!! :)


kanaka

November 07, 2008, 05:05:53 PM #48 Last Edit: November 08, 2008, 09:25:04 PM by kanaka
Patch applicate, grazie darknico, ma gli errori rimangono:

8: Undefined index: chatStats
File: /web/htdocs/www.gilera-bi4.it/home/public/forum/Themes/7dana_smf/BoardIndex.template.php (eval?)
Linea: 374

8: Undefined index: chatAlt
File: /web/htdocs/www.gilera-bi4.it/home/public/forum/Themes/7dana_smf/BoardIndex.template.php (eval?)
Linea: 378


oltre ad i due errori aggiunti... tutto questo con il tema 7dana....

8: Undefined variable: txt
File: /web/htdocs/www.gilera-bi4.it/home/public/forum/Themes/default/languages/Who.italian.php (eval?)
Linea: 59

8: Undefined variable: txt
File: /web/htdocs/www.gilera-bi4.it/home/public/forum/Themes/default/languages/Who.italian.php (eval?)
Linea: 41

Questi due errori non so come risolverli



kanaka

dimenticavo, gli ultimi 2 errori sono con il tema nuovo, che implica funzioni non usate da noi, per default... volete i file per capire meglio?

kanaka

Darknico, edi67 e Assimo... aiutooooooooooo

Assimo

Hai messo tutte le stringhe che ti ha detto Darknico? Le hai inoltre copiate anche nei file con lo stesso nome nella cartella languages del tuo tema, se ci sono tali file?

Advertisement: