Advertisement:

Author Topic: trying to convert from yabb2.1 , now can't log in as admin  (Read 69147 times)

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2, now can't log in as admin
« Reply #60 on: October 15, 2008, 12:07:56 PM »
Go ahead and empty the smf_sessions table. This just contains information about any session. So removing it will not affect anything really.
Go to the smf_settings table. Search for "databaseSession_enable".
If this exists, make sure it is set to 1, if not, create this and set it to 1.

Sorry about the "bad news" but the variable exists and is already set to 1.

I emptied smf_sessions, tried to login again, and a session entry was indeed made... but still, I can't login.

I don't see any errors being logged. I never thought it would be so complicated...  ;)

What debug do you suggest I put in?

Offline SleePy

  • Let there be light!
  • Site Team Lead
  • SMF Master
  • *
  • Posts: 30,526
  • Gender: Male
  • Thats his happy face.
    • jdarwood007 on GitHub
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: trying to convert from yabb2, now can't log in as admin
« Reply #61 on: October 15, 2008, 02:00:23 PM »
Well lets try to set that to 0 then and let php handle sessions.

If that doesn't work. I may need to look at it myself. I am quite perplexed at why it worked before the conversion and then after it, issues :|
The only thing I can think of would be the cookieTime setting that is copied over from Yabb. But that wouldn't make sense either :(
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2, now can't log in as admin
« Reply #62 on: October 15, 2008, 07:55:17 PM »
Well lets try to set that to 0 then and let php handle sessions.

If that doesn't work. I may need to look at it myself. I am quite perplexed at why it worked before the conversion and then after it, issues :|
The only thing I can think of would be the cookieTime setting that is copied over from Yabb. But that wouldn't make sense either :(

Well, I've just about given up...  :(

I set the databaseSession_enable in mysql to 0.

No change whatsoever. Even more strange, the cookies are still no different. I would have excpected to see more cookies (unless you're calling them something different? In debug I'm printing out what I get back from session_get_cookie_params()) and I still get nothing meaningful. No cookies are set.

I don't see any errors. But I can't login to the converted boards no matter what I do.

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2, now can't log in as admin
« Reply #63 on: October 16, 2008, 04:25:39 PM »
So I've been slowly trying to debug this.

What I've found so far is that after login, I end up getting kicked out where there's the "return 'KickGuest'" in index.php.

Not only that, I figured out that $user_info['is_guest'] is set to 1!

Even though I'm a registered user in smf_members. So I noticed that dateRegistered is 0.

So I'm sure that both of these things are causing my problem... the dateRegistered and the is_guest. I don't know how to get is_guest to be false.

Also, I noticed that ALL members have both a dateRegistered of 0 and ID_MEMBER is 0!!! So certainly that's messed up, everybody has the same ID.

So lo and behold... I changed my ID_MEMBER to 1 instead of 0 and suddenly the login seems to work... except that it's taking up all of the cpu and doing something with mysql. It's been there for a couple of minutes already, I don't know what it's doing.

So, in any case... the conversion needs to make sure that the dateRegistered and ID_MEMBER are all properly populated!

My login still hasn't completed, I don't know what's going on with mysql right now.

Offline SleePy

  • Let there be light!
  • Site Team Lead
  • SMF Master
  • *
  • Posts: 30,526
  • Gender: Male
  • Thats his happy face.
    • jdarwood007 on GitHub
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #64 on: October 17, 2008, 05:52:40 PM »
date_registered doesn't affect logins. The guest part just says your login failed.
The id_member could be the cause though. That seems odd they all have an id of 0. Although I do remember that the yabb converter did have a lot of issues until I rewrote it for Yabb 2.2.
Do you have any processes running in mysql?

edit,
btw. I changed the topic title here. I keep forgetting what version of yabb you are on so it will help me :P
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #65 on: October 19, 2008, 12:08:37 PM »
SleePy,

Thanks for your help so far. I really haven't had much luck. After I finally got to successfully login, the board goes nuts doing something with mysql and never actually lets me into the board.

So I've wiped everything out and started from scratch.

Is it possible to have 2 convert scripts, one that converts ONLY the members, boards, categories, moderators, and then one that converts ONLY the topics and posts?

I want to FIRST be able to reproduce the whole board structure with members. Make sure members can login and their settings are all correct.

Then only after that, I would convert the topics and posts, which is what takes many hours anyway. This is a board with 20,000 topics and 350,000 posts...

ThorstenE

  • Guest
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #66 on: October 19, 2008, 02:36:51 PM »
rkleemann,
If your yabb-version is still 2.1...  I have modified SleePy's yabb22_to_smf.php a little bit so it worked for Yabb 2.1 (and successfuly converted a yabb 2.1 with 50k Posts last week)

You should re-install SMF before using this because the old yabb21_to_smf.php has modified some tables and dropped indexes..

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #67 on: October 19, 2008, 04:42:55 PM »
Thanks!

Now is it easy to change the script so that it does it in 2 parts like I described above?

Offline SleePy

  • Let there be light!
  • Site Team Lead
  • SMF Master
  • *
  • Posts: 30,526
  • Gender: Male
  • Thats his happy face.
    • jdarwood007 on GitHub
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #68 on: October 19, 2008, 09:21:52 PM »
We could.

TE, did all parts convert? If it did. I will just update it as the official 2.1 converter and get a 2.0 version generated.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #69 on: October 20, 2008, 11:09:04 AM »
We could.

TE, did all parts convert? If it did. I will just update it as the official 2.1 converter and get a 2.0 version generated.

Thanks SleePy!

Now, these 2 scripts, are they based on the original 2.1 converter, or on TE's 2.2 converter above?

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #70 on: October 21, 2008, 01:22:32 PM »
Guys,

Since TE's scripts successfully converted a 2.1 board, I wanted to make sure that SleePy's 2 part scripts are based on that, before I tried them out...

Thanks for your help
Ricardo

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #71 on: October 21, 2008, 03:48:05 PM »
Is there another top-level convert script that I should be using?

I'm getting this error:
arse error: syntax error, unexpected ';', expecting ')' in /shared/www/SMF/convert.php on line 2656

ThorstenE

  • Guest
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #72 on: October 22, 2008, 09:55:48 AM »
the convert.php is attached to the topic: (scroll down)
http://www.simplemachines.org/community/index.php?topic=140741.0

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #73 on: October 22, 2008, 02:08:54 PM »
Thanks for your help guys.

So now I have another issue. I ran the "part1" conversion, but it seems that the conversion truncated almost everything for each of the boards because they were in another language.

Basically each text (title, description, etc) gets truncated where the first accented character would be found.

Even selecting UTF8 during conversion didn't fix this...

For example, all of the board titles begin with the word "Fórum", however all boards come out with the title "F".

ThorstenE

  • Guest
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #74 on: October 22, 2008, 02:48:03 PM »
is your forum installation UTF-8 or another charset? the source (yabb) is a text based forum so SMF should be installed in a localized charset (latin1 for example)..

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #75 on: October 22, 2008, 02:57:32 PM »
In mysql, the tables are utf8 collation

All I know is I have a bunch of boards all named just "F" ;-)

Offline SleePy

  • Let there be light!
  • Site Team Lead
  • SMF Master
  • *
  • Posts: 30,526
  • Gender: Male
  • Thats his happy face.
    • jdarwood007 on GitHub
    • @jdarwood on Twitter
    • SleePy Code - My personal site
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #76 on: October 23, 2008, 12:35:59 AM »
Well that is odd. Did it work before we split it up into parts?

I just did a lot of simple returns on TEs script for each of the sections we where going to skip. Noting fancy really.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:
GitHub

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #77 on: October 23, 2008, 12:44:46 AM »
I never got a full conversion to work so I'm not sure whether it worked before.

The master board/forum description has no problems with foreign characters. It's only the converted boards and their descriptions that don't like foreign characters.

All board names and descriptions are truncated.

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #78 on: October 23, 2008, 01:41:48 AM »
I figured it out.

I think when I installed, I selected UTF8.

So I wiped out the entire installation and re-installed with default latin-1 encoding. Now the boards convert correctly.

I'm not quite ready yet to convert the posts... but all the boards and members are there!  :D

Thanks guys for all your help!

Offline rkleemann

  • Jr. Member
  • **
  • Posts: 113
Re: trying to convert from yabb2.1 , now can't log in as admin
« Reply #79 on: October 30, 2008, 12:01:29 PM »
guys, the registration date for the yabb2.1 users didn't convert over...

I have almost 1000 users in a board, and wanted to make sure their register date also converted...

Now, a question unrelated to conversion, but I'm trying to figure out, how does one select which smileys to use when posting? I configured the board so the user can select the smileys, but when posting I don't see an option to select.