• Welcome to Simple Machines Community Forum. Please login or sign up.

Message for your guests

Started by babjusi, September 29, 2008, 08:33:00 PM

Previous topic - Next topic

babjusi

Quote from: The Cadet on October 03, 2008, 07:53:10 AM
Quote from: babjusi on October 03, 2008, 07:51:18 AM
Quote from: The Cadet on October 03, 2008, 07:49:03 AM
./Themes/default/languages/Modifications.english.php

It doesn't exist on the theme I'm using as a default. Also, after installing the mod, nothing happened. So I went and installed it manually for the theme I'm using and still nothing happened. I did edit the index file though, for a custom banner/navbar setup, so that could be the cause.

What theme are you using? Can you link me to it?

http://custom.simplemachines.org/themes/index.php?lemma=577

I should've thought of that. -_°_-

:)

The only file you need to edit is the index.template.php of the dn theme. I just tested out with that theme and you can see the result at the screenshot attached below

If you want, you can attach here the file in question and I will make the edits for you :)



W. Riker

What code I need enter to get massage bold?

babjusi

Quote from: W. Riker on October 03, 2008, 11:58:16 AM
What code I need enter to get massage bold?

Do you mean your custom message? Just place the text between the <strong></strong> tags

Bigguy

I have tried using html and bbc in this mod and it's not parsing it I don't think.

W. Riker

Quote from: babjusi on October 03, 2008, 12:19:05 PM
Quote from: W. Riker on October 03, 2008, 11:58:16 AM
What code I need enter to get massage bold?

Do you mean your custom message? Just place the text between the <strong></strong> tags


Thanks babjusi...

babjusi

Quote from: Bigguy on October 03, 2008, 12:36:57 PM
I have tried using html and bbc in this mod and it's not parsing it I don't think.

I have tested it at a 1.1.6 forum and it works fine. To be honest I haven''t tested it yet at a 2.0 beta 4 forum

Here is a screenshot at a 1.1.6 forum

babjusi

Quote from: W. Riker on October 03, 2008, 12:45:13 PM
Quote from: babjusi on October 03, 2008, 12:19:05 PM
Quote from: W. Riker on October 03, 2008, 11:58:16 AM
What code I need enter to get massage bold?

Do you mean your custom message? Just place the text between the <strong></strong> tags


Thanks babjusi...

You are welcome W. Riker. Glad to have been of help :)

Bigguy

Ok, I will check it out again maybe I did something wrong.  :P

Quote from: babjusi on October 03, 2008, 12:48:24 PM
Quote from: Bigguy on October 03, 2008, 12:36:57 PM
I have tried using html and bbc in this mod and it's not parsing it I don't think.

I have tested it at a 1.1.6 forum and it works fine. To be honest I haven''t tested it yet at a 2.0 beta 4 forum

Here is a screenshot at a 1.1.6 forum

The Cadet

October 06, 2008, 01:01:57 AM #28 Last Edit: October 06, 2008, 01:04:48 AM by The Cadet
Quote from: babjusi on October 03, 2008, 08:02:09 AM
The only file you need to edit is the index.template.php of the dn theme. I just tested out with that theme and you can see the result at the screenshot attached below

If you want, you can attach here the file in question and I will make the edits for you :)

I manually edited it in (a skill I learned working with phpBB3 which I now hate).
But it still doesn't show up. I believe it could have to do with this edit I made:

<div id="side_borders_inner">
<table border="0" width="100%" cellpadding="0" cellspacing="0" align="center">
<tr>
<td width="100%" class="logo_bg">
<table width="100%" border="0" cellpadding="0" cellspacing="0">
<tr>
<td class="logo_bg"><table>
<tr><td><a href="http://forums.mtgdarkness.com"><img src="http://www.mtgdarkness.com/images/darknesslogo.gif" alt="MTGDarkness Banner" width="100%" /></a></td></tr>
<tr>
<td class="menu" width="100%">
<ul class="mtgdmenu">
<li class="mtgdmenu"><p class="mtext"><a href="http://www.mtgdarkness.com" class="menulink">Home</a></p></li>
<li class="mtgdmenu"><p class="mtext"><a href="http://forums.mtgdarkness.com" class="menulink">Forums</a></p></li>
<li class="mtgdmenu"><p class="mtext"><a href="http://www.mtgdarkness.com/articles.php" class="menulink">Articles</a></p></li>
<li class="mtgdmenu"><p class="mtext"><a href="http://www.mtgdarkness.com/friends.php" class="menulink">Friends</a></p></li>
    <li class="mtgdmenu"><p class="mtext"><a href="http://www.mtgdarkness.com/associates.php" class="menulink">Associates</a></p></li>
</ul>
</td>
</tr>
</table>
</td>
<td class="logo_bg">&nbsp;</td>


That replaces the original place where the banner $var would've been. Could this be the cause?

My board is here: http://forums.mtgdarkness.com

babjusi

@The Cadet, can you please attach here the index.template.php file?



The Cadet



Filipina

Ok hope you can give me an idea here.  I just uploaded the MOD and all files were showing good to go.  But then I got this below at the top of my forum?  The funny thing is the same type problem happened when i tried to install the new Redirect on log in/out MOD all files looked good but then the same thing :'(

//The start of the language strings for the guest message mod $txt['mf_guests']='Guest Greeting Message
Leave blank to show the default message
'; $txt['default_message']='Welcome to our community.

Please consider registering to gain full access!
Registration is free and it only takes a few moments to complete. '; $txt['enable_mfg_mod']='Enable the guest message mod';

babjusi

Quote from: Filipina on October 06, 2008, 11:06:59 PM
Ok hope you can give me an idea here.  I just uploaded the MOD and all files were showing good to go.  But then I got this below at the top of my forum?  The funny thing is the same type problem happened when i tried to install the new Redirect on log in/out MOD all files looked good but then the same thing :'(

//The start of the language strings for the guest message mod $txt['mf_guests']='Guest Greeting Message
Leave blank to show the default message
'; $txt['default_message']='Welcome to our community.

Please consider registering to gain full access!
Registration is free and it only takes a few moments to complete. '; $txt['enable_mfg_mod']='Enable the guest message mod';

Open the Modifications.english.php file in the languages directory and make sure that all the contents in there are between the starting and closing php tags.

Filipina

thanks this was the problem with both MODS and I missed it.  Working fine and thank you for the great mod!

babjusi

Quote from: Filipina on October 07, 2008, 03:20:53 PM
thanks this was the problem with both MODS and I missed it.  Working fine and thank you for the great mod!

Glad to have been of help and thank you for your feedback :)

cammy1568

How do i center the text and put it on a new line like in the picture ???
Because i tryed the basic bbcode and it didnt work

Game-Flight

Join Us Today! And help us out!


babjusi

Quote from: cammy1568 on October 16, 2008, 12:43:00 PM
How do i center the text and put it on a new line like in the picture ???
Because i tryed the basic bbcode and it didnt work

Just enter the text at the box area of the mod settings at the Acp of your forum. The text will appear centered by itself. bbcode is not enabled, html yes.

Advertisement: