Advertisement:

Author Topic: Highslide Image Viewer  (Read 272032 times)

Offline Sabre™

  • SMF Hero
  • ******
  • Posts: 2,527
  • Gender: Male
  • IF IT AINT BROKE, I CAN FIX IT TILL IT IS!!
Re: Highslide Image Viewer
« Reply #40 on: October 11, 2008, 01:08:07 AM »
@ Tanks
Could you possibly share what you did to get it to work?
It could help others that experience the same problem.

Cheers  :)
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #41 on: October 11, 2008, 01:14:58 AM »
It was actual just me being a retard because i forgot to click the little box to install on other themes.. and since my theme only has a boardindex template, and no display template, it looked like it was installed but it wasnt :)

I am happy to use this mod ;)

Offline Sabre™

  • SMF Hero
  • ******
  • Posts: 2,527
  • Gender: Male
  • IF IT AINT BROKE, I CAN FIX IT TILL IT IS!!
Re: Highslide Image Viewer
« Reply #42 on: October 11, 2008, 01:17:38 AM »
hehe

Well, that will help others remember if they do the same ;)
Thanks for that champ, and great that you figured it out.
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Offline nokster

  • Newbie
  • *
  • Posts: 1
Re: Highslide Image Viewer
« Reply #43 on: October 11, 2008, 06:09:35 AM »
Hello everyone!!

Just installed SMF yesterday and i'm flabbergasted with it!! :D Congratz for the work!!

Anyways, I installed Highslide Image Viewer 1.0 RC4 by going to Admin->Packages->Browse Packages clicked on Highslide Image Viewer 1.0 RC4 and then clicked on install. The instalation was successful but the images are not doing their thing on the posts not even on new posts and yes, i've tried with some big images.

I'm half-a-noob in this so if you guys can give me some help I would be very apreciated.

PS: don't know if it's correct or not but I went to my ftp account to check the smf/Packages dir and there was 3 files and one folder there:
  • backups (folder)
  • Highslide_Viewer_1_RC5.zip
  • index.php
  • installed.list

Is this correct? After the instalation it dosen't decompress the zip file? Just asking cuz I found it awkward.

Tanx again for any help!!

Cheer from Portugal! :D

edit:

After a bit of reading I went again to my FTP and I can confirm that smf/Theme/default/highslide exists with all the files inside. I copied two new files inside the directory highslide.english.js and highslide.portuguese_pt-utf8.js (modified english version for Portugal portuguese, not brazilian).

I still don't know how to use this? Is there a BBC code that I don't know like "[hsiv]"?? Or I just have to use regular old "[ img][ /img]"??
I feeling so stupid!!! Please help!!
« Last Edit: October 11, 2008, 09:03:23 AM by nokster »

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #44 on: October 11, 2008, 07:00:50 AM »
Nice mod mate :)
When using a url from photobucket etc, how can you eliminate the url showing up in the frame of the popup image or clean it up to be renamed to the name you'd like??

eg..
h**p://photobucket.com/folder/universal/file/youseewhatImean/this/is/too/long/image/manboobs.gif

And just to display the name of the image = "manboobs.gif"  or rewrite it to whatever yoiu'd like to display

Cheers  :)
In a next versions will be some changes for this.

Offline Rifugio

  • Semi-Newbie
  • *
  • Posts: 17
Re: Highslide Image Viewer
« Reply #45 on: October 11, 2008, 07:54:04 PM »
Just installed version RC5 on SMF 1.1.6 and it worked straight out of the tin.  Very impressive as I've been having real problems getting the new Lightbox mod to work.  Especially like the slide-show and the hassle free install great work.

One request, the current refresh for a new image involves each image expanding from the bottom half of the image and filling the screen - this is great for the first image but when you browse using the arrows or use the slide show it looks really jerky and spoils the effect.  Would it be possible to change this to a more static fade, without the bottom left to bottom right fade?

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #46 on: October 11, 2008, 08:49:43 PM »
One request, the current refresh for a new image involves each image expanding from the bottom half of the image and filling the screen - this is great for the first image but when you browse using the arrows or use the slide show it looks really jerky and spoils the effect.  Would it be possible to change this to a more static fade, without the bottom left to bottom right fade?
This changed in RC6.
« Last Edit: October 11, 2008, 09:20:22 PM by digger »

Offline TW1ST3D

  • Jr. Member
  • **
  • Posts: 178
    • The Georgia LX Club
Re: Highslide Image Viewer
« Reply #47 on: October 11, 2008, 10:11:07 PM »
Hello everyone!!

Just installed SMF yesterday and i'm flabbergasted with it!! :D Congratz for the work!!

Anyways, I installed Highslide Image Viewer 1.0 RC4 by going to Admin->Packages->Browse Packages clicked on Highslide Image Viewer 1.0 RC4 and then clicked on install. The instalation was successful but the images are not doing their thing on the posts not even on new posts and yes, i've tried with some big images.

I'm half-a-noob in this so if you guys can give me some help I would be very apreciated.

PS: don't know if it's correct or not but I went to my ftp account to check the smf/Packages dir and there was 3 files and one folder there:
  • backups (folder)
  • Highslide_Viewer_1_RC5.zip
  • index.php
  • installed.list

Is this correct? After the instalation it dosen't decompress the zip file? Just asking cuz I found it awkward.

Tanx again for any help!!

Cheer from Portugal! :D

edit:

After a bit of reading I went again to my FTP and I can confirm that smf/Theme/default/highslide exists with all the files inside. I copied two new files inside the directory highslide.english.js and highslide.portuguese_pt-utf8.js (modified english version for Portugal portuguese, not brazilian).

I still don't know how to use this? Is there a BBC code that I don't know like "[hsiv]"?? Or I just have to use regular old "[ img][ /img]"??
I feeling so stupid!!! Please help!!

It doesn't do anything to images posted inside [img] tags. To see this mod in action, you need to post the Picture as an attachment.
Running 2.0 Gold.......SMF Rocks!!

Offline Sabre™

  • SMF Hero
  • ******
  • Posts: 2,527
  • Gender: Male
  • IF IT AINT BROKE, I CAN FIX IT TILL IT IS!!
Re: Highslide Image Viewer
« Reply #48 on: October 11, 2008, 10:18:31 PM »
Unless the image you add within the image tags are hosted at iPicture.ru, Imageshack.us or Photobucket.com.
eg.
[img ]h**p://photobucket.com/please/check/before/replying.gif [/img ]
« Last Edit: October 11, 2008, 10:24:00 PM by Sabre™ »
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


Offline asms323

  • Semi-Newbie
  • *
  • Posts: 23
Re: Highslide Image Viewer
« Reply #49 on: October 11, 2008, 10:19:23 PM »
nice mod
work with me without
any problem
thanx

Offline Rifugio

  • Semi-Newbie
  • *
  • Posts: 17
Re: Highslide Image Viewer
« Reply #50 on: October 12, 2008, 08:04:44 AM »
Now that's rapid prototyping!  This is absolutely fantastic, only thing missing compared to lightbox - is lightbox shades the background web page with a very dark filter to help the images stand out.  Enjoying the slide show :)

One request, the current refresh for a new image involves each image expanding from the bottom half of the image and filling the screen - this is great for the first image but when you browse using the arrows or use the slide show it looks really jerky and spoils the effect.  Would it be possible to change this to a more static fade, without the bottom left to bottom right fade?
This changed in RC6.

Offline fals

  • Jr. Member
  • **
  • Posts: 287
  • Gender: Male
  • bouncing through codes...
    • Large Scale Forum Denmark
Re: Highslide Image Viewer
« Reply #51 on: October 12, 2008, 08:08:30 AM »
...only thing missing compared to lightbox - is lightbox shades the background web page with a very dark filter to help the images stand out.  Enjoying the slide show :)
No problem - Highslide can do this
http://highslide.com/example-mini-gallery.html
 
[view the sourcecode of the example]  ;)
 
Or add:
Code: [Select]

     hs.dimmingDuration = "15";
    hs.dimmingOpacity = 0.75;
« Last Edit: October 12, 2008, 08:19:16 AM by fals »
500fan.dk - SMF 2.0 ~ custom theme
ls-forum.dk - SMF 2.0.2 ~ custom theme and custom iPhone theme

Offline tatore

  • Sophist Member
  • *****
  • Posts: 1,259
  • Gender: Male
    • salvo.franchina on Facebook
    • @tatore on Twitter
    • SalvoFranchina.it
Re: Highslide Image Viewer
« Reply #52 on: October 12, 2008, 08:41:40 AM »
Quote
Notice:  Undefined index:  subject in /home/XXXXXX/public_html/forum/Sources/Subs.php on line 2485
Unfortunately I have this problem, and it's displayed on my home (Joomla+smf Orstio's bridge).
Let me know, please, how to fix it. It's a great mod.

At the line 2485:
Code: [Select]
$message = str_replace($b[0], $b[5], $message) . '<div class="highslide-heading">' . $context['subject'] . '</div>';
« Last Edit: October 12, 2008, 09:01:00 AM by tatore »
*Salvo*




Quote from: Rumbaar
I wont jump to conclusion, but you might be hacked?

Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #53 on: October 12, 2008, 08:45:10 AM »
@ Fals - Where do you add that ? What file ? Thanks !

Offline fals

  • Jr. Member
  • **
  • Posts: 287
  • Gender: Male
  • bouncing through codes...
    • Large Scale Forum Denmark
Re: Highslide Image Viewer
« Reply #54 on: October 12, 2008, 09:21:35 AM »
@ Fals - Where do you add that ? What file ? Thanks !
index.template.php - you can place it after:
hs.graphicsDir = "', $settings['default_theme_url'], '/highslide/";
500fan.dk - SMF 2.0 ~ custom theme
ls-forum.dk - SMF 2.0.2 ~ custom theme and custom iPhone theme

Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #55 on: October 12, 2008, 10:09:32 AM »
@ Fals - Where do you add that ? What file ? Thanks !
index.template.php - you can place it after:
hs.graphicsDir = "', $settings['default_theme_url'], '/highslide/";

Cheers

But i was unable to get it to be transparrent.. the background just goes completly black.. or whatever color i set it to use as background.. it might be because i have other flash objects on my site !

Offline fals

  • Jr. Member
  • **
  • Posts: 287
  • Gender: Male
  • bouncing through codes...
    • Large Scale Forum Denmark
Re: Highslide Image Viewer
« Reply #56 on: October 12, 2008, 11:00:29 AM »
Cheers

But i was unable to get it to be transparrent.. the background just goes completly black.. or whatever color i set it to use as background.. it might be because i have other flash objects on my site !

Do you have:
Code: [Select]

.highslide-dimming {
 position: absolute;
 background: black;
}
in your highslide.css ?
500fan.dk - SMF 2.0 ~ custom theme
ls-forum.dk - SMF 2.0.2 ~ custom theme and custom iPhone theme

Offline Tanks

  • Full Member
  • ***
  • Posts: 583
  • Gender: Male
  • Danish Dude
Re: Highslide Image Viewer
« Reply #57 on: October 12, 2008, 11:05:33 AM »
Yeah i do - also i try changing that to white but that just made the background white.. no transparency or fading effect at all..

but like i said, it might be because i have a flash in my signature.. (http://sproutbuilder.com/) That might interfere with it.. idunno.. thanks anyway.. its no big deal to have it or not ;)

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #58 on: October 12, 2008, 01:52:09 PM »
Quote
Notice:  Undefined index:  subject in /home/XXXXXX/public_html/forum/Sources/Subs.php on line 2485
Unfortunately I have this problem, and it's displayed on my home (Joomla+smf Orstio's bridge).
Let me know, please, how to fix it. It's a great mod.

At the line 2485:
Code: [Select]
$message = str_replace($b[0], $b[5], $message) . '<div class="highslide-heading">' . $context['subject'] . '</div>';
Because with bridge it shows images outside a forum topics. There's no $context['subject'] in this case. I will fix it.

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #59 on: October 12, 2008, 01:58:24 PM »
I still don't know how to use this? Is there a BBC code that I don't know like "[hsiv]"?? Or I just have to use regular old "[ img][ /img]"??
I feeling so stupid!!! Please help!!

Quote
Quote
Does it work only with images posted as attachments?
with attachments,
with
Code: [Select]
[url=http://.../big_image.jpg][img]http://small_image.jpg[/img][/url]
and with thumbnails from iPicture.ru, Imageshack.us and Photobucket.com (thanks to  karlbenson for code).