Advertisement:

Author Topic: Highslide Image Viewer  (Read 272011 times)

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #100 on: October 17, 2008, 04:55:16 AM »
I have tried installing this mod several times and still get the same error message.  Could someone please give me some sort of idea where I may have gone wrong.

First I am using the Theme “Helios_Multi”, so I manually edited the files using Highslide Image Viewer – Installation Instructions for 1.1.6

./Sources/Subs.php
./Themes/Helios_Multi/index.template.php
./Themes/Helios_Multi/Display.template.php


I then moved the included directory "Highslide" to "./Themes/Helios_Multi".

After editing the files as soon as I click on anything in the SMF Forum, I get the following error message.

Parse error: parse error in /home/tlcc/public/htdocs/forum/Sources/Subs.php on line 3576

Fatal error: Call to undefined function: writelog() in /home/tlcc/public/htdocs/forum/index.php on line 171


Any help you could give would be most appreciated, I really would like to use this mod  :D
Attach your changed Subs.php. 

Offline jmil

  • Jr. Member
  • **
  • Posts: 252
  • Gender: Male
  • The Chief
    • Mid-Atlantic X Riders
Re: Highslide Image Viewer
« Reply #101 on: October 17, 2008, 08:54:46 AM »
YEA - It WORKS!!!! Thanks Digger - Now the Dumb Question - Can this be modified to work with the SMF Gallery??

You can modify SMF Gallery to work with Highslide mod. (Tested with SMF Gallery 1.9.3)

in Gallery.template.php
find four places looks like this code (there may be some differences like alt='')
Code: [Select]
echo '<td align="center"><a href="' . $scripturl . '?action=gallery;sa=view;id=' . $row['ID_PICTURE'] . '">
<img ' . ($GD_Installed == true ?  'src="' . $modSettings['gallery_url'] . $row['thumbfilename'] . '" ' : 'src="' . $modSettings['gallery_url'] . $row['filename'] . '" height="78" width="120" ')  . ' border="0" alt="" /></a><br />';
and replace with
Code: [Select]
echo '<td align="center"><a href="' . $modSettings['gallery_url'] . $row['filename'] . '" class="highslide" rel="highslide">
<img ' . ($GD_Installed == true ?  'src="' . $modSettings['gallery_url'] . $row['thumbfilename'] . '" ' : 'src="' . $modSettings['gallery_url'] . $row['filename'] . '" height="78" width="120" ')  . ' border="0" alt="' .  '<a href=\'' . $scripturl . '?action=gallery;sa=view;id=' . $row['ID_PICTURE'] . '\'>[Detail]</a>' . '" /></a><br />';
echo '<div class="highslide-heading">' , @$context['gallery_cat_name'] , '</div>';

Demo here http://simple-machines.ru/index.php?action=gallery;cat=1

Works Absolutly Perfectly - I only found 3 (Not 4) similar pieces of code so I only changed those 3.
This is a very cool Mod especially for the Gallery!!! My members have multiple categories with 50+ pictures each and they LOVE this mod!

Nice Job DIgger! You got talent!

Offline ssabo

  • Newbie
  • *
  • Posts: 7
Re: Highslide Image Viewer
« Reply #102 on: October 17, 2008, 09:35:42 AM »
I have tried installing this mod several times and still get the same error message.  Could someone please give me some sort of idea where I may have gone wrong.

First I am using the Theme “Helios_Multi”, so I manually edited the files using Highslide Image Viewer – Installation Instructions for 1.1.6

./Sources/Subs.php
./Themes/Helios_Multi/index.template.php
./Themes/Helios_Multi/Display.template.php


I then moved the included directory "Highslide" to "./Themes/Helios_Multi".

After editing the files as soon as I click on anything in the SMF Forum, I get the following error message.

Parse error: parse error in /home/tlcc/public/htdocs/forum/Sources/Subs.php on line 3576

Fatal error: Call to undefined function: writelog() in /home/tlcc/public/htdocs/forum/index.php on line 171


Any help you could give would be most appreciated, I really would like to use this mod  :D
Attach your changed Subs.php.

Here is my Sub.php attached.....thanks for your help.

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #103 on: October 17, 2008, 05:55:06 PM »
I have tried installing this mod several times and still get the same error message.  Could someone please give me some sort of idea where I may have gone wrong.

First I am using the Theme “Helios_Multi”, so I manually edited the files using Highslide Image Viewer – Installation Instructions for 1.1.6

./Sources/Subs.php
./Themes/Helios_Multi/index.template.php
./Themes/Helios_Multi/Display.template.php


I then moved the included directory "Highslide" to "./Themes/Helios_Multi".

After editing the files as soon as I click on anything in the SMF Forum, I get the following error message.

Parse error: parse error in /home/tlcc/public/htdocs/forum/Sources/Subs.php on line 3576

Fatal error: Call to undefined function: writelog() in /home/tlcc/public/htdocs/forum/index.php on line 171


Any help you could give would be most appreciated, I really would like to use this mod  :D
Attach your changed Subs.php.

Here is my Subs.php attached.....thanks for your help.
Looks strange.

You don't need manual modify Subs.php. Remove your changes.
Just install mod and edit index.template.php and
Display.template.php in your custom theme directory.

Offline Final60

  • Semi-Newbie
  • *
  • Posts: 74
Re: Highslide Image Viewer
« Reply #104 on: October 17, 2008, 08:00:39 PM »
Works a treat on my custom theme, many thanks.

Offline ssabo

  • Newbie
  • *
  • Posts: 7
Re: Highslide Image Viewer
« Reply #105 on: October 17, 2008, 09:49:14 PM »
I have tried installing this mod several times and still get the same error message.  Could someone please give me some sort of idea where I may have gone wrong.

First I am using the Theme “Helios_Multi”, so I manually edited the files using Highslide Image Viewer – Installation Instructions for 1.1.6

./Sources/Subs.php
./Themes/Helios_Multi/index.template.php
./Themes/Helios_Multi/Display.template.php


I then moved the included directory "Highslide" to "./Themes/Helios_Multi".

After editing the files as soon as I click on anything in the SMF Forum, I get the following error message.

Parse error: parse error in /home/tlcc/public/htdocs/forum/Sources/Subs.php on line 3576

Fatal error: Call to undefined function: writelog() in /home/tlcc/public/htdocs/forum/index.php on line 171


Any help you could give would be most appreciated, I really would like to use this mod  :D
Attach your changed Subs.php.

Here is my Subs.php attached.....thanks for your help.
Looks strange.

You don't need manual modify Subs.php. Remove your changes.
Just install mod and edit index.template.php and
Display.template.php in your custom theme directory.

Well digger I appreciate the effort, but still no go  :'(

I left the Sub.php as it was originally; edited both the "index.template.php" and "Didplay.template.php" in my custom theme directory.

I changed the attachments in the admin so it places attached pics as a thumbnail under the posts.  But when I test place a pic in a post and then click on it, it just opens up as it's original size in another browser window???

I had been running a IPB for 8 years and when I say I never had problems, it is not an exaggeration. I have manually edited hundreds of files; always do my backups, never had any problems.  But for some reason I really am having fits with SMF  :(

Oh, and I also tried the "package installer" it then said "Highslider" was successfully installed.  Went to the forum and tried clicking on a thumbnail.....nothing, just went to a new browser window to show the larger pic.

Any other thoughts on what to try?

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #106 on: October 18, 2008, 07:58:26 AM »
Any other thoughts on what to try?

Can I see our forum ?

Offline AlenNS

  • Full Member
  • ***
  • Posts: 617
  • Gender: Male
    • Baklja forum - Vaš forum
Re: Highslide Image Viewer
« Reply #107 on: October 18, 2008, 08:22:15 AM »
Is it possible to add some watermark to this mod?

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #108 on: October 18, 2008, 08:50:36 AM »
Is it possible to add some watermark to this mod?

You can add text link on images.

In index.template.php find

hs.creditsText = "";
hs.creditsHref = "";
hs.creditsTitle = "";

and insert your text, url and title

Offline AlenNS

  • Full Member
  • ***
  • Posts: 617
  • Gender: Male
    • Baklja forum - Vaš forum
Re: Highslide Image Viewer
« Reply #109 on: October 18, 2008, 09:06:29 AM »
Yes, but it only write link on the picture, but I would like to write link of my forum on the picture and when it's downloaded to stay there.

With this method it doesn's write link on the picture.

Offline ssabo

  • Newbie
  • *
  • Posts: 7
Re: Highslide Image Viewer
« Reply #110 on: October 18, 2008, 10:44:38 AM »
Any other thoughts on what to try?

Can I see our forum ?

I will PM you your log-in & password.

Offline locau

  • Semi-Newbie
  • *
  • Posts: 40
Re: Highslide Image Viewer
« Reply #111 on: October 18, 2008, 11:13:32 AM »
maybe

Code: [Select]
hs.dimmingOpacity = 0.75;

should actually be

Code: [Select]
hs.dimmingOpacity = "0.75";


Just a thought :) don't know if im right ! - but now it is working on my forum after i made that change ;)

I did try that but still no luck.

I wonder, it is possible to place an watermark using highslide ? (Either for attachments or linked images)

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #112 on: October 18, 2008, 02:24:14 PM »
Yes, but it only write link on the picture, but I would like to write link of my forum on the picture and when it's downloaded to stay there.

With this method it doesn's write link on the picture.

I have another my mod specially for Watermark.
It's still beta version and not published yet.
Demo here http://simple-machines.ru/index.php?topic=3

Offline locau

  • Semi-Newbie
  • *
  • Posts: 40
Re: Highslide Image Viewer
« Reply #113 on: October 20, 2008, 02:46:20 PM »
Yes, but it only write link on the picture, but I would like to write link of my forum on the picture and when it's downloaded to stay there.

With this method it doesn's write link on the picture.

I have another my mod specially for Watermark.
It's still beta version and not published yet.
Demo here http://simple-machines.ru/index.php?topic=3

i've registered on .ru forum but i never get the confirmation email for my account in order to acess the topic.

Offline zrotzel

  • Semi-Newbie
  • *
  • Posts: 26
Re: Highslide Image Viewer
« Reply #114 on: October 21, 2008, 04:02:54 PM »
Hello.  I just installed this mod, and did all the manual configs needed.  Is this mod supposed to auto re size images?  If so, it is not. 

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #115 on: October 21, 2008, 06:21:08 PM »
Hello.  I just installed this mod, and did all the manual configs needed.  Is this mod supposed to auto re size images?  If so, it is not.

* Autoresize full-size image for browser window

Offline zrotzel

  • Semi-Newbie
  • *
  • Posts: 26
Re: Highslide Image Viewer
« Reply #116 on: October 21, 2008, 08:47:37 PM »
Turns out it is working.  Is there a way to remove the the image link on the bottom of the picture?  I am using RC7.

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #117 on: October 21, 2008, 09:05:59 PM »
Is there a way to remove the the image link on the bottom of the picture?  I am using RC7.
remove from Subs.php
Code: [Select]
$b[5] = str_replace('alt=""', 'alt="' . $b[2] . '"', $b[5]); // Add filename to caption

Offline zrotzel

  • Semi-Newbie
  • *
  • Posts: 26
Re: Highslide Image Viewer
« Reply #118 on: October 22, 2008, 06:30:23 AM »
Its working great!!  Thanks for your help and quick responses!!

Offline Ratz

  • Newbie
  • *
  • Posts: 3
Re: Highslide Image Viewer
« Reply #119 on: October 22, 2008, 06:34:58 PM »
Hi digger,

Is it possible to make Highslide Viewer work along with another mod called "Attachment Layout 1.3"?

Both mods change some of the same strings of code in Display.template.php so when one is installed the other can't be. Well, at least, not using the package installer. I'm hoping there might be a way to do it manually but I haven't been lucky enough to trip on that yet.

Thanks for any help or suggestions.
Ratz