Advertisement:

Author Topic: Highslide Image Viewer  (Read 272118 times)

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #140 on: November 15, 2008, 07:24:26 AM »
SMF Media Gallerys Highslide only works inside the gallery itself :(

Please post requests in Media Gallery support thread
http://www.simplemachines.org/community/index.php?topic=260821.0

Offline Neons

  • Semi-Newbie
  • *
  • Posts: 42
Re: Highslide Image Viewer
« Reply #141 on: November 15, 2008, 08:44:14 AM »
Uhh, isn't this an issue with this mod, not SMG?

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #142 on: November 15, 2008, 09:19:25 AM »
Uhh, isn't this an issue with this mod, not SMG?
My mod don't have any issues with SMG.
SMG already have original highslide script included. If you want any additional possibilities with it, please contact author of SMG.

Offline ziddy123

  • Semi-Newbie
  • *
  • Posts: 14
Re: Highslide Image Viewer
« Reply #143 on: November 16, 2008, 02:46:43 PM »
Uhh, isn't this an issue with this mod, not SMG?
My mod don't have any issues with SMG.
SMG already have original highslide script included. If you want any additional possibilities with it, please contact author of SMG.

What Neon means is that their highslide only works within SMG.

Once you post a BBC Code image from SMG, where your Highslide Mod should work, on the forums or tinyportal, it doesn't.  So it would seem it would be a collaborative work between HighSlide and SMG project. 

I already posted how SMG retrieves the image files to be posted on forums previously.

Offline Neons

  • Semi-Newbie
  • *
  • Posts: 42
Re: Highslide Image Viewer
« Reply #144 on: November 16, 2008, 02:55:12 PM »
Uhh, isn't this an issue with this mod, not SMG?
My mod don't have any issues with SMG.
SMG already have original highslide script included. If you want any additional possibilities with it, please contact author of SMG.

What Neon means is that their highslide only works within SMG.

Once you post a BBC Code image from SMG, where your Highslide Mod should work, on the forums or tinyportal, it doesn't.  So it would seem it would be a collaborative work between HighSlide and SMG project. 

I already posted how SMG retrieves the image files to be posted on forums previously.
Exactly.

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #145 on: November 16, 2008, 03:41:40 PM »
Uhh, isn't this an issue with this mod, not SMG?
My mod don't have any issues with SMG.
SMG already have original highslide script included. If you want any additional possibilities with it, please contact author of SMG.

What Neon means is that their highslide only works within SMG.

Once you post a BBC Code image from SMG, where your Highslide Mod should work, on the forums or tinyportal, it doesn't.  So it would seem it would be a collaborative work between HighSlide and SMG project. 

I already posted how SMG retrieves the image files to be posted on forums previously.
Ok. I understand.
You want highslide mod detect img links from SMG.

Offline Neons

  • Semi-Newbie
  • *
  • Posts: 42
Re: Highslide Image Viewer
« Reply #146 on: November 17, 2008, 06:34:32 PM »
Uhh, isn't this an issue with this mod, not SMG?
My mod don't have any issues with SMG.
SMG already have original highslide script included. If you want any additional possibilities with it, please contact author of SMG.

What Neon means is that their highslide only works within SMG.

Once you post a BBC Code image from SMG, where your Highslide Mod should work, on the forums or tinyportal, it doesn't.  So it would seem it would be a collaborative work between HighSlide and SMG project. 

I already posted how SMG retrieves the image files to be posted on forums previously.
Ok. I understand.
You want highslide mod detect img links from SMG.
Correct. It would be really great if you could pull that off :D

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #147 on: November 17, 2008, 11:40:40 PM »
Test version with SMG support atached.

Works with BBC like
Code: [Select]
[img]http://smf-media.com/community/MGalleryItem.php?id=167;preview[/img]and
Code: [Select]
[img]http://smf-media.com/community/MGalleryItem.php?id=167;thumb[/img]
« Last Edit: August 19, 2009, 10:37:48 PM by digger »

Offline Neons

  • Semi-Newbie
  • *
  • Posts: 42
Re: Highslide Image Viewer
« Reply #148 on: November 18, 2008, 10:39:33 AM »
Test version with SMG support atached.

Works with BBC like
Code: [Select]
[img]http://smf-media.com/community/MGalleryItem.php?id=167;preview[/img]and
Code: [Select]
[img]http://smf-media.com/community/MGalleryItem.php?id=167;thumb[/img]
Works great, thank you so much! <3

Offline kyle007

  • Semi-Newbie
  • *
  • Posts: 69
  • Gender: Male
Re: Highslide Image Viewer
« Reply #149 on: November 18, 2008, 11:06:43 AM »
digger, script works like a charm, but there is a  little but really annoying bug...

Flash banners in my site block the HighSlide viewer...

You can see it here, just drag an opened image to a flash banner at the top side...

http://forum.hardwarena.com/index.php?topic=9179.0

Viewer must always at top but it isn't...

I wish you could fix this... Thanks again for this nice mod.... ;)

Offline Neons

  • Semi-Newbie
  • *
  • Posts: 42
Re: Highslide Image Viewer
« Reply #150 on: November 18, 2008, 11:33:18 AM »
digger, script works like a charm, but there is a  little but really annoying bug...

Flash banners in my site block the HighSlide viewer...

You can see it here, just drag an opened image to a flash banner at the top side...

http://forum.hardwarena.com/index.php?topic=9179.0

Viewer must always at top but it isn't...

I wish you could fix this... Thanks again for this nice mod.... ;)
Hmm.. I had a smiliar problem, not with this mod though. Try changing the z-index of either the flash banners or Highslide, perhaps removing (one of) them.

Offline kyle007

  • Semi-Newbie
  • *
  • Posts: 69
  • Gender: Male
Re: Highslide Image Viewer
« Reply #151 on: November 18, 2008, 12:35:07 PM »
Edit : I solved it,yuppi  :D

I used <param name="wmode" value="transparent"> for flash banners... Now it's exactly what i've dreamed...  8)

* BTW, i don't want my imageshack images to be opened with Highslide viewer, any chance to deactivate Highslide on ImageShack photos ?... or saying in another way, i want the script to be activated with attachments only
« Last Edit: November 19, 2008, 08:13:15 AM by kyle007 »

Offline Dazed

  • Semi-Newbie
  • *
  • Posts: 41
Re: Highslide Image Viewer
« Reply #152 on: November 19, 2008, 09:39:03 PM »
Not sure if this will help another... First an excellent Mod. Second I am using SMF 1.1.7, SMF Gallery Lite, and TP 9.8.3, and RC9 of this Mod.

I could make the Mod work fine in the default theme but could not get it to work in the beginning on a custom theme.

Essentially, 2 edits needed to be made and in the parsing tool here on SMF the edits were correct but only stated that it was the default theme. I used that knowledge to expand and make this Mod work for my application.

For Index.Template.php
Find
Code: [Select]
// If RSS feeds are enabled, advertise the presence of one.Before Add
Code: [Select]
// * Highslide mod
echo '<script language="JavaScript" type="text/javascript" src="', $settings['default_theme_url'], '/Highslide/highslide.js"></script>
<script language="JavaScript" type="text/javascript" src="', $settings['default_theme_url'], '/Highslide/highslide.', $context['user']['language'], '.js"></script>
<link rel="stylesheet" type="text/css" href="', $settings['default_theme_url'], '/Highslide/highslide.css" media="screen" />
<script type="text/javascript">
    hs.graphicsDir = "', $settings['default_theme_url'], '/Highslide/";
    hs.outlineType = "rounded-white";
    hs.captionEval = "this.thumb.alt";
    hs.transitions = ["expand", "crossfade"];
    hs.align = "center";
    hs.creditsText = "";
    hs.creditsHref = "";
    hs.creditsTitle = "";
    if (hs.addSlideshow) hs.addSlideshow({
        interval: 5000,
        repeat: false,
        useControls: true,
fixedControls: false,
        overlayOptions: {
        opacity: 1,
        position: "top right",
        hideOnMouseOut: false
}
    });
  </script>';
// Highslide mod *

In Display.template.php
Find
Code: [Select]
<a href="', $attachment['href'], ';image" id="link_', $attachment['id'], '" onclick="', $attachment['thumbnail']['javascript'], '"><img src="', $attachment['thumbnail']['href'], '" alt="" id="thumb_', $attachment['id'], '" border="0" /></a><br />';

Replace with:
Code: [Select]
<a href="', $attachment['href'], ';image" id="link_', $attachment['id'], '" class="highslide" rel="highslide"><img src="', $attachment['thumbnail']['href'], '" alt="' , $attachment['name'] , '" id="thumb_', $attachment['id'], '" border="0" /></a><br /><div class="highslide-heading">' , $message['subject'] , '</div>';

I hope this is considered useful and if possible critique my first "tech response" here for quality and substance. As a Charter member I want to get more involved in this type of thing and I know that I have far to go. Thread hijack over.... ;)


Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #153 on: November 19, 2008, 10:33:35 PM »
Edit : I solved it,yuppi  :D

I used <param name="wmode" value="transparent"> for flash banners... Now it's exactly what i've dreamed...  8)

* BTW, i don't want my imageshack images to be opened with Highslide viewer, any chance to deactivate Highslide on ImageShack photos ?... or saying in another way, i want the script to be activated with attachments only
Deactivate for ImageShack only?
Or for all linked images?

http://www.simplemachines.org/community/index.php?topic=266750.msg1750962#msg1750962

Offline kyle007

  • Semi-Newbie
  • *
  • Posts: 69
  • Gender: Male
Re: Highslide Image Viewer
« Reply #154 on: November 20, 2008, 04:52:58 AM »
@digger, first i want it for only ImageShack  then i change my decision :) Thanks ;)

Offline pecado

  • Newbie
  • *
  • Posts: 5
Re: Highslide Image Viewer
« Reply #155 on: November 23, 2008, 08:02:52 AM »
here you are additional code for subs.php to work with fotosik.pl, one of popular polish image hosters

Code: [Select]
|| (strpos($c, 'fotosik') !== false && preg_match('~(.*?)\.(?:m\.|)(png|gif|jp(e)?g|bmp)$~is'.($context['utf8'] ? 'u' : ''), $b[4]))
Code: [Select]
elseif(strpos($c, 'fotosik') !== false)
{
// Fix iPicture thumbnails
if(preg_match('~(.*?)\.(?:m\.|)(png|gif|jp(e)?g|bmp)$~is'.($context['utf8'] ? 'u' : ''), $b[4], $out))
{
$out = (substr($out[1], -1, 1)=='m'?substr($out[1], 0, strlen($out[1])-1):$out[1]).'.'.$out[2];
$d = $b[1];
$b[1] = str_replace($b[2], $out, $b[1]);
$b[2] = $out;
$b[5] = str_replace($d, $b[1], $b[5]);
unset($c, $d, $out);
}
}

works fine for me ;)
hxxp:www.knives.pl/forum/index.php/topic,61312.msg412323.html#msg412323 [nonactive]

Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #156 on: November 23, 2008, 08:58:06 AM »
here you are additional code for subs.php to work with fotosik.pl, one of popular polish image hosters

Thanks for contribution. I will add your code in a next version.

Can you attach your polish lang file for highslide?

Offline Dazed

  • Semi-Newbie
  • *
  • Posts: 41
Re: Highslide Image Viewer
« Reply #157 on: November 23, 2008, 06:03:15 PM »
Found a new issue today. Members tried to search and received this error....

Code: [Select]
[Sun Nov 23 16:37:11 2008] [error] [client 67.xxx.xxx.xx] File does not exist: /home/xxxxxxxxxx/public_html/Themes/default/Highslide/highslide.english.js, referer: http://www.xxxxxxxxxxxxxx.xxx/index.php?www
I placed the "x" in place of private info but you get the idea.

It throws a 404 error. It works fine except for when using search. And, I don't find and English.js file even going back a few versions... Ideas?

My earlier post shows the versions I am using.


Offline digger

  • Sr. Member
  • ****
  • Posts: 787
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Highslide Image Viewer
« Reply #158 on: November 23, 2008, 09:36:18 PM »
Found a new issue today. Members tried to search and received this error....

Code: [Select]
[Sun Nov 23 16:37:11 2008] [error] [client 67.xxx.xxx.xx] File does not exist: /home/xxxxxxxxxx/public_html/Themes/default/Highslide/highslide.english.js, referer: http://www.xxxxxxxxxxxxxx.xxx/index.php?www
I placed the "x" in place of private info but you get the idea.

It throws a 404 error. It works fine except for when using search. And, I don't find and English.js file even going back a few versions... Ideas?

My earlier post shows the versions I am using.

Take English.js from this post http://www.simplemachines.org/community/index.php?topic=266750.msg1744643#msg1744643

Offline Dazed

  • Semi-Newbie
  • *
  • Posts: 41
Re: Highslide Image Viewer
« Reply #159 on: November 23, 2008, 10:00:23 PM »
Works for some searches. Many do not. Goes to that error.