Advertisement:

Author Topic: Calendar Settings Parse Error (Solved)  (Read 1762 times)

Offline Garry1953

  • Jr. Member
  • **
  • Posts: 118
    • Artists Online Australia Art Forum
Calendar Settings Parse Error (Solved)
« on: October 13, 2008, 11:49:14 PM »
When Accessing: Admin/Calendar/Calendar Settings      
I Get the below error.

Parse error: syntax error, unexpected ',' in /home/My Site in Here/public_html/art-forum/Sources/ManagePermissions.php on line 2189

I upgraded from v1.16 to v2,0 beta 4.

Mods Installed:
1.     Bookmarks     2.2 
2.    Highslide Image Viewer    1.0 RC8
3.    Recent Topics On Board Index    1.01
4.    English British Spelling Of Centre & Colour BBCode
5.    Message index like vbulletin    0.1
6.    Enhance Recent Post    1.0
7.    SMF Media Gallery    1.0.2
8.    New Style Message Icon    1.0
9.    Member Notepad    1.0
10.    Google Member Map    1.0 beta 3
11.    More Spiders    1.2
12.    Stars And Badges    2.1
13.    DeInCreasePostBox    1.4
14.    Color And BgColor BBCode Bar    3.3.1
15.    AvatarOnBoard    2.1    [ Uninstall ]
16.    Auto Embed Video/Audio Clips    4.0.2
17.    TopicStarter Mod    1.1
18.    Affiliates    1.1
19.    Admin Notepad    1.0
20.    Sort Packages by Name    1.0

No Errors showing in System Log Files.

Thanks
Garry
« Last Edit: October 14, 2008, 01:16:15 AM by Garry1953 »

Offline aldo

  • Sophist Member
  • *****
  • Posts: 1,356
  • Gender: Male
Re: Calendar Settings Parse Error
« Reply #1 on: October 14, 2008, 12:15:49 AM »
Did you get this error like right after a modification was installed?

Offline Garry1953

  • Jr. Member
  • **
  • Posts: 118
    • Artists Online Australia Art Forum
Re: Calendar Settings Parse Error
« Reply #2 on: October 14, 2008, 12:23:17 AM »
I upgraded Last Saturday and checked today to see what was hidden under the v2 hood, and found this error.
But no Log Errors.

P.S. I also over-wrote the ManagePermissions.php with a new one incase the upgrade failed.
 
Aldo
I will set up a test forum and check out the mods.


Offline aldo

  • Sophist Member
  • *****
  • Posts: 1,356
  • Gender: Male
Re: Calendar Settings Parse Error
« Reply #3 on: October 14, 2008, 12:40:48 AM »
Did you have those modifications installed on your 1.1.6 forum when you upgraded to SMF 2.0?

Offline Garry1953

  • Jr. Member
  • **
  • Posts: 118
    • Artists Online Australia Art Forum
Re: Calendar Settings Parse Error
« Reply #4 on: October 14, 2008, 01:15:37 AM »
I Found the Culprit.

Its the Bookmark 2.2 mod that caused the problem.

Uninstalling it brings back the Calendar.
I'll let the mod developer know.

Aldo thanks for giving me a hint where to look.

P.S. I tested this on a clean install of SMF v2.0 beta 4 with no other mods installed.
« Last Edit: October 14, 2008, 01:27:09 AM by Garry1953 »