Advertisement:

Author Topic: Subs.php  (Read 1429 times)

Offline red oak

  • Newbie
  • *
  • Posts: 8
Subs.php
« on: October 13, 2008, 11:09:41 AM »
I upgraded Forum to SMF 2.0 Beta 4 from  SMF 2.0 Beta 3.

It was my understanding that menu items are set up in subs.php in a default theme to be used in all themes.

I set up a new menu item with sub-buttons & it works very well in Bloc's Amber theme (for SMF 2.0 Beta 4), however it does NOT work in any other theme like classic, default... Obviously something else should be changed to accommodate the sub-buttons... Please point me in the right direction....

Thank you

PS. I just realized that this might be in the wrong area, as this is not an upgrade issue, but I'm not able to move it.... sorry about that...
« Last Edit: October 13, 2008, 11:21:43 AM by red oak »

Offline Nathaniel

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,117
  • Gender: Male
    • Verbtest.com
Re: Subs.php
« Reply #1 on: October 14, 2008, 05:42:44 AM »
Moved to "SMF 2.x Support".

There is a tip/trick for adding a dropdown menu/subbuttons to the default theme for SMF 2 Beta, you should be able to apply it to your other main themes as well, with a few edits. I suspect that bloc's theme already has a dropdown menu or something similar inbuilt, the default themes do not have this feature by default.

Here is the tip/trick:
http://www.simplemachines.org/community/index.php?topic=253756.msg1736964#msg1736964
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.