Advertisement:

Author Topic: Daily Digest Emails  (Read 5090 times)

Offline ranttrmike

  • Semi-Newbie
  • *
  • Posts: 20
Daily Digest Emails
« on: October 14, 2008, 07:32:55 AM »
I have the daily digest option set in beta 2.0 4, and it runs daily in the schedule.

It always takes zero seconds, and nobody ever get's any emails.

Any thoughts?

Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: Daily Digest Emails
« Reply #1 on: October 14, 2008, 02:34:42 PM »
I may not be correct on this but I believe mail may only be set when:

"For topics and boards I've requested notification on, notify me" is set to Daily in Profile > Notifications
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline ranttrmike

  • Semi-Newbie
  • *
  • Posts: 20
Re: Daily Digest Emails
« Reply #2 on: October 14, 2008, 02:49:52 PM »
You are correct, and I have done this.

I have also tried hitting "notify" in the postings.  While invidivual notifications of replies are sent, there are no "daily digests" sent.

Thanks anway!

Offline ranttrmike

  • Semi-Newbie
  • *
  • Posts: 20
Re: Daily Digest Emails
« Reply #3 on: October 15, 2008, 10:21:17 AM »
Can anyone help?

I have tested that I can send newletters via email, so I know that it is working.

I just receive no other emails.


Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: Daily Digest Emails
« Reply #4 on: October 15, 2008, 04:05:15 PM »
So you don't receive any other e-mails (not just digests)? Do notifications get sent if they're set to immediately and not daily.
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline ranttrmike

  • Semi-Newbie
  • *
  • Posts: 20
Re: Daily Digest Emails
« Reply #5 on: October 15, 2008, 05:43:34 PM »
After testing, No I do not.  Although I have verified again that the email information is correct, and I can receive emails via the "Newsletter" option using those settings.

Yes, I have turned on the daily and weekly email routine in the schedule, it does run, and I have run it manually many times.

Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: Daily Digest Emails
« Reply #6 on: October 15, 2008, 05:46:33 PM »
Are the new posts / topics still unread at the time when the mail should send?
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline ranttrmike

  • Semi-Newbie
  • *
  • Posts: 20
Re: Daily Digest Emails
« Reply #7 on: October 15, 2008, 05:48:26 PM »
Yes, they are still unread.  I have just tried subscribing to full board notifications to see if this works also, and posted a test message with another username.  I have not received the notification there either.

Offline ranttrmike

  • Semi-Newbie
  • *
  • Posts: 20
Re: Daily Digest Emails
« Reply #8 on: October 15, 2008, 07:00:01 PM »
Problem solved, kinda...

The issue went away when I turned off the Enable Mail Queue option.

So now the problem is solved, but there is an issue with Enable Mail Queue that someone needs to look into.

Offline H

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,662
  • Gender: Male
Re: Daily Digest Emails
« Reply #9 on: October 16, 2008, 03:23:33 PM »
Did you try changing these values to something above zero (you shouldn't need to but I wonder if that is the cause of the bug)?
Anything mail related in the error log? (Admin area > Error log)

Maximum emails to send per minute
Maximum amount of emails to send per page load
-H
Former Support Team Lead
                              I recommend:
Namecheap (domains)
Fastmail (e-mail)
Linode (VPS)
                             

Offline ranttrmike

  • Semi-Newbie
  • *
  • Posts: 20
Re: Daily Digest Emails
« Reply #10 on: October 16, 2008, 07:34:35 PM »
No, I haven't played further, I just turned it off.

The forum doesn't send that many emails, so I am not concerned about queueing.