[TUTORIAL] Como acrescentar botões ao menu[SMF 1.1.X]

Started by Costa, October 18, 2008, 01:39:21 PM

Previous topic - Next topic

Costa

Se for Admin basta usar o if ($context['allow_admin'])
Hugo Costa
Todas as MP's a pedir ajuda são sujeitas a radioactividade, microondas, queimadas e atiradas borda fora.

"At least someone appreciates the fact that I am doing and not thinking..."
"Laziness is counter-revolutionary."

FragaCampos

Para o admin é fácil :)
Eu gostava era de saber como colocar o botão visível apenas para um grupo criado por mim, tipo um botão que fosse visível apenas para os "Local Moderator" do SMF (e para os admins, claro).

FragaCampos


0v3r

Boa Noite a todos, estou com dificuldade em inserir uns botões num fórum, já usei o código que disponibilizam no inicio deste tópico mas não consegui, fica um botão completamente diferente e no sitio oposto. Tentei copiar o código dos botões que já existem mas não consigo mudar o nome do botão, sei que é alterando o numero da variável $text, mas não sei quais são os números para o forum, mod Treasury e para ligações externas...

Alguém me pode ajudar? Estou a usar a versão 1.1.10 com este theme .

E este é o codigo de um botao ja existente :

/ Show the [help] button.
   echo   '<li><a href="', $scripturl, '?action=help">' , $txt[119] , '</a></li>';


Muito Obrigado

0v3r

Bem já consegui, foi bastante simples foi alterar  o código para isto


   echo   '<li><a href="http://forum.xxx.com.pt/index.php/topic,4.0.html">Regras</a></li>';

Muito obrigado na mesma ;-)


paulo074

Boas  amigos bem  o  que  me  traz  aqui  e  o  seguinte  o código que  o  amigo costa indica  Para abrir em uma nova aba

Gostaria  de  saber se  da  para  abrir em  uma  janela sim  mas  com  as  dimensões que  eu pretender .

Dês  de  já  obrigado pela ajuda

Cumps.Paulo

Fumetsu

Desculpe-me costa mas não acho essas linhas em parte alguma nem no index.template do 1.1.11 e nem do 2.0 rc3 o que será que aconteceu ?

forumbikspc

Boas,

Tentei acrescentar um botão destes a redireccionar para um outro site mas não consigo pois não fica em botão e apenas fica o titulo do botão (neste caso Google).
Se me pudessem ajudar. O meu index.template.php está assim:

// Show the start of the tab section.
echo '
<ul>';

// Show the [home] button.
echo '<li><a href="', $scripturl, '">' , $txt[103] , '</a></li>';

// Show the [help] button.
echo '<li><a href="', $scripturl, '?action=help">' , $txt[119] , '</a></li>';

// How about the [search] button?
if ($context['allow_search'])
echo '<li><a href="', $scripturl, '?action=search">' , $txt[182] , '</a></li>';

// Is the user allowed to administrate at all? ([admin])
if ($context['allow_admin'])
echo '<li><a href="', $scripturl, '?action=admin">' , $txt[2] , '</a></li>';

// Edit Profile... [profile]
if ($context['allow_edit_profile'])
echo '<li><a href="', $scripturl, '?action=profile">' , $txt[79] , '</a></li>';

// Go to PM center... [pm]
if ($context['user']['is_logged'] && $context['allow_pm'])
echo '<li><a href="', $scripturl, '?action=pm">' , $txt['pm_short'] , ' ', $context['user']['unread_messages'] > 0 ? '[<strong>'. $context['user']['unread_messages'] . '</strong>]' : '' , '</a></li>';

// The [calendar]!
if ($context['allow_calendar'])
echo '<li><a href="', $scripturl, '?action=calendar">' , $txt['calendar24'] , '</a></li>';

// the [member] list button
if ($context['allow_memberlist'])
echo '<li><a href="', $scripturl, '?action=mlist">' , $txt[331] , '</a></li>';

// If the user is a guest, show [login] button.
if ($context['user']['is_guest'])
echo '<li><a href="', $scripturl, '?action=login">' , $txt[34] , '</a></li>';

// If the user is a guest, also show [register] button.
if ($context['user']['is_guest'])
echo '<li><a href="', $scripturl, '?action=register">' , $txt[97] , '</a></li>';

// Otherwise, they might want to [logout]...
if ($context['user']['is_logged'])
echo '<li><a href="', $scripturl, '?action=logout;sesc=', $context['session_id'], '">' , $txt[108] , '</a></li>';

echo '
</ul>';


Cumprimentos

Spectrum..!!

@ forumbikspc,

O que quer? Linkar para o Google? Já tentou assim:


   echo   '<li><a href="http://endereço_que_quer.com">Nome</a></li>';

Existem pessoas que deixam de buscar algo que dura a vida toda, para somente conquistar algo que dura alguns momentos...
Ser humilde; não é ser menos que alguém. É saber que não somos mais que ninguém!
SMF 2.0.4 | Meu site -->
Dell Vostro 3560 + AMD Radeon™ HD 7670M 1GB| Windows 8 Pro | Fedora 18 | IE10 | Google Chrome

Não atendo PM para pedidos de suporte/ajuda

forumbikspc

Quero que ao carregar no botão nos redireccione para um link, suponhamos o Google.
Só meto mesmo isso? Não tenho que meter nada antes do género

if ($context['allow_search'])

Cumprimentos,

forumbikspc

Boas de novo,

Spectrum..!!☻, muito obrigado, já ficou a funcionar às mil maravilhas.

Cumprimentos.

Spectrum..!!

Quote from: forumbikspc on January 27, 2011, 03:26:17 PM
Boas de novo,

Spectrum..!!☻, muito obrigado, já ficou a funcionar às mil maravilhas.

Cumprimentos.

Disponha amigo.

Cumps.

Existem pessoas que deixam de buscar algo que dura a vida toda, para somente conquistar algo que dura alguns momentos...
Ser humilde; não é ser menos que alguém. É saber que não somos mais que ninguém!
SMF 2.0.4 | Meu site -->
Dell Vostro 3560 + AMD Radeon™ HD 7670M 1GB| Windows 8 Pro | Fedora 18 | IE10 | Google Chrome

Não atendo PM para pedidos de suporte/ajuda

Thiaaguh

#73
Intão to com um problema minha versão do forum é 2.0 RC5 , e é toralmente diferente, dessa alguem pode me ajuda pls

- - - - - - - - - - - - - - - - - - - - - - - - - -

Duvida agora é como eu mudo os link por exemplo, o Forum ta aqui -> http://gsmgroup.xp3.biz/ [nofollow]
e o Portal aqui ->http://gsmgroup.xp3.biz/index.php?action=portal [nofollow] Queria deixa ao contrario, para quando abri a pagina http://gsmgroup.xp3.biz/ [nofollow] em vez do Forum abrice o Portal tenderão.

Grive_Snake

Boas pessoal, uma questão tive a tentar procurar um dos codigos para meter um botão novo e não encontro de maneira nenhuma, o thema é o Csmanul_20 , http://www.jpr62.com/demos/index.php?theme=57, aquilo pelo que vejo tem 2 Index.template.php..

cumps.


Grive_Snake



Grive_Snake



ab-positivo

Grive_Snake, o que que tem o Index haver com isso? Não lembro dos botões do menu fazerem parte do Index.
Da uma olhadinha no Sources e abre o arquivo subs php, depois procure por: // All the buttons we can possible want and then some, try pulling the final list of buttons from cache first.

Ai você vai encontrar os botões do menu! Caso não seja esse o caso, então eu não sei mais como ajudar =(

Darkness_Black

Quote from: Grive_Snake on February 06, 2012, 07:40:41 AM
Não econtro a resposta ao meu problema :S

Se vc usa o smf 2.0 vai no source/subs.php

Os botoes iniciam no:

$buttons = array(
'home' => array(
'title' => $txt['home'],
'href' => $modSettings['sp_portal_mode'] == 3 && empty($context['disable_sp']) ? $modSettings['sp_standalone_url'] : $scripturl,
'show' => true,
'sub_buttons' => array(
),
'is_last' => $context['right_to_left'],
),


Daí basta inserir depois disso o seu botão como exemplo:


'new button' => array(
'title' =>'Botão',
'href' => http://.....br
'show' => true,
'sub_buttons' => array(
),

Translator - Brazilian

Não respondo MP de ajuda, Poste sua duvida no forum!!! Se alguém te Ajudou Agradeça!!!

Advertisement: