Author Topic: YaBB 2.1 to SMF 1.1.7 problems  (Read 9630 times)

Offline spliffeh

  • Semi-Newbie
  • *
  • Posts: 17
YaBB 2.1 to SMF 1.1.7 problems
« on: November 08, 2008, 08:47:27 PM »
I'm trying to convert from YaBB 2.1 to SMF 1.1.7 using the smf_1-1-7_yabb21_converter I downloaded from this site tonight.

After I run it I can't login with admin, and there are a number of other problems, ie: main forum list seems to load extremely slow (~30 seconds).  Number of posts is very incorrect, etc. It's clear something is wrong with the database.

When I ran the converter I got these two errors:

Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /home/zerg/public_html/smf/convert.php on line 799

Recalculating forum statistics... Unsuccessful!
This query:
ALTER TABLE `zerg_smf1`.smf_topics
Caused the error:

Duplicate entry '0' for key 1

(Misc Notes that may help: I used Cpanel to install to SMF 1.1.6 then upgraded to 1.1.7 without issue. I grabbed the MySQL pw from settings.php or one of those files. I'm trying to do the convert on a "clean install" of SMF. If I create a new user with my admin name it says 'user exists', so it did import the usernames, but something is wrong with PW's. If I register a new user it I get the ~30 sec pause again and then it sends me back to the main forum list and the user has not been created and/or it wont let me log it in. If I try to register the same user again it says "you're not allowed to register multiple accounts at the same time from the same computer", so it is remembering something).

Any help would be greatly appreciated, I want to get off YaBB very badly and SMF looks great.

« Last Edit: November 08, 2008, 11:02:20 PM by spliffeh »


  • Guest
Re: YaBB 2.1 to SMF 1.1.7 problems
« Reply #1 on: November 10, 2008, 01:22:35 AM »

Offline spliffeh

  • Semi-Newbie
  • *
  • Posts: 17
Re: YaBB 2.1 to SMF 1.1.7 problems
« Reply #2 on: November 11, 2008, 02:02:23 PM »

It worked and I'm free of YaBB.... Freeeeedom!!!!!

It did not convert my attachments, and it ignored a few of my user ranks and put most of them to 'full member' - but that's a sacrifice I'm willing to make. Thanks for all the work you guys have done with this.