Advertisement:

Author Topic: Test Site says copyright not there, when it is...  (Read 2929 times)

Offline Burke ♞ Knight

  • SMF Hero
  • ******
  • Posts: 3,534
Test Site says copyright not there, when it is...
« on: December 05, 2008, 05:56:11 PM »
I am working on a test site, in order to re-make another site.
It now says:
Quote
Sorry, the copyright must be in the template.
Please notify this forum's administrator that this site is missing the copyright message for SMF so they can rectify the situation. Display of copyright is a legal requirement. For more information on this please visit the Simple Machines website.
Not sure why this message is appearing? Take a look at some common causes.

However, it is in the template file:

Code: [Select]
// Show the "Powered by" and "Valid" logos, as well as the copyright. Remember, the copyright must be somewhere!
echo '
<div id="footerarea" style="padding-top:0px;" class="headerpadding topmargin clearfix">
                <div>', !empty($settings['custom_copyright']) ? '<span class="smalltext">'. parse_bbc($settings['custom_copyright']). '</span>' : '', '</div>
<ul class="smalltext"><li class="copywrite">', theme_copyright(), '</li>
<li><a id="button_xhtml" href="http://validator.w3.org/check/referer" target="_blank" class="new_win" title="', $txt['valid_html'], '"><span>XHTML</span></a></li>
<li><a id="button_rss" href="', $scripturl , '?type=rss;action=.xml" class="new_win"><span>RSS</span></a></li>
<li class="last"><a id="button_wap2" href="', $scripturl , '?wap2" class="new_win"><span>WAP2</span></a></li>
</ul>';

This happened a few times yesterday, then it cleared up on it's own. Now, just as I'm about to go live with it, replacing the original, it's doing it again.

Any ideas why it would say the copyright is not there, when it clearly is?

Offline Oldiesmann

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,872
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • https://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: Test Site says copyright not there, when it is...
« Reply #1 on: December 05, 2008, 06:06:47 PM »
Try re-uploading Sources/Subs.php and Themes/default/languages/index.english.php
Michael Eshom
Cincy Space - now open!

Offline Burke ♞ Knight

  • SMF Hero
  • ******
  • Posts: 3,534
Re: Test Site says copyright not there, when it is...
« Reply #2 on: December 05, 2008, 06:09:54 PM »
I don't have backups of after mods were done, as the test site has different mods.

However, I think I'll just start from scratch on a new test site. After all, the theme used on the test site is now basically  no good.

I was mainly wondering what could cause it, and I bet it may have been a mod that went in bad.

Offline Oldiesmann

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,872
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • https://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: Test Site says copyright not there, when it is...
« Reply #3 on: December 05, 2008, 06:11:25 PM »
It could be a mod that screwed up a file.
Michael Eshom
Cincy Space - now open!