News:

Join the Facebook Fan Page.

Main Menu

TinyPortal

Started by lurkalot, February 12, 2005, 04:43:00 AM

Previous topic - Next topic

lurkalot

#2260
Quote from: Drakkon on April 15, 2018, 07:01:23 AM
How do I make "Home" link to the front page of my website? Right now "Home" and "Forum" link to the index page of the forum.

Please provide a link, either here or if you prefer by PM.

Edit:  Just noticed you had Simpleportal installed, and had the very same problem with that. https://www.simplemachines.org/community/index.php?topic=559763.0

Drakkon

Thank you for your help. I just reinstalled and got it to work.

lurkalot

The TinyPortal Team is pleased to announce the released of TinyPortal 1.5.0 http://custom.simplemachines.org/mods/index.php?mod=97

Changelog; TP 1.5.0

Drag and Drop added for Images, enabled via a Setting
Float Left and Float Right for images or text to restore functionality lost from old wysiwyg
Fix to show copyright correctly and not rewrite when Simple Machines Simple Machines
TinyPortal © 2005-2018 is put in a post.
Bug fix for posts and articles on front page where variable wasn't cleared before use.
Fix for embedding youtube videos in responsive mode

Apllicmz

Yes Nice Work
thank you



jafonseca

Error installing mod could y help me?

Error en la Base de Datos

Field 'description' doesn't have a default value
Archivo: /home/uhdcl/public_html/Packages/temp/install.php
Línea: 915

Nota: Parece que tu base de datos puede necesitar una actualización. La versión de los archivos de tu foro están en la versión SMF 2.0.15, mientras que tu base de datos está en la versión de SMF 2.0.4. Este error probablemente desaparecerá si ejecutas la última versión de upgrade.php.



SMF 2.0.15 | SMF © 2013, Simple Machines
­

tinoest

What version of php and MySQL?

jafonseca

Quote from: tinoest on May 12, 2018, 05:00:45 PM
What version of php and MySQL?
Server: Localhost via UNIX socket
Server type: MySQL
Server version: 5.7.22-0ubuntu0.16.04.1 - (Ubuntu)
Protocol version: 10
User: root@localhost
Server charset: UTF-8 Unicode (utf8)
Web server
root
Database client version: libmysql - mysqlnd 5.0.12-dev - 20150407 - $Id: b396954eeb2d1d9ed7902b8bae237b287f21ad9e $
PHP extension: mysqliDocumentation curlDocumentation mbstringDocumentation
PHP version: 7.1.9
phpMyAdmin
Version information: 4.6.3 , latest stable version: 4.8.0.1


RUn with ZESLE panel,  have php 5.6 and php 7.1

tinoest

Change line 177 in install.php to

array('name' => 'description', 'type' => 'text', 'default' => '',),

I think there will be loads more though..

jafonseca

Quote from: tinoest on May 12, 2018, 05:46:04 PM
Change line 177 in install.php to

array('name' => 'description', 'type' => 'text', 'default' => '',),

I think there will be loads more though..

Thanks, but another error


Error en la Base de Datos
BLOB, TEXT, GEOMETRY or JSON column 'description' can't have a default value
Archivo: /home/uhdcl/public_html/Packages/temp/install.php
Line: 329

tinoest

Hmmm ok, I'll look in to this later today.

Not near a pc atm. Should be able to reply about 12hours from now.

It's your version of MySQL that's not happy with the format.

tinoest

Can you provide me with the output of

select @@GLOBAL.sql_mode

either run that in phpmyadmin or in a mysql shell.

Thanks,

jafonseca

Quote from: tinoest on May 13, 2018, 04:12:58 PM
Can you provide me with the output of

select @@GLOBAL.sql_mode

either run that in phpmyadmin or in a mysql shell.

Thanks,


tinoest

Thanks is there a way you can edit your sql_mode to not include STRICT_TRANS_TABLES? It will probably be set in your my.cnf

I can't copy and paste the string in your image but you could add this to the start of install.php if you can't remove it from the config.

$smcFunc['db_query']('', '
set session sql_mode = \'NO_ENGINE_SUBSTITUTION\';
                ',
            );


Replacing NO_ENGINE_SUBSTITUTION with all the settings there excluding the STRICT_TRANS_MODE

I'll raise a error on GitHub for it.

Undo the other change for the db table I suggested above as that won't work.

delta5

 Lots of bugs, updated php7.1 to 7.2. Even more errors. See my posts in 2.0.15 support. Tried to uninstall, crashed the forum. Nice mod, but I don't have time to deal with bugs and conflicts.

Arantor

Firstly, are you running the current version? Your other posts suggest you are not.

Secondly, SMF doesn't even support PHP 7.2, which means it may well be a PHP problem, not a TinyPortal problem.

-Rock Lee-

Quote from: delta5 on June 19, 2018, 12:44:53 PM
Lots of bugs, updated php7.1 to 7.2. Even more errors. See my posts in 2.0.15 support. Tried to uninstall, crashed the forum. Nice mod, but I don't have time to deal with bugs and conflicts.

Is it necessary to change the version? since SMF still gives problems with the branch 7.2 that in next versions it was tried to make compatible for that moment recimienda 7.0 or 7.1 where there are some solutions for the problem of compatabilidad.


Regards!
¡Regresando como cual Fenix! ~ Bomber Code
Ayudas - Aportes - Tutoriales - Y mucho mas!!!

MamaTea

I am wondering if maybe I am missing something?

I am working on getting my articles set up on my frontpage. (for now, just experimenting)

I have yet to find out what purpose the Intro Text serves, as I have not been able to find any trace of it outside of the article editor.

I would like to use the Intro Text on my front page, instead of showing the entire article.  I would like the entire article to only show on it's own page.

I have tried messing with the layout code on the frontpage editor, though whatever I do to it, is done to the actual article.  If I take the article text or ratings off of the frontpage article layout, the actual article page will not display any text or ratings either. -- I hope you can see what I am getting at here

Any ideas?

lurkalot

Quote from: MamaTea on June 26, 2018, 11:04:44 AM

I have yet to find out what purpose the Intro Text serves, as I have not been able to find any trace of it outside of the article editor.

I would like to use the Intro Text on my front page, instead of showing the entire article.  I would like the entire article to only show on it's own page.


Article intro is just that, it's a intro, a sample of the main article, which should at the bottom of it have a link to the full article.

The intro can be shown on the front page, and the article on its own page.  To get them to show on the front page you need to set in the front page settings to either,  "Selected topics + articles" or "Forum-posts and articles - sorted on date"

On the settings for the article you need to select
Status: Toggle show on front page. (button).
Use intro:  Yes
Approved: Yes
Article is active

Save.

MamaTea

Quote from: lurkalot on June 26, 2018, 01:34:47 PM

Article intro is just that, it's a intro, a sample of the main article, which should at the bottom of it have a link to the full article.

The intro can be shown on the front page, and the article on its own page.  To get them to show on the front page you need to set in the front page settings to either,  "Selected topics + articles" or "Forum-posts and articles - sorted on date"

On the settings for the article you need to select
Status: Toggle show on front page. (button).
Use intro:  Yes
Approved: Yes
Article is active

Save.


Awesome, thanks!  I knew I was missing some sort of step there.  Thank you!

Now that I know which settings I need to have it under for the intro, I'll try this again.

MamaTea

Is there an easy way to get rid of the icon when viewing the article?  (I actually am not planning to use it at all)

when I select not to use an icon, the default one pops up.  I would just rather the article to take up the entire width of the page.

Thanks.

Advertisement: