Advertisement:

Author Topic: TinyPortal  (Read 806480 times)

Offline minormike

  • Semi-Newbie
  • *
  • Posts: 14
Re: TinyPortal
« Reply #2780 on: October 17, 2020, 08:35:16 AM »
I'm using SMF 2.0.17 and TT 2.0.0
Adding that piece at the end still generates the error unfortunately. It occurred when I created an article and set an area to display it and hit Save

Offline @rjen

  • Full Member
  • ***
  • Posts: 699
  • Gender: Male
    • FJR-club Nederland
Re: TinyPortal
« Reply #2781 on: October 17, 2020, 09:39:58 AM »
Trying to understand what exactly lead to the error.

You created and article and set an area to display it?

How exactly did you do that:

1. As an admin or as a user with extra permissions?

2. You mention that you tries adding an article in the portal top panel

Quote
My complete forum is borked after checking an option to display articles in the portal top block

So I assume you created the article itself just fine, but the error started when you included the article in a block? Is that a correct assessment? Articles themselves do not contain a setting where to display them....

3. Then how did you go about that: I assume you created a new block of type Article: Single or Articles in a category?

Please help narrow it down, because I cannot reproduce it...
Running SMF 2.0 with Tinyportal 2.0.1 at www.fjr-club.nl
Testing SMF 2.1 with Tinyportal 2.1.0 at test2.fjr-club.nl

Offline MoreBloodWine

  • SMF Hero
  • ******
  • Posts: 2,741
  • Gender: Male
  • ...
    • Uncharted 2: Among Thieves Stat Sig Generator
Re: TinyPortal
« Reply #2782 on: October 17, 2020, 10:50:24 AM »
Finally I don't see why the latest upgrader should handle something which hasn't been supported for five years in the latest version when you can go to an intermediate release first.
So you missed where I said I brought the site current the the 2.1 RC2 branch of SMF which as I understand it should be supported by the TP 2.0 I'm trying to install ?!? But am instead being told to use an older ver ? That about right ?

But I'll chalk that up to miscommunications... since I can see where the following may have confused you or anyone for that matter by me indicating in a not so direct way that I fixed the WSOD by upgrading the forum to be current on it's underlying software....

Quote
Finally getting around to updating an old site after fixing an EXTREMELY old WSOD.

Did that by upgrade, anyway..



Finally getting around to updating an old site after fixing an EXTREMELY old WSOD.

Did that by upgrade, anyway...

Old TP was of the 1.1x branch.

DL'd and then UL'd the 2.0.0 version for the 2.1RC2 version of SMF.

It seems to look fine on the cursory check before installing. But after I click Install Now, I'm greeted with this.

Please assist, Ty ;-)

Code: [Select]
Unknown column 'var5' in 'field list'
File: /*removed*/Packages/temp/install.php
Line: 1156

Think we need to back track a little.

So this was an old SMF forum you have upgraded, from what version of SMF to what version? 

And you were running a really old TinyPortal version 1.107 and want to upgrade to the latest. Did you try installing TP1.6.8 first before going to TP2.0.0 as suggested?

Yes, it probably is best to start over.......

2015/16 is probably accurate for when I last gave a damn about fixing the site. It was an old one that wasn't really going anywhere. But I started feeling a bit nostalgic and brought it back in a manner of speaking.

I don't recall the version number I previously had installed for SMF, I want to say maybe 2.0.9. But the previously named version of TP I do believe to be accurate.

But without citing more potentially confusing history etc.

I upgraded an old forum of the 2015/16 era to the 2.1 RC2 of SMF. This, unless I am missing something... means my site is now current.

So, starting with packages I would always do TP first before even adding a Theme.

Well, me being on SMF 2.1 RC2 now means my database has already been modified.

But yes, I do have an old DB copy & file copy made before the upgrade. So I can go back to a WSOD if needed. But as of this minute without touching anything else...

This is where I currently stand...

2015/16 era forum upgraded to 2.1 RC2 of SMF, me now trying to install TP 2.0 on the now current forum software stuck at the install.php error I originally mentioned.

Ty, lukalot.

As a final answer, no I haven't tried to reinstall old packages since past experience have taught that that never works out too well if at all.

I can manually patch lines of code getting a package to install that otherwise wont for parse errors where something needs to fit between say lines 3 and 8 but wont because of a stray comma or something. That's like riding a bike I hope... but I only posted here bec I never attempt to solo something I don't recall seeing before.
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 73,189
Re: TinyPortal
« Reply #2783 on: October 17, 2020, 10:55:05 AM »
The only miscommunication here is the part where you missed that you can't go from 1.107 direct to 2.0.0 of TP - no matter what version of SMF you're basing it on.

You upgraded SMF, sure, but TP can't go from TP 1.107 to TP 2.0.0 because the stuff required to upgrade it was ditched years ago.
No good deed goes unpunished
All helpful urges should be circumvented

Offline MoreBloodWine

  • SMF Hero
  • ******
  • Posts: 2,741
  • Gender: Male
  • ...
    • Uncharted 2: Among Thieves Stat Sig Generator
Re: TinyPortal
« Reply #2784 on: October 17, 2020, 10:59:28 AM »
The only miscommunication here is the part where you missed that you can't go from 1.107 direct to 2.0.0 of TP - no matter what version of SMF you're basing it on.

You upgraded SMF, sure, but TP can't go from TP 1.107 to TP 2.0.0 because the stuff required to upgrade it was ditched years ago.
Ok, then the middle ground of a TP install is warranted and I will go DL and try I think the suggested 1.6.8 and post back accordingly...
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Offline MoreBloodWine

  • SMF Hero
  • ******
  • Posts: 2,741
  • Gender: Male
  • ...
    • Uncharted 2: Among Thieves Stat Sig Generator
Re: TinyPortal
« Reply #2785 on: October 17, 2020, 11:04:05 AM »
Going to go make my morning coffee but this is what I'm now getting... Ty.

Code: [Select]
Install Error: - please install a version of TinyPortal greater than or equal to 2.0.0
Edit: To be clear, that's what I get trying to install 1.6.8 on an upgraded 2.1 RC2 forum.
« Last Edit: October 17, 2020, 11:18:23 AM by MoreBloodWine »
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Offline lurkalot

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,757
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: TinyPortal
« Reply #2786 on: October 17, 2020, 11:16:11 AM »
I'm using SMF 2.0.17 and TT 2.0.0
Adding that piece at the end still generates the error unfortunately. It occurred when I created an article and set an area to display it and hit Save

OK, hopefully you should be able to get back in on your forum, I've turned that block off for you .  Let me know if that isn't the case.

And please, it would be useful to have the info @rjen requested above so we can narrow down the cause of the issue.

Offline @rjen

  • Full Member
  • ***
  • Posts: 699
  • Gender: Male
    • FJR-club Nederland
Re: TinyPortal
« Reply #2787 on: October 17, 2020, 11:18:05 AM »
Going to go make my morning coffee but this is what I'm now getting... Ty.

Code: [Select]
Install Error: - please install a version of TinyPortal greater than or equal to 2.0.0
Edit: To be clear, that's what I get trying to install 1.6.8 on a upgraded 2.1 RC2 forum.

That means that the Install of TP 2.0.0 seems to have partially completed. Due to the database changes in 2.0.0 compared to 1.6.x you cannot go back.

Since you said it was 2015 since you gave a damn about fixing the site, you may not have that much Tinyportal history to salvage? If so, you better start fresh...

Mind you: you will lose any articles and blocks that way...

step 1: go into PhPMyadmin and download the TinyPortal tables from the database: these are all the tables with a _tp_ prefix.  If you are up for it you could try to salvage the content of articles from there later
If it is old and you do not mind: skip this step

step 2: Uninstall whatever is left of TinyPortal

step 3: go into PhPMyadmin and delete the TinyPortal tables from the database: these are all the tables with a _tp_ prefix.

step 4: in the TinyPortal 2.0.0 package find the do_hooks.php file, upload this to the root of your forum and execute.
Manual with instructions found here: https://www.tinyportal.net/docs/index.php?page=87

step 5: Install TinyPortal 2.0.0
This will give you a clean install with the default blocks and you can go from there...
Running SMF 2.0 with Tinyportal 2.0.1 at www.fjr-club.nl
Testing SMF 2.1 with Tinyportal 2.1.0 at test2.fjr-club.nl

Offline MoreBloodWine

  • SMF Hero
  • ******
  • Posts: 2,741
  • Gender: Male
  • ...
    • Uncharted 2: Among Thieves Stat Sig Generator
Re: TinyPortal
« Reply #2788 on: October 17, 2020, 11:21:33 AM »
Going to go make my morning coffee but this is what I'm now getting... Ty.

Code: [Select]
Install Error: - please install a version of TinyPortal greater than or equal to 2.0.0
Edit: To be clear, that's what I get trying to install 1.6.8 on a upgraded 2.1 RC2 forum.

That means that the Install of TP 2.0.0 seems to have partially completed. Due to the database changes in 2.0.0 compared to 1.6.x you cannot go back.

Since you said it was 2015 since you gave a damn about fixing the site, you may not have that much Tinyportal history to salvage? If so, you better start fresh...

Mind you: you will lose any articles and blocks that way...

step 1: go into PhPMyadmin and download the TinyPortal tables from the database: these are all the tables with a _tp_ prefix.  If you are up for it you could try to salvage the content of articles from there later
If it is old and you do not mind: skip this step

step 2: Uninstall whatever is left of TinyPortal

step 3: go into PhPMyadmin and delete the TinyPortal tables from the database: these are all the tables with a _tp_ prefix.

step 4: in the TinyPortal 2.0.0 package find the do_hooks.php file, upload this to the root of your forum and execute.
Manual with instructions found here: https://www.tinyportal.net/docs/index.php?page=87

step 5: Install TinyPortal 2.0.0
This will give you a clean install with the default blocks and you can go from there...
I said I didn't giove a damn about it then but it's a site with substantial data.

Also, what was there to complete when I never got to install it,  ?the 2.0 of TP

That said, I also mentioned that I still have the old files and DB stuff.

So if I were to reinstall a WSOD site in a manner of speaking. Do the same thing but sans 2.0 and go directly to attempting 1.6.8 after the "new" 2.1 RC2 upgrade, then you're saying it will work ?
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Offline @rjen

  • Full Member
  • ***
  • Posts: 699
  • Gender: Male
    • FJR-club Nederland
Re: TinyPortal
« Reply #2789 on: October 17, 2020, 11:34:26 AM »
Finally getting around to updating an old site after fixing an EXTREMELY old WSOD.

Did that by upgrade, anyway...

Old TP was of the 1.1x branch.

DL'd and then UL'd the 2.0.0 version for the 2.1RC2 version of SMF.

It seems to look fine on the cursory check before installing. But after I click Install Now, I'm greeted with this.

Please assist, Ty ;-)

Code: [Select]
Unknown column 'var5' in 'field list'
File: /*removed*/Packages/temp/install.php
Line: 1156

You say that you clicked Install for TinyPortal 2.0.0 before you got the error: that means that the installer started to install. Somewhere in the process the install choked on the very old TP1.x table structure so the TP2.0.0 installer did not complete it's work.

I understand your site will have substantial data, but that does not necessarily mean that involves much TinyPortal data...
I am only suggesting to drop the tinyportal data, that will leave the rest of your forum (members, posts and all) intact

Quote
So if I were to reinstall a WSOD site in a manner of speaking. Do the same thing but sans 2.0 and go directly to attempting 1.6.8 after the "new" 2.1 RC2 upgrade and then you're saying it will work ?

That's not what I said, that's a completely different approach, like tinoest suggested. But if I remember correctly he suggested the start with 1.4.0

Quote
Although looking at the change you will probably need something from the 1.4.0 release or similar which was released in 2018; https://www.tinyportal.net/index.php?action=tportal;sa=download;dl=item115

But if I am honest: you are now in the Twilight zone, since the first TinyPortal that has support for SMF2.1 was version 1.5.1...
Running SMF 2.0 with Tinyportal 2.0.1 at www.fjr-club.nl
Testing SMF 2.1 with Tinyportal 2.1.0 at test2.fjr-club.nl

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 73,189
Re: TinyPortal
« Reply #2790 on: October 17, 2020, 11:38:14 AM »
Me personally I'd go back to the backup taken before upgrading to 2.1, then off the top of my head I'd probably to SMF 1.x to SMF 2.0, TP to TP 1.4.0 then TP to TP 1.6.8, then SMF to SMF 2.1 then TP to SMF 2.0.
No good deed goes unpunished
All helpful urges should be circumvented

Offline MoreBloodWine

  • SMF Hero
  • ******
  • Posts: 2,741
  • Gender: Male
  • ...
    • Uncharted 2: Among Thieves Stat Sig Generator
Re: TinyPortal
« Reply #2791 on: October 17, 2020, 11:45:50 AM »
Me personally I'd go back to the backup taken before upgrading to 2.1, then off the top of my head I'd probably to SMF 1.x to SMF 2.0, TP to TP 1.4.0 then TP to TP 1.6.8, then SMF to SMF 2.1 then TP to SMF 2.0.
Thats a long approach to what I said and probably best. Since I do have the old data and tables, unlike some. I have room to play with. So I'll try a direct jump to 2.1 RC2 again, try 1.6.8 then 2.0

If that fails, then I'll take this longer approach.

As for the other reply regarding substantial data, you're not necessarily wrong rjen, but I do have a bunch of custom TP blocks that tie into other things that just can't be as easily produced as they were then.

I'll take the approach suggested by arantor that's pretty much inline with what I was thinking at this point. So I'll go that route and post back if needed for more support or just to say, thank god that ******s over lol
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Offline @rjen

  • Full Member
  • ***
  • Posts: 699
  • Gender: Male
    • FJR-club Nederland
Re: TinyPortal
« Reply #2792 on: October 17, 2020, 11:54:18 AM »
Sounds like a plan..,
Running SMF 2.0 with Tinyportal 2.0.1 at www.fjr-club.nl
Testing SMF 2.1 with Tinyportal 2.1.0 at test2.fjr-club.nl

Offline lurkalot

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,757
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: TinyPortal
« Reply #2793 on: October 17, 2020, 11:56:33 AM »
Me personally I'd go back to the backup taken before upgrading to 2.1, then off the top of my head I'd probably to SMF 1.x to SMF 2.0, TP to TP 1.4.0 then TP to TP 1.6.8, then SMF to SMF 2.1 then TP to SMF 2.0.
Thats a long approach to what I said and probably best. Since I do have the old data and tables, unlike some. I have room to play with. So I'll try a direct jump to 2.1 RC2 again, try 1.6.8 then 2.0

If that fails, then I'll take this longer approach.

As for the other reply regarding substantial data, you're not necessarily wrong rjen, but I do have a bunch of custom TP blocks that tie into other things that just can't be as easily produced as they were then.

I'll take the approach suggested by arantor that's pretty much inline with what I was thinking at this point. So I'll go that route and post back if needed for more support or just to say, thank god that ******s over lol

Can I make another suggestion while you go through this process.  It might be wise to turn off blocks while you can, just in case they contain any conflicting code.  You can then re enable them one by one,  once everything is stable.

Offline MoreBloodWine

  • SMF Hero
  • ******
  • Posts: 2,741
  • Gender: Male
  • ...
    • Uncharted 2: Among Thieves Stat Sig Generator
Re: TinyPortal
« Reply #2794 on: October 17, 2020, 12:12:27 PM »
Me personally I'd go back to the backup taken before upgrading to 2.1, then off the top of my head I'd probably to SMF 1.x to SMF 2.0, TP to TP 1.4.0 then TP to TP 1.6.8, then SMF to SMF 2.1 then TP to SMF 2.0.
Thats a long approach to what I said and probably best. Since I do have the old data and tables, unlike some. I have room to play with. So I'll try a direct jump to 2.1 RC2 again, try 1.6.8 then 2.0

If that fails, then I'll take this longer approach.

As for the other reply regarding substantial data, you're not necessarily wrong rjen, but I do have a bunch of custom TP blocks that tie into other things that just can't be as easily produced as they were then.

I'll take the approach suggested by arantor that's pretty much inline with what I was thinking at this point. So I'll go that route and post back if needed for more support or just to say, thank god that ******s over lol

Can I make another suggestion while you go through this process.  It might be wise to turn off blocks while you can, just in case they contain any conflicting code.  You can then re enable them one by one,  once everything is stable.
How would I do this via an SQL command after I restore the old DB ? But before trying to "upgrade" TP through the PM ?

The old ver in said DB is I think I had said 1.0.7 if that changes any commands used via the DB run command thing.
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Offline lurkalot

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,757
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: TinyPortal
« Reply #2795 on: October 17, 2020, 12:30:38 PM »

Can I make another suggestion while you go through this process.  It might be wise to turn off blocks while you can, just in case they contain any conflicting code.  You can then re enable them one by one,  once everything is stable.
How would I do this via an SQL command after I restore the old DB ? But before trying to "upgrade" TP through the PM ?

The old ver in said DB is I think I had said 1.0.7 if that changes any commands used via the DB run command thing.

I meant through the TP admin panel before you go for the upgrade, assuming it's in a state where you can get to it.   It was just an extra precaution just in case there's some very old code in some of the blocks, especially if they were prior to using smfunc 

Offline MoreBloodWine

  • SMF Hero
  • ******
  • Posts: 2,741
  • Gender: Male
  • ...
    • Uncharted 2: Among Thieves Stat Sig Generator
Re: TinyPortal
« Reply #2796 on: October 17, 2020, 12:45:04 PM »

Can I make another suggestion while you go through this process.  It might be wise to turn off blocks while you can, just in case they contain any conflicting code.  You can then re enable them one by one,  once everything is stable.
How would I do this via an SQL command after I restore the old DB ? But before trying to "upgrade" TP through the PM ?

The old ver in said DB is I think I had said 1.0.7 if that changes any commands used via the DB run command thing.

I meant through the TP admin panel before you go for the upgrade, assuming it's in a state where you can get to it.   It was just an extra precaution just in case there's some very old code in some of the blocks, especially if they were prior to using smfunc
An old WSOD is what started this process so that's a no go.

I have an idea though, any errors shouldn't show with blocks on while in admin. So i should be able to disable after upgrade.

Then i can enable one by one.

This assumes the WSOD isn't just the home page.

What's the url for tp admin ?
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Offline lurkalot

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,757
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: TinyPortal
« Reply #2797 on: October 17, 2020, 12:49:39 PM »

Can I make another suggestion while you go through this process.  It might be wise to turn off blocks while you can, just in case they contain any conflicting code.  You can then re enable them one by one,  once everything is stable.
How would I do this via an SQL command after I restore the old DB ? But before trying to "upgrade" TP through the PM ?

The old ver in said DB is I think I had said 1.0.7 if that changes any commands used via the DB run command thing.

I meant through the TP admin panel before you go for the upgrade, assuming it's in a state where you can get to it.   It was just an extra precaution just in case there's some very old code in some of the blocks, especially if they were prior to using smfunc
An old WSOD is what started this process so that's a no go.

I have an idea though, any errors shouldn't show with blocks on while in admin. So i should be able to disable after upgrade.

Then i can enable one by one.

This assumes the WSOD isn't just the home page.

What's the url for tp admin ?

You could try adding this to the end of your site url and see if you can get there.   ?action=tpadmin;sa=panels;noblocks

Offline MoreBloodWine

  • SMF Hero
  • ******
  • Posts: 2,741
  • Gender: Male
  • ...
    • Uncharted 2: Among Thieves Stat Sig Generator
Re: TinyPortal
« Reply #2798 on: October 17, 2020, 01:16:14 PM »

Can I make another suggestion while you go through this process.  It might be wise to turn off blocks while you can, just in case they contain any conflicting code.  You can then re enable them one by one,  once everything is stable.
How would I do this via an SQL command after I restore the old DB ? But before trying to "upgrade" TP through the PM ?

The old ver in said DB is I think I had said 1.0.7 if that changes any commands used via the DB run command thing.

I meant through the TP admin panel before you go for the upgrade, assuming it's in a state where you can get to it.   It was just an extra precaution just in case there's some very old code in some of the blocks, especially if they were prior to using smfunc
An old WSOD is what started this process so that's a no go.

I have an idea though, any errors shouldn't show with blocks on while in admin. So i should be able to disable after upgrade.

Then i can enable one by one.

This assumes the WSOD isn't just the home page.

What's the url for tp admin ?

You could try adding this to the end of your site url and see if you can get there.   ?action=tpadmin;sa=panels;noblocks
Didn't work, was worth trying, but I'm now back to the WSOD site, so fingers crossed on everything else...
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Offline MoreBloodWine

  • SMF Hero
  • ******
  • Posts: 2,741
  • Gender: Male
  • ...
    • Uncharted 2: Among Thieves Stat Sig Generator
Re: TinyPortal
« Reply #2799 on: October 17, 2020, 01:44:51 PM »
Not that I need to post this, but I may be ok just doing 2.0.17 and waiting for 2.1 to become final before worrying about bringing TP completely current.

https://www.simplemachines.org/community/index.php?topic=575261.msg4071313#msg4071313

This will be my only remarks here regarding non TP stuff. But will post back in a while if I need more help regarding TP to which I haven't touched yet, but will after this.

But for now, at least until 2.1 is final which should be soon if we're on RC3.

It looks like I can still use TP 1.0.7 on SMF 2.0.17... for a short while anyway.

But at least on 2.0.17 it might still be prudent to try 1.6.8 and do 2.0 when SMF 2.1 is final.
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits