TinyPortal

Started by lurkalot, February 12, 2005, 04:43:00 AM

Previous topic - Next topic

@rjen

Thanks for the report. I'll check it...
Running SMF 2.1 with latest Tinyportal at www.fjr-club.nl
Testing SMF 2.1 with next version Tinyportal at test.fjr-club.nl

@rjen

Quote from: marcosbr on March 08, 2022, 02:44:43 PMTwo bugs that bothered me about TinyPortal. I always ignored them and today I decided to look for them.

Themes/default/css/tp-style.css

Find:
max-height: 300 px;Replace:
max-height: 300px;

Find:
6px 0 0 0; !important;Replace:
6px 0 0 0 !important;

Old validation error:

Corrected for the next TP version
Running SMF 2.1 with latest Tinyportal at www.fjr-club.nl
Testing SMF 2.1 with next version Tinyportal at test.fjr-club.nl

aaronhall

Okay, I am lost at how to install a Mod or a hook for SMF 2.1.

How do I do it? The documentation I found didn't really explain to where I understood it.

@rjen

Install a hook? What are you trying to do exactly?
Running SMF 2.1 with latest Tinyportal at www.fjr-club.nl
Testing SMF 2.1 with next version Tinyportal at test.fjr-club.nl

Doug Heffernan

Quote from: aaronhall on March 12, 2022, 01:23:59 PMOkay, I am lost at how to install a Mod or a hook for SMF 2.1.

How do I do it? The documentation I found didn't really explain to where I understood it.

You do not install a hook. A mod is installed through the Package Manager.

Can you link to the documentation that you found which did not really explain it btw?

 

Oldiesmann

Hooks are added in one of two ways - either via package-info.xml (via the <hook> element) or via the add_integration_function call (included in a PHP file that's run when installing the mod).
Michael Eshom
Christian Metal Fans

Sir Osis of Liver

"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

@rjen

There was an issue with 2.2.0 related to the shoutbox being installed with a missing parameter: this is fixed in 2.2.1.

But once installed the block parameter stays missing. To fix Go to the TinyPortal shoutbox block. Make sure to save the block setting (no change needed) and it will set the missing parameter in the database.

Then the problem will be fixed...
Running SMF 2.1 with latest Tinyportal at www.fjr-club.nl
Testing SMF 2.1 with next version Tinyportal at test.fjr-club.nl

@rjen

This bug...

Quote from: @rjen on February 15, 2022, 03:14:14 PM
Quote from: bienquangcao on February 15, 2022, 02:08:35 PMI run SMF on LEMP (PHP 7.4 and Nginx), my forum index redirect loop forever.

That bug is in TP version 2.2.0 only. Version 2.2.1 was released yesterday to fix that. Please do NOT use version 2.2.0 anymore....
Running SMF 2.1 with latest Tinyportal at www.fjr-club.nl
Testing SMF 2.1 with next version Tinyportal at test.fjr-club.nl

Cookieswithcoffee

Question - while you're working to correct the bugs, can the previous version of this be posted or did it also have errors? I apologize if my question hovers in the area of ridiculous. I'm a newb ;)

Thanks!

tinoest

Quote from: Cookieswithcoffee on April 28, 2022, 06:02:37 AMQuestion - while you're working to correct the bugs, can the previous version of this be posted or did it also have errors? I apologize if my question hovers in the area of ridiculous. I'm a newb ;)

Thanks!

Sorry previous version of what?

All previous versions are available on the TinyPortal website.

Or GitHub https://github.com/Tinyportal/TinyPortal/tags

Cookieswithcoffee

Quote from: @rjen on April 15, 2022, 12:17:36 AMThis bug...
This is what I read that made me question the availability of versions.


Quote from: @rjen on February 15, 2022, 03:14:14 PM
Quote from: bienquangcao on February 15, 2022, 02:08:35 PMI run SMF on LEMP (PHP 7.4 and Nginx), my forum index redirect loop forever.

That bug is in TP version 2.2.0 only. Version 2.2.1 was released yesterday to fix that. Please do NOT use version 2.2.0 anymore....


tinoest

Quote from: Cookieswithcoffee on April 28, 2022, 08:13:06 AM
Quote from: @rjen on April 15, 2022, 12:17:36 AMThis bug...
This is what I read that made me question the availability of versions.


Quote from: @rjen on February 15, 2022, 03:14:14 PM
Quote from: bienquangcao on February 15, 2022, 02:08:35 PMI run SMF on LEMP (PHP 7.4 and Nginx), my forum index redirect loop forever.

That bug is in TP version 2.2.0 only. Version 2.2.1 was released yesterday to fix that. Please do NOT use version 2.2.0 anymore....



I wouldn't use this version as it had bugs, one of which was fatal. The fixed version is available both on here and the TinyPortal website. So there isn't really a reason to download it.

@rjen

No need to worry about what to download. All downloadable versions are ok and can be used. Latest version of TP has that bug fixed. Just use it. Version number is 2.2.1
Running SMF 2.1 with latest Tinyportal at www.fjr-club.nl
Testing SMF 2.1 with next version Tinyportal at test.fjr-club.nl

djkimmel

Today I updated a forum from 2.0.17 to 2.0.18 to 2.0.19. Then went from Tiny Portal 1.3 (uninstalled first) to 2.2.1. Forum and frontpage fail with too many redirects error in the browser. I cleared cookies and tried an incognito window. Ended up uninstalling new v2.2.1 and going down to v2.1.0. v2.1.0 is working though I had to reset a bunch of block and other settings to get things back to how they looked.

The front page was not displaying correctly before probably because I had upgraded a while back to PHP v7.3. It's a live site that doesn't get much traffic so not high on my priority list, but I use Tiny Portal elsewhere and concerned I will have the same error. (kentucky lake bass dot com)

Sounds like TP v2.2.1 was supposed to fix the too many redirects browser error (in Google Chrome), but I'm still having it and don't know why.

@rjen

Not sure why you had the issue, but maybe it was because you came from a very old version.

The redirect issue was caused by changes to the shoutbox block. If you have the issue , please check all shoutbox blocks you have and make sure a shoutbox ID is set. Going to the block settings and saving should suffice: the block should then get the default shoutbox I'd: 1
Running SMF 2.1 with latest Tinyportal at www.fjr-club.nl
Testing SMF 2.1 with next version Tinyportal at test.fjr-club.nl

Cookieswithcoffee

I apologize if this is covered in the 156 pages but I think my brain is getting melty. How do I change the background color of the shoutbox to a dark theme? I saw it 2 days ago -praying that wasn't a dream or hallucination- and now I'm circling the drain.

I'm using the current version of TP (which I'm loving as I learn it). I'm new to all of this.

Thanks muchly!

cookdandbombd

#3117
Just installed the latest version on the most up-to-date SMF, and it's just not displaying correctly for me when I'm logged in as an admin?

When I go into the forum listings, the page stretches out to the right.

If I read a thread it's fine, but when I go to quick edit I then again have the screen stretching way off the side of my phone. Any ideas?



(Ignore the black bar at the bottom, that's my browser.)

The portal posts don't display properly either, with the text all overwriting the avatars.



Edit: I think the stretching forum pages in the first pic are caused by the moderation check boxes. Is there a way to turn them off or fix that?

Shades.

Quote from: cookdandbombd on May 04, 2022, 07:09:23 PMEdit: I think the stretching forum pages in the first pic are caused by the moderation check boxes. Is there a way to turn them off or fix that?
Admin>Configuration>Themes and Layout>Member Options,  show quick-moderation as click on "don't show".
ShadesWeb.com - Custom Logos - My Themes on SMF | My Themes on ShadesWeb
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Antechinus

Quote from: cookdandbombd on May 04, 2022, 07:09:23 PMIf I read a thread it's fine, but when I go to quick edit I then again have the screen stretching way off the side of my phone. Any ideas?
Have seen that before on RC versions. IIRC it was a bug with flex CSS, but was fixed before 2.1 went stable. Have you edited the default CSS at all?

QuoteEdit: I think the stretching forum pages in the first pic are caused by the moderation check boxes.
No, they aren't the problem. The default 2.1 theme is fine down to phone size with the checkboxes enabled. The problem is something else.

Advertisement: