• Welcome to Simple Machines Community Forum. Please login or sign up.
September 22, 2021, 05:24:52 AM

News:

Join the Facebook Fan Page.


TinyPortal

Started by lurkalot, February 12, 2005, 04:43:00 AM

Previous topic - Next topic

kerux4

ok, now I am getting this

Table 'htfeozng_smf1.tportal_settings' doesn't exist
File: /home/htfeozng/public_html/forum1/Sources/TPortal.php
Line: 40
C-YA,
Mike

bloc

Quote from: kerux4 on February 18, 2005, 10:55:53 AM
ok, when I try to install this, I get the following

2: copy(index.php~): failed to open stream: Permission denied

How do i fix this??
Quote from: kerux4 on February 18, 2005, 11:02:46 AM
ok, now I am getting this

Table 'htfeozng_smf1.tportal_settings' doesn't exist
File: /home/htfeozng/public_html/forum1/Sources/TPortal.php
Line: 40
You are using a bit older version of it. Please use the latest archive, that don't create these errors. Also note that it IS beta still, so please do not use it without at least testing it locally - or with a non-important website.

Things WILL change, although I aim to preserve most of what is already done. 

kerux4

Well, I did the smart thing and got my host to install it for me. I must say it is pretty cool.
C-YA,
Mike

Azraeliitti

I have tested it for three days and noticed the following flaws and bugs:

  • If you have articles divided for multiple pages, only the articles in the first page show up
  • Writer of the article won't show up
  • If you add tables with WYSIWYG- editor in HTML mode, it won't show them up right
  • Also, if you copy+paste the code to WYSIWYG- editor in HTML mode, the code rarely works right.
  • You should be able to set permissions who can add articles and stuff.
  • Read more- links don't work, so intro- option is useless for now.
  • If you set permissions for table for some membergroups, they still show up for everyone...
  • ...and they show up to the membergroups allowed to view it at least twice.

More to come... :P

bloc

Quote from: Azraeliitti on February 18, 2005, 02:36:37 PM
I have tested it for three days and noticed the following flaws and bugs:

  • If you have articles divided for multiple pages, only the articles in the first page show up
  • Writer of the article won't show up
  • If you add tables with WYSIWYG- editor in HTML mode, it won't show them up right
  • Also, if you copy+paste the code to WYSIWYG- editor in HTML mode, the code rarely works right.
  • You should be able to set permissions who can add articles and stuff.
  • Read more- links don't work, so intro- option is useless for now.
  • If you set permissions for table for some membergroups, they still show up for everyone...
  • ...and they show up to the membergroups allowed to view it at least twice.

More to come... :P

Thanks for the feedback. :)

Most of the problems I am aware of and are working on. The ones with tables I have to check, but it most likely is something with the WYSIWYG editor. As for adding support for writer and who can see/write it is planned in the next beta.

NightOwl

Quote from: Bloc on February 18, 2005, 06:40:42 PM
Most of the problems I am aware of and are working on. The ones with tables I have to check, but it most likely is something with the WYSIWYG editor. As for adding support for writer and who can see/write it is planned in the next beta.

Glad to hear that. Cause I'm also waiting for the viewing permission of blocks too.

Tanks

My banners are working again :-) Thanks Bloc

maufonseca

You will make a blank page creator right?

bloc

A single page on frontpage you mean? If so, yes.

_complex

Dont know if i thanked u yet.. but thx for this.. nice mod..

thefool1972

Hullo,

Was just curious, what would it take to have an option in an article to make it stay at the top?  While I can just date it way ahead, this is only a workaround.

Also, allowing sticky posts to stay at the top of the news would be good too.

Thanks,
John Bowden 

bloc

You can already make an article "on top " regardless of date - just use the option of  "set as featured". It will then come on top of the first page.

Sticky posts from the news on top too..? Not planned , but I can check how difficult it might be. The news from forum is taken from the SSI.php function, so if that don't collect information about stickiness, it would mean another call to the database just for that then...but I will check further first.

thefool1972

Oh good!  When I didn't see it as a checkbox in the message creation, I didn't notice it...

Thanks!

mennou

How can i make the portal work with these themes?
Theme Settings
SMF Default Theme 
Classic YaBB SE Theme   
theme1   
MidLand   
MidMetal   
MidBlue   
xtSMF Theme!   
Iblues Theme   
Hotmail Theme   
red   
Loon Theme - Blue   
MidOrange   
XP Theme!   
curveSMF   
TechHead   
amdred01-rc111   
amdgreen01-rc111   
amdgreen01-english-buttons11   
Season Theme - Autumn dark   
Season Theme - Winter light   
hendrix-exp-v103   
woodland10   
Apollo   
Mercury   
Themis   
Juno   
SMF Black Theme   
Chat Bubbles2

bloc

Well, at least some of my themes are already converted : Helios, Mercury and Themis. And of course SMF default theme..that one is the the one that gets modded..! For downloads of my converted ones , look here :
http://www.bloczone.net/smf/index.php?board=24.0

As for the others they will have to be done manually, but its only index.template.php in them that needs some modifications. If the theme authors agreed on that, i could help out on this...but I won't start mass-converting them as such.

I will make a tutorial on how to convert other themes though. 

riekl

I love this mod .. 2 questions ..

#1) The front page has the no articles thing .. however .. in the tpadmin i have it set to show the posts from my announcements forum .. yet nothing i post in the announcements forum appears on this front page ??

#2) On your site you have a block showing the most recent threads .. i desperatly need that :)  have code for that ?

peterstannard

Quote from: riekl on February 22, 2005, 01:48:58 PM
I love this mod .. 2 questions ..

#1) The front page has the no articles thing .. however .. in the tpadmin i have it set to show the posts from my announcements forum .. yet nothing i post in the announcements forum appears on this front page ??

#2) On your site you have a block showing the most recent threads .. i desperatly need that :)  have code for that ?

1) maybe you have turned it off?

2) use ssi (www.yourforums.com/forum/ssi_examples.php

riekl

#1)

Found out the problem .. apparently the forum you use must be open to GUEST for the tinyportal to read it ? :(

#2)

Thanks for the link .. i'm still clueless about how to actually use this i'm not a web designer ..

verbam

I have the same problem, you can NOT see any topic in TPortal UNLESS you give to guests permission to see THE TOPICS BUT...

Configure it like this:

Forum Configuration --> Edit Features and Options --> Allow guests to browse the forum  = NO
Manage Permissions  --> Permissions by Board (your Board name) --> Unregistered Guests = YES


Gives the result that your MEMBERS will see the Topics in TPortal (but you have to login to see something)

(Temporary you can use these settings ???)


bloc

Of course guest can't see the topics if you don't allow guest to see them inside the forum! It would be not very logical to show them on portal's frontpage - and then not show them once in.

This is the beauty of SSI.php, which the portal use for getting the news in the first palce - it takes into account what forums members/non-members actually can see. ;)

Advertisement: