Advertisement:

Author Topic: TinyPortal  (Read 753330 times)

Offline Ken.

  • Full Member
  • ***
  • Posts: 496
  • Gender: Male
  • TinyPortal Rocks!
    • Our FamilyForum
Re: TinyPortal
« Reply #500 on: February 18, 2010, 05:17:43 AM »
Just to add to Bikken's post... there is also a download system built into TinyPortal that can be used to host files on your site and make them available for download. It can be set to allow for member uploads and downloads.
"If you don't have a stack of failures in your shop, you aren't trying hard enough". --Richard Raffin.


Offline oOo--STAR--oOo

  • Full Member
  • ***
  • Posts: 645
  • Perfectionist
    • Developing Uniquez
Re: TinyPortal
« Reply #501 on: February 18, 2010, 06:31:01 AM »
Is it better than the download system thats available here?
Style and feture wise?
You can't fool a sufficiently talented fool.

http://www.uniquez-home.com
In Design Phase!

Mods I am designing,  No refresh Collapse Categories , Poll Redesign , Pure CSS Breadcrumb , Profile Statuses, Profile Views.

Offline Ken.

  • Full Member
  • ***
  • Posts: 496
  • Gender: Male
  • TinyPortal Rocks!
    • Our FamilyForum
Re: TinyPortal
« Reply #502 on: February 18, 2010, 06:47:00 AM »
Is it better than the download system thats available here?
Style and feture wise?

That's always going to be a matter of personal preference, for me the answer is yes because I use TinyPortal and think it's best... for others the answer may be different.
The best way to resolve questions like this for yourself is to set up a test site and try the different options that are available to determine what suits your needs.
"If you don't have a stack of failures in your shop, you aren't trying hard enough". --Richard Raffin.


Offline ricardo35

  • Semi-Newbie
  • *
  • Posts: 73
Re: TinyPortal
« Reply #503 on: March 23, 2010, 11:50:36 AM »
Hello.

I have got a question regarding TP and SMF.

I'm trying to get the forum displayed next to the left tiny portal blocks. However I do NOT want the right side of the blocks to be displayed on the forum.
I've found an option in the admin panel saying '' hide panels when in custom actions'' @ Panels & Blocks.
Adding ''Forums'' makes both left and right blocks dissapear. Removing ''Forums'' Makes both blocks appear.

I'm clueless :)

Thanks!

bloc

  • Guest
Re: TinyPortal
« Reply #504 on: March 23, 2010, 11:52:55 AM »
There is a setting on the "panels" page that let you hide the panel when inside the forum, tick off that and you should be fine.

Offline ricardo35

  • Semi-Newbie
  • *
  • Posts: 73
Re: TinyPortal
« Reply #505 on: March 23, 2010, 12:03:44 PM »
Thanks for your reply.

Do you mean that I have to check the other boxes and uncheck the forum one?
That seems a little bit odd in my opinion, as I would have to do this for all right blocks then?

Pic07 displays the Settings page from Panels.. Where I can only say whether to display both blocks or none.

EDIT: I found it, thanks!
« Last Edit: March 23, 2010, 12:07:25 PM by ricardo35 »

Offline ricardo35

  • Semi-Newbie
  • *
  • Posts: 73
Re: TinyPortal
« Reply #506 on: March 23, 2010, 01:30:29 PM »
I've got one more question..

Tinyportal allows you to create some block that displays recent topics on your forum.
Now I've made two of these blocks. Both blocks show the last 5 posts on my forum in any section.
I was now wondering how I could make one block only show the last 5 topics from one specific forum.

If anyone happens to know if this is possible and how, please let me know!

Thanks in advance.

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #507 on: March 23, 2010, 01:37:48 PM »
There are several custom block code snippets on the TP site in the block code snippets board for exactly this. A search through this board will help you find what you need.
http://www.tinyportal.net/index.php?board=46.0
IchBin™        TinyPortal
Coding Guidelines       

Offline ricardo35

  • Semi-Newbie
  • *
  • Posts: 73
Re: TinyPortal
« Reply #508 on: March 23, 2010, 01:54:54 PM »
Hey.

Thanks for your reply.

I checked one of your topics with the extremely long code, this one gave an error on line 1.

The other code I tried, which works.
Code: [Select]
       
global $scripturl;

echo '
                        <table border="0" width="100%" cellspacing="1" cellpadding="4" class="bordercolor">
                               <tr><td colspan="3" class="titlebg">Recent topics</td></tr> ';
       $what=ssi_recenttopics('4', NULL, 'array');


        foreach ($what as $topic)
        {
                echo '
                                <tr>
                                        <td class="windowbg" valign="middle">
                                                ', $topic['link'];

                // Is this topic new? (assuming they are logged in!)
                if (!$topic['new'] && $context['user']['is_logged'])
                        echo '
                                                <a href="', $scripturl, '?topic=', $topic['topic'], '.from', $topic['new_from'], '#new"><img src="', $settings['images_url'], '/', $context['user']['language'], '/new.gif" alt="', $txt[302], '" border="0" /></a>';

                echo '
                                        </td>
                                        <td class="windowbg2" valign="middle" width="20%">
                                                ', $topic['poster']['link'], '
                                        </td>
                                        <td class="windowbg2" valign="middle" width="35%">';
                if ($settings['images_url'] != $settings['theme_url'] . '/images' || file_exists($settings['theme_dir'] . '/images/icons/last_post.gif'))
                        echo '
                                        <a href="', $topic['href'], '"><img src="', $settings['images_url'], '/icons/last_post.gif" alt="', $txt[111], '" title="', $txt[111], '" border="0" style="float: right;" /></a>';
                echo '
                                                <span class="smalltext">
                                                        ', $topic['time'], '
                                                </span>
                                        </td>
                                </tr>';
        }

        echo '
                        </table>';

However, here, I won't be able to select specific boards from my forum, for as far I know.
Is this possible? And if please let me know :)

Thanks!

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #509 on: March 23, 2010, 02:20:59 PM »
There are several topics for your request in that board I pointed you to. Here's one.

http://www.tinyportal.net/index.php?topic=25497.0
IchBin™        TinyPortal
Coding Guidelines       

bloc

  • Guest
Re: TinyPortal
« Reply #510 on: April 01, 2010, 01:15:49 PM »
- TinyPortal have been updated to v1.0 beta5 today, with support for SMF 2.0 RC2/RC3 + lots of bugfixes and improvements. Check first post for download link or visit http://www.tinyportal.net for more details.

Offline Antechinus

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,327
  • Master of BBC Abuse
Re: TinyPortal
« Reply #511 on: April 02, 2010, 04:47:41 PM »
Congratulations on the new release. :)

bloc

  • Guest
Re: TinyPortal
« Reply #512 on: April 03, 2010, 05:27:21 PM »
Did you choose a module that should show on frontpage? currently only the Shoutbox will show, so thats prob. why you get the error.

Offline KensonPlays

  • SMF Hero
  • ******
  • Posts: 4,306
    • @Kenson_Plays on Twitter
Re: TinyPortal
« Reply #513 on: April 03, 2010, 07:00:51 PM »
Now this is for RC3, I am trying it out, registered at tinyportal.net...

EDIT:
My activation email never came... not spam or inbox!
« Last Edit: April 03, 2010, 07:10:23 PM by Kcmartz »

bloc

  • Guest
Re: TinyPortal
« Reply #514 on: April 04, 2010, 08:05:04 AM »
Did you get in, Kcmartz?

Offline KensonPlays

  • SMF Hero
  • ******
  • Posts: 4,306
    • @Kenson_Plays on Twitter
Re: TinyPortal
« Reply #515 on: April 04, 2010, 08:54:47 AM »
Yes, finally, but the admin is wierd, not in admin, but a whole new menu area menu! I don't like that :|. I switched back to PortaMx, which I am way more familiar with, sorry...

bloc

  • Guest
Re: TinyPortal
« Reply #516 on: April 04, 2010, 08:55:38 AM »
No worries. :)

Offline KensonPlays

  • SMF Hero
  • ******
  • Posts: 4,306
    • @Kenson_Plays on Twitter
Re: TinyPortal
« Reply #517 on: April 04, 2010, 08:57:33 AM »
Thanks, once it looks like I will be more familiar with it's admin layout, then I might try it again...

Offline Snogmarr

  • Jr. Member
  • **
  • Posts: 289
  • Gender: Male
  • 2RC3
Re: TinyPortal
« Reply #518 on: April 04, 2010, 09:56:32 AM »
Ref 030410-156p+3
funny
you answered above posters question yesterday after mine then his again today even after I had asked again about the error,,,
you were on line when I asked again yet you answered above post again and ignored mine.

 can you tell me why.

« Last Edit: April 04, 2010, 10:56:30 AM by xnathansxdadx »

bloc

  • Guest
Re: TinyPortal
« Reply #519 on: April 04, 2010, 11:28:16 AM »
Ref 030410-156p+3
funny
you answered above posters question yesterday after mine then his again today even after I had asked again about the error,,,
you were on line when I asked again yet you answered above post again and ignored mine.

 can you tell me why.



There is no reason, your error is a language error. Check you have the latest of them - or clear the cache.