Advertisement:

Author Topic: TinyPortal  (Read 744945 times)

bloc

  • Guest
Re: TinyPortal
« Reply #800 on: September 28, 2010, 05:12:48 PM »
The gallery script used on smfdesign was a previous TP module, not developed anymore.

The one at Blocweb is a brand new one and isn't a TP module at all - its a custom action that integrates tightly with subscriptions, and can both show the themes as well as provide downloads for them. Its not for sale, though I plan to re-use the code in TP modules in the future. It will be free modules then.

Offline ormuz

  • Full Member
  • ***
  • Posts: 689
Re: TinyPortal
« Reply #801 on: September 29, 2010, 08:31:03 AM »
The gallery script used on smfdesign was a previous TP module, not developed anymore.

Can u provide the download link?

thanks,

bloc

  • Guest
Re: TinyPortal
« Reply #802 on: September 29, 2010, 11:52:38 AM »
No, it isn't available anywhere.

Offline FBy

  • Newbie
  • *
  • Posts: 5
Re: TinyPortal
« Reply #803 on: October 01, 2010, 05:38:07 AM »
Hi, at first thanks for TP...

my Setup:
smf 2.0 rc3
tp 1.0rc1
ajax chat
Theme: Curve

but now some questions:
1. Since i changed my Version from TP 1 Beta 5 to the 1Rc1 the Usernames are no longer shown in the "online" Box / Panel
only the User Avatars are visible, no matter if i switch to Avatar yes or no...
2. Also referring to the online box:
The user Info center also gives information about users that are in the chat but i haven't found any solution to show it in a TP panel.
3. I recieve an error in the ajax chat window
Undefined index: show_download in /home/www/web221/html/forum/Sources/TPSubs.php on line 201


Best regards and thanks for the help...
Frank
p.s.: i'm not a programmer  :-X so please be patient with me..
Urgent help needed (as usual  ;) )
« Last Edit: October 01, 2010, 06:20:00 AM by FBy »

Offline FBy

  • Newbie
  • *
  • Posts: 5
Re: TinyPortal
« Reply #804 on: October 01, 2010, 08:32:25 AM »
After removing TP1.0RC1 and going back to TP 1.5beta
The Ajax chat is running again
and also the Usernames are displayed instead of Avatar Pictures..

bloc

  • Guest
Re: TinyPortal
« Reply #805 on: October 01, 2010, 11:49:06 AM »
Hi, at first thanks for TP...

my Setup:
smf 2.0 rc3
tp 1.0rc1
ajax chat
Theme: Curve

but now some questions:
1. Since i changed my Version from TP 1 Beta 5 to the 1Rc1 the Usernames are no longer shown in the "online" Box / Panel
only the User Avatars are visible, no matter if i switch to Avatar yes or no...
2. Also referring to the online box:
The user Info center also gives information about users that are in the chat but i haven't found any solution to show it in a TP panel.
3. I recieve an error in the ajax chat window
Undefined index: show_download in /home/www/web221/html/forum/Sources/TPSubs.php on line 201


Best regards and thanks for the help...
Frank
p.s.: i'm not a programmer  :-X so please be patient with me..
Urgent help needed (as usual  ;) )

1.) I will check if it is changing - it should really.

2.) It should be matter of copying the info center code from BoardIndex.template but it will prob. only show on boardindex, not anywhere else.

3) Ajax chat? Not sure what that can be, but if it worked on beta5 then it relies on something not present in RC1 perhaps. I will need more debug info though.

Offline FBy

  • Newbie
  • *
  • Posts: 5
Re: TinyPortal
« Reply #806 on: October 04, 2010, 02:34:26 AM »
Hi Bjoern
What kind of debug infos do you need?
i'll try to genearte it...

Greetings Frank

bloc

  • Guest
Re: TinyPortal
« Reply #807 on: October 04, 2010, 04:41:41 AM »
Hi Bjoern
What kind of debug infos do you need?
i'll try to genearte it...

Greetings Frank

Just exactly what the errors contain and what link it came from.

Offline FBy

  • Newbie
  • *
  • Posts: 5
Re: TinyPortal
« Reply #808 on: October 04, 2010, 05:58:41 AM »
Ok...
1.) The link: hxxp:www.url.de/forum/chat/index.php [nonactive] (thats what's behind the button)
2.) The Error: it appears inside the chat windows first line..
      Undefined index: show_download in /home/www/web221/html/forum/Sources/TPSubs.php on line 201




bloc

  • Guest
Re: TinyPortal
« Reply #809 on: October 04, 2010, 11:47:14 AM »
It sounds like an error that have been fixed for RC2, really.

Not sure why it comes up in the chat window, but since it uses AJAX it will prob. also fetch *some* TP routines in the process. We have to see if its better when RC2 comes out, which isn't so far away.

Offline FBy

  • Newbie
  • *
  • Posts: 5
Re: TinyPortal
« Reply #810 on: October 04, 2010, 11:52:47 AM »
So I'll be patient...  8)
and next time i won't try it in a live system  O:)

But anyway could you reconstruct my trouble with the Username/Avatar Problem?
it was a little bit weird to me .. because as i wrote already by down grading the "trouble disappeared...

and.. i have a wish...  :-*  ist it possible to show  the "users in chat" like in the Info Center also in the Users Online Block?

Thanks Frank

bloc

  • Guest
Re: TinyPortal
« Reply #811 on: October 04, 2010, 12:09:13 PM »
To show users from the chat you should be able to add the same code..but if its getting its data ONLY when you are on the boardindex, it will not work elsewhere. TP use SSI functions to fetch its online users everywhere, it isn't dependent upon being only on boardidnex. If the AJAX chat have a SSI routine, you could use that inside the TP online block.

The avatars error I have yet to look at, but I will check asap.

Offline agent47

  • Jr. Member
  • **
  • Posts: 394
  • Gender: Male
  • Death can strike at anyone, for the right price.
    • Superhero Alliance
Re: TinyPortal
« Reply #812 on: October 08, 2010, 06:24:20 AM »
Any significant changes (features-wise) in this version compared to your previous version which is "TinyPortal 1.0 beta 5.2" ??

PortaMx is probably the best SMF portal!

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: TinyPortal
« Reply #813 on: October 08, 2010, 09:49:38 AM »
No additional features, just bug fixes.
IchBin™        TinyPortal
Coding Guidelines       

Offline Goss

  • Jr. Member
  • **
  • Posts: 152
Re: TinyPortal
« Reply #814 on: October 13, 2010, 11:37:08 AM »
I set up tinyportal on a test forum and everything seems to be working great so far.  I'm just having an issue with the article system.  BBC articles written using the WYSIWYG editor don't seem to save any of the actual content.

Also, I went and had 3 article submissions to look over.  I deleted them all but the box on the left still says there are 3 articles in the submissions queue. 

Here's a link to my test forum: http://markedtest.elementfx.com/forum

I'm brand new to SMF so this might just be something I'm overlooking...but any help would be wonderful.

Offline BryanD

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 22,150
  • Gender: Male
Re: TinyPortal
« Reply #815 on: October 15, 2010, 06:30:51 PM »
Execute Modification     SMF2RC3/tinyportal200rc3.mod     Modification parse error

any ideas bloc, any possibility you make a .xml install and not a .mod install  :P
Former Project Manager and Customizer of SMF
Former Marketing and Vice-President of Simple Machines

Offline agridoc

  • SMF Hero
  • ******
  • Posts: 3,274
  • Gender: Male
    • Aeromodelling GR - Aeromodelling in Greece
Re: TinyPortal
« Reply #816 on: October 15, 2010, 11:32:40 PM »
I'm just having an issue with the article system.  BBC articles written using the WYSIWYG editor don't seem to save any of the actual content.

http://www.tinyportal.co.uk/index.php?topic=33274.msg266868#msg266868
Quote
There is a bug. To the moment, until it's fixed, copy the content then save. If not saved, paste the saved content, toggle the WYSIWYG editor, then save. To be able to save again you have to toggle again the WYSIWYG editor. WYSIWYG state doesn't affect save, only toggle before saving.
  For Greek aeromodellers and our friends around the world  - Greek Button sets for SMF - Greeklish to Greek mod
Δeν αφιερώνω χρόνο για μηνύματα σε greeklish.

Offline Roger Rabbit

  • Semi-Newbie
  • *
  • Posts: 77
Re: TinyPortal
« Reply #817 on: October 17, 2010, 06:48:48 AM »
Hi..Can anyone please help me with this installation problem:

Installing TinyPortal V1.0 RC1 for SMF 2.0 RC3..

Quote
Error in Package Installation
At least one error was encountered during a test installation of this package. It is strongly recommended that you do not continue with installation unless you know what you are doing, and have made a backup very recently. This error may be caused by a conflict between the package you're trying to install and another package you have already installed, an error in the package, a package which requires another package that you don't have installed yet, or a package designed for another version of SMF.

1. Extract Tree ./Themes 
 2. Extract Tree ./Themes 
 3. Extract Tree ./Sources 
 4. Extract Tree ./tp-downloads 
 5. Extract Tree ./tp-images 
 6. Extract Tree ./tp-files 
 7. Execute Modification SMF2RC3/tinyportal200rc3.mod Modification parse error
 8. Adapt Database SMF2RC3/tp_upgrade.php

I tried everything but i'm still receiving the same error...

Offline flutter

  • Jr. Member
  • **
  • Posts: 225
Re: TinyPortal
« Reply #818 on: October 18, 2010, 01:32:29 AM »
Just a couple of things I'm hoping you can help me with.  I'm more interested in the download function of this mod. 

Does it support more than one .rar.  That is can we add more then one .rar to a download?

Does is accept html in the download post?

and lastly, do I need to download all three files?  I'm setting up a test forum with 2.0 and want to give this a shot

Offline welshdog

  • Jr. Member
  • **
  • Posts: 128
  • Gender: Male
    • Australian Opinion
Re: TinyPortal
« Reply #819 on: October 18, 2010, 05:43:51 AM »
Brilliant update as usual. The Modules look fabulous and perform spectacularly well as usual.

One small quibble. I now see Avatars in the Shoutbox which makes it a little cramped. Is there any way to switch them off (just in the Shoutbox) please??

Otherwise... gobsmacked as usual!!  ;D